summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/gauche-gtk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/gauche-gtk')
-rw-r--r--dev-scheme/gauche-gtk/Manifest1
-rw-r--r--dev-scheme/gauche-gtk/files/gauche-gtk-0.4.1-gtk+-2.8.diff23
-rw-r--r--dev-scheme/gauche-gtk/files/gauche-gtk-gtk-lib.hints.diff71
-rw-r--r--dev-scheme/gauche-gtk/files/gauche-gtk-h2s-cpp.diff11
-rw-r--r--dev-scheme/gauche-gtk/files/gauche-gtk-h2s-gdk-pixbuf.diff23
-rw-r--r--dev-scheme/gauche-gtk/gauche-gtk-0.6_pre1.ebuild81
-rw-r--r--dev-scheme/gauche-gtk/metadata.xml16
7 files changed, 226 insertions, 0 deletions
diff --git a/dev-scheme/gauche-gtk/Manifest b/dev-scheme/gauche-gtk/Manifest
new file mode 100644
index 000000000000..fdb3ea507b10
--- /dev/null
+++ b/dev-scheme/gauche-gtk/Manifest
@@ -0,0 +1 @@
+DIST Gauche-gtk-0.6_pre1.tar.gz 203261 SHA256 cfe38221217519d3e6fe9bca6168938abe4801ec1a79a73f2f1b441cdc47dc0b
diff --git a/dev-scheme/gauche-gtk/files/gauche-gtk-0.4.1-gtk+-2.8.diff b/dev-scheme/gauche-gtk/files/gauche-gtk-0.4.1-gtk+-2.8.diff
new file mode 100644
index 000000000000..9734da949518
--- /dev/null
+++ b/dev-scheme/gauche-gtk/files/gauche-gtk-0.4.1-gtk+-2.8.diff
@@ -0,0 +1,23 @@
+diff -urN Gauche-gtk-0.4.1.orig/src/gtktexttag.stub Gauche-gtk-0.4.1/src/gtktexttag.stub
+--- Gauche-gtk-0.4.1.orig/src/gtktexttag.stub 2004-06-27 12:59:26.000000000 +0900
++++ Gauche-gtk-0.4.1/src/gtktexttag.stub 2006-10-30 17:53:25.039657000 +0900
+@@ -36,7 +36,6 @@
+ (language-set :type <uint>)
+ (pad1 :type <uint>)
+ (pad2 :type <uint>)
+- (pad3 :type <uint>)
+ )
+ (allocator (c "Scm_GtkObjectAllocate"))
+ )
+diff -urN Gauche-gtk-0.4.1.orig/src/gtktoolbar.stub Gauche-gtk-0.4.1/src/gtktoolbar.stub
+--- Gauche-gtk-0.4.1.orig/src/gtktoolbar.stub 2004-06-27 12:59:26.000000000 +0900
++++ Gauche-gtk-0.4.1/src/gtktoolbar.stub 2006-10-30 18:16:32.889657000 +0900
+@@ -51,8 +51,6 @@
+ (tooltips :type <gtk-tooltips>)
+ (button-maxw :type <int>)
+ (button-maxh :type <int>)
+- (style-set-connection :type <uint>)
+- (icon-size-connection :type <uint>)
+ (style-set :type <uint>)
+ (icon-size-set :type <uint>)
+ )
diff --git a/dev-scheme/gauche-gtk/files/gauche-gtk-gtk-lib.hints.diff b/dev-scheme/gauche-gtk/files/gauche-gtk-gtk-lib.hints.diff
new file mode 100644
index 000000000000..be54ee550ba7
--- /dev/null
+++ b/dev-scheme/gauche-gtk/files/gauche-gtk-gtk-lib.hints.diff
@@ -0,0 +1,71 @@
+--- a/src/gtk-lib.hints
++++ b/src/gtk-lib.hints
+@@ -527,8 +527,10 @@ SCM_RETURN(Scm_Values2(Scm_MakeInteger(n_properties), h));"
+ (add-mixin! "Scm_GtkEditableClass" "Scm_GtkCellEditableClass"))
+
+ ;; we can't free the return value of gtk_entry_get_text.
+-(define-cproc gtk-entry-get-text (entry::<gtk-entry>)
+- "SCM_RETURN(SCM_MAKE_STR_COPYING(gtk_entry_get_text(entry)));")
++(define-cproc-fix gtk-entry-get-text
++ (fix-arguments! '(entry::<gtk-entry>))
++ (fix-body!
++ "SCM_RETURN(SCM_MAKE_STR_COPYING(gtk_entry_get_text(entry)));"))
+
+ ;;==================================================================
+ ;; gtkfilesel.h
+@@ -539,8 +541,10 @@ SCM_RETURN(Scm_Values2(Scm_MakeInteger(n_properties), h));"
+ ;; gtk_file_selection_get_filename returns mbstr encoded by the current
+ ;; locale. We canonicalize it to utf8. The Scheme glue code converts
+ ;; it to Gauche's internal encoding.
+-(define-cproc gtk-file-selection-get-filename (sel::<gtk-file-selection>)
+- "const gchar *fn_mb = gtk_file_selection_get_filename(sel);
++(define-cproc-fix gtk-file-selection-get-filename
++ (fix-arguments! '(sel::<gtk-file-selection>))
++ (fix-body!
++ "const gchar *fn_mb = gtk_file_selection_get_filename(sel);
+ gchar *fn_utf8 = g_filename_to_utf8(fn_mb, -1, NULL, NULL, NULL);
+ if (fn_utf8 == NULL) {
+ Scm_Error(\"got a filename including multibyte chars which can't be converted to UTF8: %s\", fn_mb);
+@@ -549,7 +553,7 @@ SCM_RETURN(Scm_Values2(Scm_MakeInteger(n_properties), h));"
+ SCM_RETURN(SCM_MAKE_STR_COPYING(fn_utf8));
+ #else
+ SCM_RETURN(Scm_MakeString(fn_utf8, -1, -1, SCM_MAKSTR_COPYING|SCM_MAKSTR_INCOMPLETE));
+-#endif")
++#endif"))
+
+ (define-cproc gtk-file-selection-get-selections (sel::<gtk-file-selection>)
+ "gchar **fns_mb = gtk_file_selection_get_selections(sel);
+@@ -609,10 +613,14 @@ SCM_RETURN(Scm_Values2(Scm_MakeInteger(n_properties), h));"
+ (input-file "gtklabel.h")
+
+ ;; Memory is owned by the widget so we don't need to free them.
+-(define-cproc gtk-label-get-text (label::<gtk-label>)
+- "SCM_RETURN(SCM_MAKE_STR_COPYING(gtk_label_get_text(label)));")
+-(define-cproc gtk-label-get-label (label::<gtk-label>)
+- "SCM_RETURN(SCM_MAKE_STR_COPYING(gtk_label_get_label(label)));")
++(define-cproc-fix gtk-label-get-text
++ (fix-arguments! '(label::<gtk-label>))
++ (fix-body!
++ "SCM_RETURN(SCM_MAKE_STR_COPYING(gtk_label_get_text(label)));"))
++(define-cproc-fix gtk-label-get-label
++ (fix-arguments! '(label::<gtk-label>))
++ (fix-body!
++ "SCM_RETURN(SCM_MAKE_STR_COPYING(gtk_label_get_label(label)));"))
+
+ (define-cproc-fix gtk-label-get-seleciton-bounds
+ (fix-arguments! '(label::<gtk-label>))
+@@ -1121,9 +1129,11 @@ return SCM_MAKE_STR_COPYING((char*)string);"))
+
+ (input-file "gtkprogressbar.h")
+
+-(define-cproc gtk-progress-bar-get-text (pbar::<gtk-progress-bar>)
+- "gchar *g = gtk_progress_bar_get_text(pbar);
+- SCM_RETURN(SCM_MAKE_STR_COPYING_SAFELY(g));")
++(define-cproc-fix gtk-progress-bar-get-text
++ (fix-arguments! '(pbar::<gtk-progress-bar>))
++ (fix-body!
++ "gchar *g = gtk_progress_bar_get_text(pbar);
++ SCM_RETURN(SCM_MAKE_STR_COPYING_SAFELY(g));"))
+
+ ;;==================================================================
+ ;; gtkradiobutton
diff --git a/dev-scheme/gauche-gtk/files/gauche-gtk-h2s-cpp.diff b/dev-scheme/gauche-gtk/files/gauche-gtk-h2s-cpp.diff
new file mode 100644
index 000000000000..081c83df1fe5
--- /dev/null
+++ b/dev-scheme/gauche-gtk/files/gauche-gtk-h2s-cpp.diff
@@ -0,0 +1,11 @@
+--- a/lib/h2s/parse.scm
++++ b/lib/h2s/parse.scm
+@@ -329,6 +329,8 @@
+ (#/^\}\s*([\w_]+)/ (#f name) (make-enum name (reverse enums))) ; ----->
+ ;; empty line:
+ (#/^\s*$/ () (loop (read-line) enums))
++ ;; preprocessor directive:
++ (#/^\s*#\s*\w+/ () (loop (read-line) enums))
+ ;;
+ (test has-comment? (skip-comment line (cut loop <> enums) err-eof)) ; what if?: new_value, /* boring comment*/
+ (#/\s+([\w_]+),?/ (#f enum)
diff --git a/dev-scheme/gauche-gtk/files/gauche-gtk-h2s-gdk-pixbuf.diff b/dev-scheme/gauche-gtk/files/gauche-gtk-h2s-gdk-pixbuf.diff
new file mode 100644
index 000000000000..9e8bbcf6e72d
--- /dev/null
+++ b/dev-scheme/gauche-gtk/files/gauche-gtk-h2s-gdk-pixbuf.diff
@@ -0,0 +1,23 @@
+--- a/src/h2s-gtk.scm
++++ b/src/h2s-gtk.scm
+@@ -50,6 +50,11 @@
+ (define pango-directory
+ (find-header-dir #`"pango-,|pango-version|/pango/pango.h"
+ *header-search-paths*))
++(define gdk-pixbuf-directory
++ (guard (e [(<error> e)
++ gtk-directory])
++ (find-header-dir #`"gdk-pixbuf-,|gtk-version|/gdk-pixbuf/gdk-pixbuf.h"
++ *header-search-paths* )))
+
+
+ (define (parse-gdk)
+@@ -64,7 +69,7 @@
+ (call-with-input-file "PANGOFILES" port->string-list)))
+
+ (define (parse-gdk-pixbuf)
+- (parse-headers #`",|gtk-directory|/gdk-pixbuf"
++ (parse-headers #`",|gdk-pixbuf-directory|/gdk-pixbuf"
+ (call-with-input-file "GDKPIXBUFFILES" port->string-list)))
+
+ ;; defaults for the gauche-gtk package:
diff --git a/dev-scheme/gauche-gtk/gauche-gtk-0.6_pre1.ebuild b/dev-scheme/gauche-gtk/gauche-gtk-0.6_pre1.ebuild
new file mode 100644
index 000000000000..f5fc57aba157
--- /dev/null
+++ b/dev-scheme/gauche-gtk/gauche-gtk-0.6_pre1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools eutils
+
+MY_P="${P/g/G}"
+MY_PN="${PN/g/G}2"
+PV_COMMIT="598828842a339a44c32ab8c16f5f9a77f3c1c799"
+
+DESCRIPTION="GTK2 binding for Gauche"
+HOMEPAGE="http://practical-scheme.net/gauche/"
+SRC_URI="https://github.com/shirok/${MY_PN}/tarball/${PV_COMMIT} -> ${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE="examples glgd nls opengl"
+RESTRICT="test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="x11-libs/gtk+:2
+ dev-scheme/gauche
+ opengl? (
+ x11-libs/gtkglext
+ dev-scheme/gauche-gl
+ )"
+S="${WORKDIR}/shirok-${MY_PN}-${PV_COMMIT:0:7}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-h2s-gdk-pixbuf.diff
+ epatch "${FILESDIR}"/${PN}-gtk-lib.hints.diff
+ epatch "${FILESDIR}"/${PN}-h2s-cpp.diff
+ eautoconf
+}
+
+src_configure() {
+ local myconf
+ if use opengl; then
+ if use glgd; then
+ myconf="--enable-glgd"
+ if use nls; then
+ myconf="${myconf}-pango"
+ fi
+ else
+ myconf="--enable-gtkgl"
+ fi
+ fi
+
+ econf ${myconf}
+}
+
+src_compile() {
+ emake stubs
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc examples/*.scm
+ # install gtk-tutorial
+ docinto examples/gtk-tutorial
+ dodoc examples/gtk-tutorial/*
+ if use opengl; then
+ # install gtkglext
+ dodoc -r examples/gtkglext
+ if use glgd; then
+ # install glgd
+ dodoc -r examples/glgd
+ fi
+ fi
+ fi
+}
diff --git a/dev-scheme/gauche-gtk/metadata.xml b/dev-scheme/gauche-gtk/metadata.xml
new file mode 100644
index 000000000000..decd5434e1a4
--- /dev/null
+++ b/dev-scheme/gauche-gtk/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Gauche extension module to use GTK.
+ </longdescription>
+ <use>
+ <flag name="glgd">Enable GL graph draw</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">shirok/Gauche-gtk2</remote-id>
+ </upstream>
+</pkgmetadata>