summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/scmxlate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/scmxlate')
-rw-r--r--dev-scheme/scmxlate/Manifest1
-rw-r--r--dev-scheme/scmxlate/metadata.xml13
-rw-r--r--dev-scheme/scmxlate/scmxlate-20090410.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-scheme/scmxlate/Manifest b/dev-scheme/scmxlate/Manifest
new file mode 100644
index 000000000000..a52b388552d9
--- /dev/null
+++ b/dev-scheme/scmxlate/Manifest
@@ -0,0 +1 @@
+DIST scmxlate-20090410.tar.bz2 30016 SHA256 78fd2155dab925f1b47e36a57c55e6a322397737063aed1945b2da9325ae7cf6 SHA512 c6148a1c928ff326c5ac5442a0843a334645d76bb17a48d32018807a2dfa2a4147acfaf43866996d4b06fbe0e6723280da7e66576a3c7c18d70f8e75c73954af WHIRLPOOL 7a95f6f3698900ad87a0ba0a4aff3c5575bb2b7de1d52f4d26eb4db89ef1813095a12bf118df2f0b61d27077d73ec60efd120af5ff89e8ba339d57c5facb3759
diff --git a/dev-scheme/scmxlate/metadata.xml b/dev-scheme/scmxlate/metadata.xml
new file mode 100644
index 000000000000..b8be9f4a7dcf
--- /dev/null
+++ b/dev-scheme/scmxlate/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>scheme</herd>
+ <maintainer>
+ <email>hkBst@gentoo.org</email>
+ <name>Marijn Schouten</name>
+ </maintainer>
+ <longdescription lang="en">
+Scmxlate is a configuration tool for software packages written in Scheme.
+Scmxlate provides the package author with a strategy for programmatically specifying the changes required to translate the package for a variety of Scheme dialects and Common Lisp, and a variety of operating systems. The end-user simply loads one file into their Scheme or Common Lisp, which triggers the entire configuration process with little or no further intervention.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-scheme/scmxlate/scmxlate-20090410.ebuild b/dev-scheme/scmxlate/scmxlate-20090410.ebuild
new file mode 100644
index 000000000000..3411ad2f47ba
--- /dev/null
+++ b/dev-scheme/scmxlate/scmxlate-20090410.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="Scmxlate is a configuration tool for software packages written in Scheme"
+HOMEPAGE="http://www.ccs.neu.edu/home/dorai/scmxlate/scmxlate.html"
+SRC_URI="http://evalwhen.com/scmxlate/scmxlate.tar.bz2
+ -> ${P}.tar.bz2"
+
+LICENSE="freedist" # license doesn't grant the right for modifications
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_compile() { true; }
+
+src_install() {
+ insinto /usr/share/${PN}/
+ doins *.cl *.scm || die "doins failed"
+ dodoc README || die "dodoc failed"
+}