summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/ypsilon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/ypsilon')
-rw-r--r--dev-scheme/ypsilon/Manifest1
-rw-r--r--dev-scheme/ypsilon/files/ypsilon-0.9.6_p3-asneeded.patch11
-rw-r--r--dev-scheme/ypsilon/metadata.xml10
-rw-r--r--dev-scheme/ypsilon/ypsilon-0.9.6_p3.ebuild40
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-scheme/ypsilon/Manifest b/dev-scheme/ypsilon/Manifest
new file mode 100644
index 000000000000..122d553f250f
--- /dev/null
+++ b/dev-scheme/ypsilon/Manifest
@@ -0,0 +1 @@
+DIST ypsilon-0.9.6.update3.tar.gz 4555843 SHA256 2ca3c901dc3f6bca857a94a9d991d14ecc12727d2833694f0e4f5aa1a8a4064d SHA512 9ea5e3e70481c538bcaf671feb7f764015fb44702bcec4e2873007e065bf48d7d9b0cfc8f9dcc51e0083b0bf5296fd8ac40a1f851d76019a18b21fa7e292ee89 WHIRLPOOL ab3f341a27b00f0f8d688adfe17c66a38125c2e4a4a62d622070299283cd27526d6a41c0e5fd61a85e38a0c0aac0e142b0597e1a7475d5d9b060634de315db0a
diff --git a/dev-scheme/ypsilon/files/ypsilon-0.9.6_p3-asneeded.patch b/dev-scheme/ypsilon/files/ypsilon-0.9.6_p3-asneeded.patch
new file mode 100644
index 000000000000..4769fce6c25c
--- /dev/null
+++ b/dev-scheme/ypsilon/files/ypsilon-0.9.6_p3-asneeded.patch
@@ -0,0 +1,11 @@
+--- ypsilon-0.9.6.update3.orig/Makefile 2008-12-23 09:56:02.000000000 +0100
++++ ypsilon-0.9.6.update3/Makefile 2009-10-21 18:14:37.613881129 +0200
+@@ -126,7 +126,7 @@
+ @mkdir -p -m755 $(HOME)/.ypsilon
+
+ $(PROG): $(OBJS)
+- $(CXX) $(LDFLAGS) $(LDLIBS) -o $@ $^
++ $(CXX) $(LDFLAGS) -o $@ $^ $(LDLIBS)
+
+ vm1.s: vm1.cpp
+ $(CXX) $(CXXFLAGS) $(CPPFLAGS) \
diff --git a/dev-scheme/ypsilon/metadata.xml b/dev-scheme/ypsilon/metadata.xml
new file mode 100644
index 000000000000..993379f14f74
--- /dev/null
+++ b/dev-scheme/ypsilon/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>scheme</herd>
+ <longdescription lang="en">Ypsilon is the implementation of Scheme Programming Language, which conforms
+ to the latest standard R6RS.</longdescription>
+ <upstream>
+ <remote-id type="google-code">ypsilon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-scheme/ypsilon/ypsilon-0.9.6_p3.ebuild b/dev-scheme/ypsilon/ypsilon-0.9.6_p3.ebuild
new file mode 100644
index 000000000000..6b7bcbf8b28f
--- /dev/null
+++ b/dev-scheme/ypsilon/ypsilon-0.9.6_p3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P="${P/_p/.update}"
+DESCRIPTION="R6RS-compliant Scheme implementation for real-time applications"
+HOMEPAGE="http://code.google.com/p/ypsilon/"
+SRC_URI="http://ypsilon.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples threads"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
+src_compile() {
+ use threads && append-flags "-pthread"
+
+ emake PREFIX="/usr" CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" LDFLAGS="$LDFLAGS" || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install || die "Install failed"
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins example/* || die "Failed to install examples"
+ fi
+}