summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-14 23:15:51 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-14 23:15:51 +0100
commit650424f5e96800b0c02ef32d64d5bb021ad7a4a7 (patch)
treed4e488fbc3e1277e0c9df97d783bd683e141a0f0 /dev-scheme
parentdev-lang/go: 1.13.5 bump (diff)
downloadgentoo-650424f5e96800b0c02ef32d64d5bb021ad7a4a7.tar.gz
gentoo-650424f5e96800b0c02ef32d64d5bb021ad7a4a7.tar.bz2
gentoo-650424f5e96800b0c02ef32d64d5bb021ad7a4a7.zip
dev-scheme/elk: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/elk/elk-3.99.8.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/dev-scheme/elk/elk-3.99.8.ebuild b/dev-scheme/elk/elk-3.99.8.ebuild
index 991a0ed09213..a9e62f4c49fe 100644
--- a/dev-scheme/elk/elk-3.99.8.ebuild
+++ b/dev-scheme/elk/elk-3.99.8.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
DESCRIPTION="Scheme implementation designed to be embeddable extension to C/C++ applications"
HOMEPAGE="http://sam.zoy.org/elk"
SRC_URI="http://sam.zoy.org/elk/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-DEPEND=""
+src_configure() {
+ econf --disable-static
+}
src_compile() {
# parallel build is broken
@@ -26,5 +27,13 @@ src_test() {
src_install() {
# parallel install is broken
- emake -j1 DESTDIR="${D}" install
+ emake -j1 DESTDIR="${D}" \
+ docsdir="${EPREFIX}"/usr/share/doc/${PF} \
+ examplesdir="${EPREFIX}"/usr/share/doc/${PF}/examples \
+ install
+ einstalldocs
+ docompress -x /usr/share/doc/${PF}
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}