summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/ck
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/ck')
-rw-r--r--dev-tcltk/ck/Manifest2
-rw-r--r--dev-tcltk/ck/ck-8.0-r4.ebuild49
-rw-r--r--dev-tcltk/ck/files/ck-8.0-gentoo.patch133
-rw-r--r--dev-tcltk/ck/metadata.xml5
4 files changed, 189 insertions, 0 deletions
diff --git a/dev-tcltk/ck/Manifest b/dev-tcltk/ck/Manifest
new file mode 100644
index 000000000000..b07e307c126e
--- /dev/null
+++ b/dev-tcltk/ck/Manifest
@@ -0,0 +1,2 @@
+DIST ck-8.0-tcl8.6.patch.xz 12836 SHA256 e414eb16f1905738474e2d1c773c369c54a219ede311289e1edbe1a22c53116b SHA512 55682b9490ac5470ef14213f0dac3fa10139a13a7e3d915773c50285038b3b566c140fcc5f4721a091744e45bbef405c2ee3ee22daf71a3a82148acba28b0dde WHIRLPOOL d5317abce4eaf875b9980a9e2051465df1f3a70b1edb764632623784a287d8096e36c4cf8b42a7d5f879a822dc9e273215ba438f1b865fb7a62b5bc1e2cc0147
+DIST ck8.0.tar.gz 400262 SHA256 11588244fcbbb1e19658357194ade5ad3877e6315a04530e6a41c18ee99babdf SHA512 68d92be354e5ec24830cc9a20d1cbb5a27d4e04369ceecf6fdad7759da3d9b4909970bf54abdf5f5b015fd0d08b8680a33cdcdf468b9007afc21e69c7381b262 WHIRLPOOL 69926cee3b4879d47f762425ca39ca08ca9bad2021162b7540af1edd1770fa4eeafe2e5be0c923787945779c7fc92cb7a168fe160bc75151b56182c45092f4cd
diff --git a/dev-tcltk/ck/ck-8.0-r4.ebuild b/dev-tcltk/ck/ck-8.0-r4.ebuild
new file mode 100644
index 000000000000..359cc40aa61c
--- /dev/null
+++ b/dev-tcltk/ck/ck-8.0-r4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+MY_P=${PN}${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A curses based toolkit for tcl"
+HOMEPAGE="http://www.ch-werner.de/ck/"
+SRC_URI="
+ http://www.ch-werner.de/ck/${MY_P}.tar.gz
+ http://dev.gentoo.org/~jlec/distfiles/${P}-tcl8.6.patch.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/tk
+ sys-libs/ncurses[gpm]
+ sys-libs/gpm
+ "
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${WORKDIR}"/${P}-tcl8.6.patch
+ sed \
+ -e "/^LIB_INSTALL_DIR/s:lib$:$(get_libdir):g" \
+ -i Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)" \
+ --enable-shared
+}
+
+src_compile() {
+ emake \
+ CURSES_LIB_SWITCHES="$($(tc-getPKG_CONFIG) --libs ncursesw) -lgpm"
+}
diff --git a/dev-tcltk/ck/files/ck-8.0-gentoo.patch b/dev-tcltk/ck/files/ck-8.0-gentoo.patch
new file mode 100644
index 000000000000..727f7e8b5356
--- /dev/null
+++ b/dev-tcltk/ck/files/ck-8.0-gentoo.patch
@@ -0,0 +1,133 @@
+ Makefile.in | 40 ++++++++++++++++------------------------
+ 1 files changed, 16 insertions(+), 24 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 00960d9..16d4123 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -29,9 +29,9 @@ exec_prefix = @exec_prefix@
+ # The following definition can be set to non-null for special systems
+ # like AFS with replication. It allows the pathnames used for installation
+ # to be different than those used for actually reference files at
+-# run-time. INSTALL_ROOT is prepended to $prefix and $exec_prefix
++# run-time. DESTDIR is prepended to $prefix and $exec_prefix
+ # when installing files.
+-INSTALL_ROOT =
++DESTDIR =
+
+ # Directory from which applications will reference the library of Tcl
+ # scripts (note: you can set the CK_LIBRARY environment variable at
+@@ -39,22 +39,22 @@ INSTALL_ROOT =
+ CK_LIBRARY = $(prefix)/lib/ck$(VERSION)
+
+ # Path name to use when installing library scripts:
+-SCRIPT_INSTALL_DIR = $(INSTALL_ROOT)$(CK_LIBRARY)
++SCRIPT_INSTALL_DIR = $(DESTDIR)$(CK_LIBRARY)
+
+ # Directory in which to install the archive libck*:
+-LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
++LIB_INSTALL_DIR = $(DESTDIR)$(exec_prefix)/lib
+
+ # Directory in which to install the program cwsh:
+-BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
++BIN_INSTALL_DIR = $(DESTDIR)$(exec_prefix)/bin
+
+ # Directory from which the program cwsh should be referenced by scripts:
+ BIN_DIR = $(exec_prefix)/bin
+
+ # Directory in which to install the include file ck.h:
+-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
++INCLUDE_INSTALL_DIR = $(DESTDIR)$(prefix)/include
+
+ # Top-level directory for manual entries:
+-MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
++MAN_INSTALL_DIR = $(DESTDIR)$(prefix)/share/man
+
+ # Directory in which to install manual entry for cwsh:
+ MAN1_INSTALL_DIR = $(MAN_INSTALL_DIR)/man1
+@@ -96,7 +96,7 @@ LIBS = @TCL_BUILD_LIB_SPEC@ @LIBS@ $(CURSES_LIB_SWITCHES) @DL_LIBS@ @MATH_LIBS@
+
+ # To change the compiler switches, for example to change from -O
+ # to -g, change the following line:
+-CFLAGS = -O
++#CFLAGS = -O
+
+ # To disable ANSI-C procedure prototypes reverse the comment characters
+ # on the following lines:
+@@ -231,14 +231,14 @@ configInfo: Makefile
+ @echo "CK_CURSES_INCLUDES = ${CURSES_INCLUDES}" >> configInfo
+ @echo "CK_LIBS = ${CURSES_LIB_SWITCHES} @LIBS@" >> configInfo
+
+-install: install-binaries install-libraries
++install: install-man install-binaries install-libraries
+
+ install-binaries: $(CK_LIB_FILE) cwsh
+ @for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
+ do \
+ if [ ! -d $$i ] ; then \
+ echo "Making directory $$i"; \
+- mkdir $$i; \
++ mkdir -p $$i; \
+ chmod 755 $$i; \
+ else true; \
+ fi; \
+@@ -251,12 +251,12 @@ install-binaries: $(CK_LIB_FILE) cwsh
+ @$(INSTALL_PROGRAM) cwsh $(BIN_INSTALL_DIR)/cwsh
+
+ install-libraries:
+- @for i in $(INSTALL_ROOT)$(prefix)/lib $(INCLUDE_INSTALL_DIR) \
++ @for i in $(DESTDIR)$(prefix)/lib $(INCLUDE_INSTALL_DIR) \
+ $(SCRIPT_INSTALL_DIR) ; \
+ do \
+ if [ ! -d $$i ] ; then \
+ echo "Making directory $$i"; \
+- mkdir $$i; \
++ mkdir -p $$i; \
+ chmod 755 $$i; \
+ else true; \
+ fi; \
+@@ -270,13 +270,13 @@ install-libraries:
+ done;
+
+ install-demos:
+- @for i in $(INSTALL_ROOT)$(prefix)/lib $(SCRIPT_INSTALL_DIR) \
++ @for i in $(DESTDIR)$(prefix)/lib $(SCRIPT_INSTALL_DIR) \
+ $(SCRIPT_INSTALL_DIR)/demos \
+ $(SCRIPT_INSTALL_DIR)/demos/images ; \
+ do \
+ if [ ! -d $$i ] ; then \
+ echo "Making directory $$i"; \
+- mkdir $$i; \
++ mkdir -p $$i; \
+ chmod 755 $$i; \
+ else true; \
+ fi; \
+@@ -301,11 +301,11 @@ install-demos:
+ done;
+
+ install-man:
+- @for i in $(MAN_INSTALL_DIR) $(MAN1_INSTALL_DIR) $(MAN3_INSTALL_DIR) $(MANN_INSTALL_DIR) ; \
++ @for i in $(MAN_INSTALL_DIR) $(MAN1_INSTALL_DIR) $(MAN3_INSTALL_DIR); \
+ do \
+ if [ ! -d $$i ] ; then \
+ echo "Making directory $$i"; \
+- mkdir $$i; \
++ mkdir -p $$i; \
+ chmod 755 $$i; \
+ else true; \
+ fi; \
+@@ -326,14 +326,6 @@ install-man:
+ $$i > $(MAN3_INSTALL_DIR)/$$i; \
+ chmod 444 $(MAN3_INSTALL_DIR)/$$i; \
+ done;
+- @cd $(SRC_DIR)/doc; for i in *.n; \
+- do \
+- echo "Installing doc/$$i"; \
+- rm -f $(MANN_INSTALL_DIR)/$$i; \
+- sed -e '/man\.macros/r man.macros' -e '/man\.macros/d' \
+- $$i > $(MANN_INSTALL_DIR)/$$i; \
+- chmod 444 $(MANN_INSTALL_DIR)/$$i; \
+- done;
+
+ Makefile: $(SRC_DIR)/Makefile.in
+ $(SHELL) config.status
diff --git a/dev-tcltk/ck/metadata.xml b/dev-tcltk/ck/metadata.xml
new file mode 100644
index 000000000000..70ac40499556
--- /dev/null
+++ b/dev-tcltk/ck/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+</pkgmetadata>