summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/pdfannotextractor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/pdfannotextractor')
-rw-r--r--dev-tex/pdfannotextractor/Manifest1
-rw-r--r--dev-tex/pdfannotextractor/files/javajars.patch13
-rw-r--r--dev-tex/pdfannotextractor/metadata.xml5
-rw-r--r--dev-tex/pdfannotextractor/pdfannotextractor-0.1l.ebuild52
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-tex/pdfannotextractor/Manifest b/dev-tex/pdfannotextractor/Manifest
new file mode 100644
index 000000000000..f851c780bf81
--- /dev/null
+++ b/dev-tex/pdfannotextractor/Manifest
@@ -0,0 +1 @@
+DIST pdfannotextractor-0.1l.zip 48496 SHA256 e57e5fdb844bb74f8bf99b0ccd199db7ad2f7c1d11fe48b0b14ec81b7a28f66f SHA512 043a12545889cbdf9309024bcb381a70eef6ac1c1a3214d678b606c97102dde6cfd473fbd8057f9ed7badebd0fc85db0ce0e05f361a71f8b8c3f71e523f8beba WHIRLPOOL 611cfa374c3833707b71c14bfc8a75d82ff6ae394c99cabc6ddee1a3aade3aedede15921bdcf9a98b16df415cb49ae819dc0911aa5a550764795b1be1b4ce54d
diff --git a/dev-tex/pdfannotextractor/files/javajars.patch b/dev-tex/pdfannotextractor/files/javajars.patch
new file mode 100644
index 000000000000..bc52050e7b06
--- /dev/null
+++ b/dev-tex/pdfannotextractor/files/javajars.patch
@@ -0,0 +1,13 @@
+Index: work/scripts/pax/pdfannotextractor.pl
+===================================================================
+--- work.orig/scripts/pax/pdfannotextractor.pl
++++ work/scripts/pax/pdfannotextractor.pl
+@@ -84,6 +84,8 @@ my @jar_pdfbox = qw[
+ PDFBox-0.7.2.jar
+ ];
+ my @dir_jar = qw[
++ /usr/share/pdfannotextractor/lib
++ /usr/share/pdfbox/lib
+ /usr/share/java
+ /usr/local/share/java
+ ];
diff --git a/dev-tex/pdfannotextractor/metadata.xml b/dev-tex/pdfannotextractor/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/dev-tex/pdfannotextractor/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>
diff --git a/dev-tex/pdfannotextractor/pdfannotextractor-0.1l.ebuild b/dev-tex/pdfannotextractor/pdfannotextractor-0.1l.ebuild
new file mode 100644
index 000000000000..3691bb94f5bc
--- /dev/null
+++ b/dev-tex/pdfannotextractor/pdfannotextractor-0.1l.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit latex-package java-utils-2 java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Extract annotations from pdf files"
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/pax/"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x64-macos"
+IUSE=""
+
+CDEPEND="virtual/latex-base
+ dev-java/pdfbox
+ dev-java/fontbox"
+DEPEND="${CDEPEND}
+ app-arch/unzip
+ >=virtual/jdk-1.5"
+RDEPEND="${CDEPEND}
+ virtual/perl-Getopt-Long
+ dev-perl/File-Which
+ >=virtual/jre-1.5
+ !<=dev-texlive/texlive-latexextra-2010"
+
+TEXMF=/usr/share/texmf-site
+S=${WORKDIR}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="pdfbox fontbox"
+
+src_prepare() {
+ epatch "${FILESDIR}/javajars.patch"
+ java-pkg-2_src_prepare
+}
+
+src_compile() {
+ cd "${S}/source/latex/pax"
+ eant || die
+}
+
+src_install() {
+ newbin scripts/pax/pdfannotextractor.pl pdfannotextractor || die
+ java-pkg_dojar "${S}/source/latex/pax/pax.jar" || die
+ insinto ${TEXMF}
+ doins -r tex || die
+ dodoc doc/latex/pax/README || die
+}