summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/ppower4
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/ppower4')
-rw-r--r--dev-tex/ppower4/Manifest1
-rw-r--r--dev-tex/ppower4/files/ppower4-gentoo.patch11
-rw-r--r--dev-tex/ppower4/metadata.xml5
-rw-r--r--dev-tex/ppower4/ppower4-0.9.6.ebuild47
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-tex/ppower4/Manifest b/dev-tex/ppower4/Manifest
new file mode 100644
index 000000000000..08c64120c338
--- /dev/null
+++ b/dev-tex/ppower4/Manifest
@@ -0,0 +1 @@
+DIST ppower4-0.9.6.tar.gz 379282 SHA256 92602c3f31c925ee37dbde7a7639e8d74e52c1e6087874d8cde7eb9516c4a3a2 SHA512 edade748c33006a20535a663904adccfd8196eb96bcd963d3512a4e416e2747231101756396af7b4eb2395c4bfa1338b73fd77bb1c1e9addfcf57cf8d0beadcd WHIRLPOOL 900ea951bd33cd505807eccf444a1ca944eebfef53da1bdae48dbb60fbec5d8d060642d70b6c38110bd12919a6be29c565843239773136e825e579877a5c0749
diff --git a/dev-tex/ppower4/files/ppower4-gentoo.patch b/dev-tex/ppower4/files/ppower4-gentoo.patch
new file mode 100644
index 000000000000..f9afa86a9bdb
--- /dev/null
+++ b/dev-tex/ppower4/files/ppower4-gentoo.patch
@@ -0,0 +1,11 @@
+--- ppower4 2003-08-16 19:43:09.000000000 +0200
++++ ppower4 2003-08-16 19:46:24.000000000 +0200
+@@ -14,7 +14,7 @@
+ # Modify this script such that jarfile contains the full path
+ # of the pp4p.jar file.
+ #
+-jarfile=/common/Java/lib/ppower4/pp4p.jar
++jarfile=/usr/lib/ppower4/pp4p.jar
+ #
+ # If you use a web2c distribution, you can place pp4p.jar
+ # e.g. into the directory texmf/java/ppower4, run mktexlsr,
diff --git a/dev-tex/ppower4/metadata.xml b/dev-tex/ppower4/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/dev-tex/ppower4/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>
diff --git a/dev-tex/ppower4/ppower4-0.9.6.ebuild b/dev-tex/ppower4/ppower4-0.9.6.ebuild
new file mode 100644
index 000000000000..fe66458205d9
--- /dev/null
+++ b/dev-tex/ppower4/ppower4-0.9.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit latex-package eutils
+
+DESCRIPTION="Post-process presentations in PDF format which were prepared using (La)TeX to add dynamic effects"
+
+# Taken from:
+#SRC_URI="http://www.tex.ac.uk/tex-archive/support/ppower4/pp4sty.zip
+# http://www.tex.ac.uk/tex-archive/support/ppower4/pp4p.jar
+# http://www.tex.ac.uk/tex-archive/support/ppower4/ppower4
+# http://www.tex.ac.uk/tex-archive/support/ppower4/manual.pdf"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+HOMEPAGE="http://www.tex.ac.uk/tex-archive/support/ppower4/index.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc x86"
+
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}
+ virtual/jre"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+ unzip pp4sty.zip
+
+ epatch "${FILESDIR}/${PN}-gentoo.patch"
+}
+
+src_install() {
+
+ latex-package_src_install || die
+
+ dobin ppower4
+
+ insinto /usr/lib/${PN}
+ doins pp4p.jar
+
+ insinto /usr/share/doc/${PF}
+ doins manual.pdf
+}