summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/rubber
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/rubber')
-rw-r--r--dev-tex/rubber/Manifest1
-rw-r--r--dev-tex/rubber/metadata.xml5
-rw-r--r--dev-tex/rubber/rubber-1.1_p20090819.ebuild45
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-tex/rubber/Manifest b/dev-tex/rubber/Manifest
new file mode 100644
index 000000000000..94b2f8be0309
--- /dev/null
+++ b/dev-tex/rubber/Manifest
@@ -0,0 +1 @@
+DIST rubber-20090819.tar.gz 87066 SHA256 f271971a282a9aeed179dd510410be8ac4e3f324312d1367fdca0018a14d89c7 SHA512 7ce37f37406c88172195e738f860fe32b81a9e88026526aa5f2f765eed94205507972ccff11fbe9248c5b93d7f37a3e532089806983711e5dfa72cf5a97a6115 WHIRLPOOL 38a27d408607480b0ae73c3da690f39b49781ef1c71cc666c9c4d532b637136aa357876da5216f0632a580526c2212e3da43bb22cec9c6745d5a53f7d811bb88
diff --git a/dev-tex/rubber/metadata.xml b/dev-tex/rubber/metadata.xml
new file mode 100644
index 000000000000..21ff3a538481
--- /dev/null
+++ b/dev-tex/rubber/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+</pkgmetadata>
diff --git a/dev-tex/rubber/rubber-1.1_p20090819.ebuild b/dev-tex/rubber/rubber-1.1_p20090819.ebuild
new file mode 100644
index 000000000000..9892b139a286
--- /dev/null
+++ b/dev-tex/rubber/rubber-1.1_p20090819.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit distutils
+
+IUSE=""
+
+MY_P=${PN}-${PV/*_p/}
+
+DESCRIPTION="A LaTeX wrapper for automatically building documents"
+HOMEPAGE="http://iml.univ-mrs.fr/~beffara/soft/rubber/"
+SRC_URI="http://iml.univ-mrs.fr/~beffara/soft/rubber/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="virtual/latex-base"
+
+S=${WORKDIR}/${P/_p*/}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ # configure script is not created by GNU autoconf
+ ./configure --prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die
+}
+
+src_compile() {
+ distutils_src_compile
+
+ cd doc
+ emake all || die "emake failed"
+}