summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/texamator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/texamator')
-rw-r--r--dev-tex/texamator/Manifest1
-rw-r--r--dev-tex/texamator/files/texamator3
-rw-r--r--dev-tex/texamator/metadata.xml5
-rw-r--r--dev-tex/texamator/texamator-1.7.5.ebuild48
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-tex/texamator/Manifest b/dev-tex/texamator/Manifest
new file mode 100644
index 000000000000..6d20cb571b74
--- /dev/null
+++ b/dev-tex/texamator/Manifest
@@ -0,0 +1 @@
+DIST TeXamator.v.1.7.5.tar.gz 784894 SHA256 b81298658c370e0695dcdce109144037836bc830a7ffcc15f38c30aec0fbb0ad SHA512 a0b05364ac1a65250a2b493616d618b1bd57950681b8f9b60200790572c1bac86dcc86fb922bb0d26bfe49f4d076a5d2f109761a4cdd5630807db03ea7928bb1 WHIRLPOOL 4e299251264cb116c38e3f8abf324a9c24235845384705b78a57766cde5b2197e51f0a17f04513520d18b19e2fd94cf745a94287c919074ee4963d32e722ff6a
diff --git a/dev-tex/texamator/files/texamator b/dev-tex/texamator/files/texamator
new file mode 100644
index 000000000000..93e860dc09c1
--- /dev/null
+++ b/dev-tex/texamator/files/texamator
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/lib/TeXamator
+exec python2 TeXamator.py
diff --git a/dev-tex/texamator/metadata.xml b/dev-tex/texamator/metadata.xml
new file mode 100644
index 000000000000..ed0568d85e79
--- /dev/null
+++ b/dev-tex/texamator/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+</pkgmetadata>
diff --git a/dev-tex/texamator/texamator-1.7.5.ebuild b/dev-tex/texamator/texamator-1.7.5.ebuild
new file mode 100644
index 000000000000..df0e135ca3c9
--- /dev/null
+++ b/dev-tex/texamator/texamator-1.7.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="2"
+
+inherit multilib python
+
+MY_PN=TeXamator
+
+DESCRIPTION="A program aimed at helping you making your exercise sheets"
+HOMEPAGE="http://snouffy.free.fr/blog-en/index.php/category/TeXamator"
+SRC_URI="http://snouffy.free.fr/blog-en/public/${MY_PN}/${MY_PN}.v.${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-text/dvipng
+ dev-python/PyQt4
+ virtual/latex-base"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ python_need_rebuild
+
+ dobin "${FILESDIR}"/${PN}
+
+ insinto /usr/$(get_libdir)/${MY_PN}
+ doins -r ${MY_PN}.py partielatormods {ts,ui}_files
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${MY_PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${MY_PN}
+}