summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-03-12 02:56:53 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-03-12 02:57:07 +0100
commitb9c4a480b5d786da8c0365ca06a71dcb7145fa64 (patch)
tree208348e7c7a59c323128cfe90599a3c0c1285b66 /dev-tex
parentdev-python/pymongo: version bump to 3.2.1 (diff)
downloadgentoo-b9c4a480b5d786da8c0365ca06a71dcb7145fa64.tar.gz
gentoo-b9c4a480b5d786da8c0365ca06a71dcb7145fa64.tar.bz2
gentoo-b9c4a480b5d786da8c0365ca06a71dcb7145fa64.zip
dev-tex/biber: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/biber/Manifest1
-rw-r--r--dev-tex/biber/biber-2.4.ebuild75
-rw-r--r--dev-tex/biber/files/biber-2.4-drop-mozilla-ca.patch146
3 files changed, 222 insertions, 0 deletions
diff --git a/dev-tex/biber/Manifest b/dev-tex/biber/Manifest
index 3cfd337822fd..3e6f326815f4 100644
--- a/dev-tex/biber/Manifest
+++ b/dev-tex/biber/Manifest
@@ -1,2 +1,3 @@
DIST biber-2.2.tar.gz 2296128 SHA256 6dd93476b27ac7603bc9f224a3b00558f86617209f93b74f8cb4a51f54480c2f SHA512 508b5a8046a1ff7ef6482b5c1f86ce427fa47f669ca224ee52252109dd6488ff242ea5076cafd47f66f288fed994b5425eab4c2566346046e0b2f656ca679d7c WHIRLPOOL 2006b26277eaeb707211a1828e70c4bbfd04030f56e91062c57050a5b0479d317455352730976f3f9206eafbafdccc71d9f071f4e9dedace1c77e8c79ab826b4
DIST biber-2.3.tar.gz 2288957 SHA256 7a85a7716f0dbe73b118d8d9b8ab26428a3505a1d5b366f2e954ede3e78563e3 SHA512 5d4c0ff32ba69d3f4591c167fc838972f39206a3ba7d73f9052ac10b9f528931a8fe6bdf37812a8e2634592f26a203e332bdc01e42997ce8bc49cf779eac2462 WHIRLPOOL 602acb26e4990e55024d21a7d4ed481133f27112dc7081c939b886c30cd33cb958abe59fc92e97e6a3e6f6fe1c9d4177dec36b0683f7a5b633f8eac9d7b778bc
+DIST biber-2.4.tar.gz 1480095 SHA256 708dbdb6598eba182b6a217bd48ce6d101925b65f5f24e8828bee9465747682e SHA512 dcd4e455ada36299c159e24b70ec208f28ba2254813fd5be471a1dd750da9f2f348282fc012107f6a5b9ba1aefd209802b4ee97b6e82b1fc30927c4c8e8c0b41 WHIRLPOOL 027723040e1b9cb78a7817c8fc73fc0c41bb9684d31ecd6146966c3f1809692affcf2bc3d972317178cda5bee2d8219c2dc7518d5f3d796f4dfb2a093fff621c
diff --git a/dev-tex/biber/biber-2.4.ebuild b/dev-tex/biber/biber-2.4.ebuild
new file mode 100644
index 000000000000..5182c1414749
--- /dev/null
+++ b/dev-tex/biber/biber-2.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils perl-module
+
+MY_PN=biblatex-${PN}
+
+DESCRIPTION="A BibTeX replacement for users of biblatex"
+HOMEPAGE="http://biblatex-biber.sourceforge.net/ https://github.com/plk/biber/"
+SRC_URI="https://github.com/plk/biber/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Artistic-2 GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+RDEPEND=">=dev-lang/perl-5.16
+ dev-perl/autovivification
+ dev-perl/Business-ISBN
+ dev-perl/Business-ISMN
+ dev-perl/Business-ISSN
+ dev-perl/Data-Compare
+ dev-perl/Data-Dump
+ dev-perl/Data-Uniqid
+ dev-perl/Date-Simple
+ dev-perl/Encode-EUCJPASCII
+ dev-perl/Encode-HanExtra
+ dev-perl/Encode-JIS2K
+ dev-perl/File-Slurp-Unicode
+ dev-perl/IPC-Run3
+ dev-perl/libwww-perl[ssl]
+ dev-perl/List-AllUtils
+ >=dev-perl/List-MoreUtils-0.408.0
+ dev-perl/Log-Log4perl
+ dev-perl/LWP-Protocol-https
+ dev-perl/regexp-common
+ dev-perl/Readonly
+ dev-perl/Readonly-XS
+ dev-perl/Text-Roman
+ >=dev-perl/Text-BibTeX-0.700.0
+ dev-perl/URI
+ dev-perl/Unicode-LineBreak
+ >=virtual/perl-Unicode-Normalize-1.230.0
+ dev-perl/XML-LibXML-Simple
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-SAX-Base
+ dev-perl/XML-Writer
+ >=dev-tex/biblatex-3.2
+ virtual/perl-IPC-Cmd
+ >=virtual/perl-Unicode-Collate-1.140.0"
+DEPEND="${RDEPEND}
+ dev-perl/Config-AutoConf
+ dev-perl/Module-Build
+ test? ( dev-perl/File-Which
+ dev-perl/Test-Differences
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST="parallel"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${PN}-2.4-drop-mozilla-ca.patch
+}
+
+src_install(){
+ perl-module_src_install
+ use doc && dodoc -r doc/*
+}
+
+src_test() {
+ BIBER_SKIP_DEV_TESTS=1 perl-module_src_test
+}
diff --git a/dev-tex/biber/files/biber-2.4-drop-mozilla-ca.patch b/dev-tex/biber/files/biber-2.4-drop-mozilla-ca.patch
new file mode 100644
index 000000000000..d4618a4cb99d
--- /dev/null
+++ b/dev-tex/biber/files/biber-2.4-drop-mozilla-ca.patch
@@ -0,0 +1,146 @@
+commit 09ac1811820c2d2b92f8de779f7c389f89dc6c16
+Author: Jason A. Donenfeld <Jason@zx2c4.com>
+Date: Sat Mar 12 02:54:35 2016 +0100
+
+ Remove Mozilla::CA dependency
+
+diff --git a/Build.PL b/Build.PL
+index 6031458..8de2f2a 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -53,7 +53,6 @@ my $builder = $class->new(
+ 'List::AllUtils' => 0,
+ 'List::MoreUtils' => 0,
+ 'List::MoreUtils::XS' => 0,
+- 'Mozilla::CA' => '20141217',
+ 'Regexp::Common' => 0,
+ 'Log::Log4perl' => 0,
+ 'Unicode::Collate' => '1.14',
+diff --git a/bin/biber b/bin/biber
+index f9e28fb..8d614e5 100755
+--- a/bin/biber
++++ b/bin/biber
+@@ -78,7 +78,6 @@ GetOptions(
+ 'sortgiveninits|sortfirstinits=s',
+ 'sortlocale|l=s',
+ 'sortupper=s',
+- 'ssl-nointernalca',
+ 'ssl-noverify-host',
+ 'strip_comments|strip-comments',
+ 'tool',
+@@ -710,12 +709,6 @@ default sorting (B<--collate|-C>). When
+ using B<--fastsort|-f>, your OS collation locale determines
+ this and this option is ignored (default is true).
+
+-=item B<--ssl-nointernalca>
+-
+-Don't try to use the default Mozilla CA certificates when using HTTPS to fetch remote data.
+-This assumes that the user will set one of the perl LWP::UserAgent module environment variables
+-to find the CA certs.
+-
+ =item B<--ssl-noverify-host>
+
+ Turn off host verification when using HTTPS to fetch remote data sources.
+diff --git a/data/schemata/config.rnc b/data/schemata/config.rnc
+index 7baf386..f3d321e 100644
+--- a/data/schemata/config.rnc
++++ b/data/schemata/config.rnc
+@@ -79,7 +79,6 @@ start =
+ map+
+ }+
+ }? &
+- element ssl-nointernalca { "0" | "1" }? &
+ element ssl-noverify-host { "0" | "1" }? &
+ element tool { "0" | "1" }? &
+ element tool_config { text }? &
+diff --git a/data/schemata/config.rng b/data/schemata/config.rng
+index f11b38e..fff209a 100644
+--- a/data/schemata/config.rng
++++ b/data/schemata/config.rng
+@@ -353,14 +353,6 @@
+ </element>
+ </optional>
+ <optional>
+- <element name="ssl-nointernalca">
+- <choice>
+- <value>0</value>
+- <value>1</value>
+- </choice>
+- </element>
+- </optional>
+- <optional>
+ <element name="ssl-noverify-host">
+ <choice>
+ <value>0</value>
+diff --git a/lib/Biber/Input/file/biblatexml.pm b/lib/Biber/Input/file/biblatexml.pm
+index 8139cd4..14018da 100644
+--- a/lib/Biber/Input/file/biblatexml.pm
++++ b/lib/Biber/Input/file/biblatexml.pm
+@@ -115,19 +115,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/bibtex.pm b/lib/Biber/Input/file/bibtex.pm
+index 6cc365a..b41e946 100644
+--- a/lib/Biber/Input/file/bibtex.pm
++++ b/lib/Biber/Input/file/bibtex.pm
+@@ -138,19 +138,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/ris.pm b/lib/Biber/Input/file/ris.pm
+index 9814723..e849b95 100644
+--- a/lib/Biber/Input/file/ris.pm
++++ b/lib/Biber/Input/file/ris.pm
+@@ -109,19 +109,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {