summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-texlive/texlive-fontutils/texlive-fontutils-2015.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-texlive/texlive-fontutils/texlive-fontutils-2015.ebuild')
-rw-r--r--dev-texlive/texlive-fontutils/texlive-fontutils-2015.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-texlive/texlive-fontutils/texlive-fontutils-2015.ebuild b/dev-texlive/texlive-fontutils/texlive-fontutils-2015.ebuild
new file mode 100644
index 000000000000..6e1e63151f6c
--- /dev/null
+++ b/dev-texlive/texlive-fontutils/texlive-fontutils-2015.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+TEXLIVE_MODULE_CONTENTS="accfonts afm2pl dosepsbin epstopdf fontware lcdftypetools metatype1 ps2pk pstools psutils dvipsconfig fontinst fontools mf2pt1 t1utils collection-fontutils
+"
+TEXLIVE_MODULE_DOC_CONTENTS="accfonts.doc afm2pl.doc dosepsbin.doc epstopdf.doc fontware.doc lcdftypetools.doc ps2pk.doc pstools.doc psutils.doc fontinst.doc fontools.doc mf2pt1.doc t1utils.doc "
+TEXLIVE_MODULE_SRC_CONTENTS="dosepsbin.source metatype1.source fontinst.source "
+inherit texlive-module
+DESCRIPTION="TeXLive Graphics and font utilities"
+
+LICENSE=" Artistic GPL-1 GPL-2 LPPL-1.3 public-domain TeX-other-free "
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+DEPEND=">=dev-texlive/texlive-basic-2015
+!dev-texlive/texlive-psutils
+!<dev-texlive/texlive-fontsextra-2009
+!<app-text/texlive-core-2013
+"
+RDEPEND="${DEPEND} "
+TEXLIVE_MODULE_BINSCRIPTS="
+ texmf-dist/scripts/accfonts/mkt1font
+ texmf-dist/scripts/accfonts/vpl2ovp
+ texmf-dist/scripts/accfonts/vpl2vpl
+ texmf-dist/scripts/epstopdf/epstopdf.pl
+ texmf-dist/scripts/fontools/afm2afm
+ texmf-dist/scripts/fontools/autoinst
+ texmf-dist/scripts/fontools/ot2kpx
+ texmf-dist/scripts/mf2pt1/mf2pt1.pl
+ texmf-dist/scripts/dosepsbin/dosepsbin.pl
+ texmf-dist/scripts/texlive/fontinst.sh
+ texmf-dist/scripts/texlive/ps2frag.sh
+ texmf-dist/scripts/texlive/pslatex.sh
+"
+TEXLIVE_MODULE_BINLINKS="
+ epstopdf:repstopdf
+"