summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorS├ębastien Fabbro <bicatali@gentoo.org>2017-07-14 17:25:00 +0000
committerS├ębastien Fabbro <bicatali@gentoo.org>2017-07-14 17:31:47 +0000
commit33639dde7dee44b6d1fbcf456af0cbcb85682609 (patch)
tree1669ba31a67809821d2a6a399e65fa441ca50629 /dev-util/conan
parentdev-python/pluginbase: initial import (diff)
downloadgentoo-33639dde7dee44b6d1fbcf456af0cbcb85682609.tar.gz
gentoo-33639dde7dee44b6d1fbcf456af0cbcb85682609.tar.bz2
gentoo-33639dde7dee44b6d1fbcf456af0cbcb85682609.zip
dev-util/conan: add missing dependency on pluginbase, and force specific
versions on patch Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-util/conan')
-rw-r--r--dev-util/conan/Manifest1
-rw-r--r--dev-util/conan/conan-0.20.3.ebuild49
-rw-r--r--dev-util/conan/conan-0.24.0-r1.ebuild (renamed from dev-util/conan/conan-0.24.0.ebuild)5
3 files changed, 3 insertions, 52 deletions
diff --git a/dev-util/conan/Manifest b/dev-util/conan/Manifest
index 885afc7920b..99f096f0407 100644
--- a/dev-util/conan/Manifest
+++ b/dev-util/conan/Manifest
@@ -1,2 +1 @@
-DIST conan-0.20.3.tar.gz 469877 SHA256 ba8245f2b39c50d64eeab89ea9c4eb76c3950a19f4ee173fad69dd96b70b0096 SHA512 bba57d720ed38a93167082ffb28dc6f42257907d5bc0158056800921f5ce011a5fca8faf49843be0a3be20c9ffecdb54c34a478510a2e6c35d3254c64742d242 WHIRLPOOL 9131ad2546b244b3382423bbea34f6bc3fa73d2d9a05d9c6a80caf106dbbc80a505d44b94ca951bb4e5a9b2de0936512676126182fbe8463459a97b88f480912
DIST conan-0.24.0.tar.gz 514654 SHA256 59ff6db2bfbbe5e2b5f31612a3a6be64844346359b64f2f78803af4f35dfe2e2 SHA512 6fdbf4731be6aa6fb06e2d976c97975dc4cdc60fb7a6381f99c83c19b73230de13c7a60bffa1ab6aac0d64ce20986cee99f98af986b23396107471ac804c08af WHIRLPOOL 3c6fb70b4c262d82410471d35c36118e3ae9091699ca06fc515f1bdcbc0c0da7632ae5a5b3f99de7f94448ea9a1c9dce1c88fdc3fbf09fb2c0afa49e458916df
diff --git a/dev-util/conan/conan-0.20.3.ebuild b/dev-util/conan/conan-0.20.3.ebuild
deleted file mode 100644
index 89476460fd1..00000000000
--- a/dev-util/conan/conan-0.20.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="Distributed C/C++ package manager"
-HOMEPAGE="http://conan.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/bottle-0.12.8[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.3.3[${PYTHON_USEDEP}]
- >=dev-python/distro-1.0.2[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.14.1[${PYTHON_USEDEP}]
- >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
- >=dev-python/patch-1.16[${PYTHON_USEDEP}]
- >=dev-python/pyjwt-1.4[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
- >=dev-python/requests-2.7[${PYTHON_USEDEP}]
- >=dev-python/six-1.10[${PYTHON_USEDEP}]
- >=dev-python/node-semver-0.1.1[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-lang/go
- >=dev-python/mock-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/nose-1.3.7[${PYTHON_USEDEP}]
- >=dev-python/nose-parameterized-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/webtest-2.0.18[${PYTHON_USEDEP}]
- dev-util/cmake
- )
-"
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- PYTHONPATH=. nosetests -v . || die
-}
diff --git a/dev-util/conan/conan-0.24.0.ebuild b/dev-util/conan/conan-0.24.0-r1.ebuild
index 1371d8109f4..453ff6e2d56 100644
--- a/dev-util/conan/conan-0.24.0.ebuild
+++ b/dev-util/conan/conan-0.24.0-r1.ebuild
@@ -23,9 +23,10 @@ RDEPEND="
>=dev-python/distro-1.0.2[${PYTHON_USEDEP}]
>=dev-python/fasteners-0.14.1[${PYTHON_USEDEP}]
>=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
- >=dev-python/patch-1.16[${PYTHON_USEDEP}]
+ =dev-python/patch-1.16[${PYTHON_USEDEP}]
+ >=dev-python/pluginbase-0.5[${PYTHON_USEDEP}]
>=dev-python/pyjwt-1.4[${PYTHON_USEDEP}]
- >=dev-python/pylint-1.6.5[${PYTHON_USEDEP}]
+ =dev-python/pylint-1.6.5[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
>=dev-python/requests-2.7[${PYTHON_USEDEP}]
>=dev-python/six-1.10[${PYTHON_USEDEP}]