summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-01-09 13:43:14 -0600
committerWilliam Hubbs <williamh@gentoo.org>2017-01-09 13:43:47 -0600
commit8ef101a0026c3466729466869da06ef59c1e00a2 (patch)
tree33eac776290b87d5824f92fe7a9cf1162057c84b /dev-util/meson/meson-9999.ebuild
parentdev-util/meson: 0.37.1 version bump (diff)
downloadgentoo-8ef101a0026c3466729466869da06ef59c1e00a2.tar.gz
gentoo-8ef101a0026c3466729466869da06ef59c1e00a2.tar.bz2
gentoo-8ef101a0026c3466729466869da06ef59c1e00a2.zip
dev-util/meson: add live ebuild
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util/meson/meson-9999.ebuild')
-rw-r--r--dev-util/meson/meson-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/meson/meson-9999.ebuild b/dev-util/meson/meson-9999.ebuild
new file mode 100644
index 000000000000..f0a050e91bde
--- /dev/null
+++ b/dev-util/meson/meson-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mesonbuild/meson"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Open source build system"
+HOMEPAGE="http://mesonbuild.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-util/ninja-1.6.0
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( authors.txt contributing.txt )