summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-11-12 01:39:19 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2016-11-12 01:39:39 +0200
commit55733e375bb9688fd48766877f6e1ec9ecbc343d (patch)
tree183bcae942494b8a84e3c1f6aabcfe3f91233a9e /dev-util/mingw64-runtime
parentsci-physics/thepeg: Pin slots (diff)
downloadgentoo-55733e375bb9688fd48766877f6e1ec9ecbc343d.tar.gz
gentoo-55733e375bb9688fd48766877f6e1ec9ecbc343d.tar.bz2
gentoo-55733e375bb9688fd48766877f6e1ec9ecbc343d.zip
dev-util/mingw64-runtime: version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util/mingw64-runtime')
-rw-r--r--dev-util/mingw64-runtime/Manifest1
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-5.0.0.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/dev-util/mingw64-runtime/Manifest b/dev-util/mingw64-runtime/Manifest
index 613d77b3992f..8003331f58b4 100644
--- a/dev-util/mingw64-runtime/Manifest
+++ b/dev-util/mingw64-runtime/Manifest
@@ -4,3 +4,4 @@ DIST mingw-w64-v3.2.0.tar.bz2 7053254 SHA256 78a0de610829a1145ae12c4a29603344963
DIST mingw-w64-v4.0.1.tar.bz2 10803072 SHA256 89d2524a071b6337dfd9f3b6e6f46d8002b2633f928c833dc4e873a13e045b17 SHA512 a216a09a460c56c29208aee1e1cdb428e856f9c8d59dd399723ccf6d549368f0a13a6aacb046d211ddec7c0a1f1c227d5dd599e4f0c33ba4b6d9c92bd0a7fa1b WHIRLPOOL e021031e2820e918fe0f291624335fadc08641e811f6cf19d45b1586d2ac96c6bff4fb936bcd154a7b48711db9f5faabd27bfdced3a38073b4a20c8471a91915
DIST mingw-w64-v4.0.4.tar.bz2 10812375 SHA256 89356a0aa8cf9f8b9dc8d92bc8dd01a131d4750c3acb30c6350a406316c42199 SHA512 06de6b592f776676184a9c50c63eb105c82a912965dee5d8217f9b5b325e0258c188f5d7d5e28aaeacf7bad44ce5d36bd837b9f1cbb91358754787738fb15146 WHIRLPOOL ff557b2aff821c1833ab6d5fdade4f256b71cb37e84a476d3e5a4cfe13f60db68c336d7e72f6e3eb13b3d127e1bac2cbfdde160ea2f7016867f10efa6a02914b
DIST mingw-w64-v4.0.6.tar.bz2 10853871 SHA256 0c407394b0d8635553f4fbca674cdfe446aac223e90b4010603d863e4bdd015c SHA512 c9ec75b10fe40d80e620b569ca8f452b1f78e9e4dd45ad087a2b69297dc661d06aa30255ea310786f28c042256c35a1d3e709ff7ea8bc19e7f4ea914c120f020 WHIRLPOOL 69015094c14f66e1102d343b220eb17cc245f24a66c1a39ffced2f155cae84315eabb9a843bd9aa8e7874a12e34297a4f7cfff06447972a17beecf070bc70b08
+DIST mingw-w64-v5.0.0.tar.bz2 11193007 SHA256 e41d8ca739e22b4215c8ebe99ed2fc398c734cae73877f3143c394661b096d08 SHA512 21e3029701a88cf11f0649f7876ab0c3ef04e14cb3221876854dc01d09e627dc3502f1d71a5eb8b0378ff37aa03a0e8080b72a1907ebd47857952fc145ac797a WHIRLPOOL a761a78db5ba2c0ec3ea017f1bb95f69d7e90478703dbc8cb566424ec8703995aa3201b83409216aad105512cd3583ea0198985a48e171f369d4e304481ec562
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-5.0.0.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-5.0.0.ebuild
new file mode 100644
index 000000000000..3b8b4c293d56
--- /dev/null
+++ b/dev-util/mingw64-runtime/mingw64-runtime-5.0.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+WANT_AUTOMAKE="1.15"
+
+inherit autotools flag-o-matic eutils
+
+DESCRIPTION="Free Win64 runtime and import library definitions"
+HOMEPAGE="http://mingw-w64.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crosscompile_opts_headers-only idl libraries tools"
+RESTRICT="strip"
+
+S="${WORKDIR}/mingw-w64-v${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.1-winpthreads.patch"
+ "${FILESDIR}/${PN}-4.0.1-build.patch"
+)
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+just_headers() {
+ use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+crt_with() {
+ just_headers && echo --without-$1 || echo --with-$1
+}
+crt_use_enable() {
+ just_headers && echo --without-$2 || use_enable "$@"
+}
+crt_use_with() {
+ just_headers && echo --without-$2 || use_with "$@"
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration"
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ CHOST=${CTARGET} strip-unsupported-flags
+
+ if ! just_headers; then
+ mkdir "${WORKDIR}/headers"
+ pushd "${WORKDIR}/headers" > /dev/null
+ CHOST=${CTARGET} "${S}/configure" \
+ --prefix="${T}/tmproot" \
+ --with-headers \
+ --without-crt \
+ || die
+ popd > /dev/null
+ append-cppflags "-I${T}/tmproot/include"
+ fi
+
+ CHOST=${CTARGET} econf \
+ --prefix=/usr/${CTARGET} \
+ --includedir=/usr/${CTARGET}/usr/include \
+ --with-headers \
+ --enable-sdk \
+ $(crt_with crt) \
+ $(crt_use_enable idl) \
+ $(crt_use_with libraries libraries winpthreads,libmangle) \
+ $(crt_use_with tools) \
+ $(
+ $(tc-getCPP ${CTARGET}) ${CPPFLAGS} -dM - < /dev/null | grep -q __MINGW64__ \
+ && echo --disable-lib32 --enable-lib64 \
+ || echo --enable-lib32 --disable-lib64
+ )
+}
+
+src_compile() {
+ if ! just_headers; then
+ emake -C "${WORKDIR}/headers" install
+ fi
+ default
+}
+
+src_install() {
+ default
+
+ if is_crosscompile ; then
+ # gcc is configured to look at specific hard-coded paths for mingw #419601
+ dosym usr /usr/${CTARGET}/mingw
+ dosym usr /usr/${CTARGET}/${CTARGET}
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ rm -rf "${ED}/usr/share"
+}