summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/sgb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/sgb')
-rw-r--r--dev-util/sgb/Manifest1
-rw-r--r--dev-util/sgb/files/sgb-20030623-destdir.patch76
-rw-r--r--dev-util/sgb/files/sgb-20030623-parallel-make-fix.patch47
-rw-r--r--dev-util/sgb/metadata.xml7
-rw-r--r--dev-util/sgb/sgb-20030623.ebuild59
5 files changed, 190 insertions, 0 deletions
diff --git a/dev-util/sgb/Manifest b/dev-util/sgb/Manifest
new file mode 100644
index 000000000000..3f7ced50189b
--- /dev/null
+++ b/dev-util/sgb/Manifest
@@ -0,0 +1 @@
+DIST sgb-2003-06-23.tar.gz 493974 SHA256 dc911a3abd0bad1a528e89fc7f06135e05845ca7996ddf44559d3cc73d5eb7b5 SHA512 f486317dd85dc11761c970ab2bc0c9193f8dd3fa0d114528e1b55fd935fa9cce9266dc595b2ebe3526214ce3e6a1b3dc747382b32cbfd518ffb6179d3463e874 WHIRLPOOL 341ac4e0121675c2eb321d596ae7f52f7eeaeed802b7c330361f8621f72083ff0b26c1667ae6fb8af413868b9143bf20d7250e01f780aa34d6d9302b460df34b
diff --git a/dev-util/sgb/files/sgb-20030623-destdir.patch b/dev-util/sgb/files/sgb-20030623-destdir.patch
new file mode 100644
index 000000000000..0517d0ce46a3
--- /dev/null
+++ b/dev-util/sgb/files/sgb-20030623-destdir.patch
@@ -0,0 +1,76 @@
+diff -Nuar -Nuar work.orig/Makefile work/Makefile
+--- work.orig/Makefile 2009-09-22 01:59:32.521217030 +0000
++++ work/Makefile 2009-09-22 01:58:42.494972535 +0000
+@@ -93,50 +93,48 @@
+ $(CC) $(CFLAGS) -DDATA_DIRECTORY=\"$(DATADIR)/\" -c gb_io.c
+
+ test_io: gb_io.o
+- $(CC) $(CFLAGS) test_io.c gb_io.o -o test_io
++ $(CC) $(CFLAGS) $(LDFLAGS) test_io.c gb_io.o -o test_io
+
+ test_graph: gb_graph.o
+- $(CC) $(CFLAGS) test_graph.c gb_graph.o -o test_graph
++ $(CC) $(CFLAGS) $(LDFLAGS) test_graph.c gb_graph.o -o test_graph
+
+ test_flip: gb_flip.o
+- $(CC) $(CFLAGS) test_flip.c gb_flip.o -o test_flip
++ $(CC) $(CFLAGS) $(LDFLAGS) test_flip.c gb_flip.o -o test_flip
+
+-tests: test_io test_graph test_flip
++tests: certified
++
++tests_phase1: test_io test_graph test_flip
+ ./test_io
+ ./test_graph
+ ./test_flip
+- make gb_sort.o
+- make lib
+- make test_sample
++
++certified tests_phase2: tests_phase1 gb_sort.o lib test_sample
+ - ./test_sample > sample.out
+ diff test.gb test.correct
+ diff sample.out sample.correct
+- rm test.gb sample.out test_io test_graph test_flip test_sample
++ echo rm test.gb sample.out test_io test_graph test_flip test_sample
+ echo "Congratulations --- the tests have all been passed."
+ touch certified
+
+-install: lib
+- if test ! -r certified; then echo "Please run 'make tests' first!"; fi
+- test -r certified
+- make installdata
+- - mkdir $(LIBDIR)
+- - cp libgb.a $(LIBDIR)
+- - mkdir $(CWEBINPUTS)
+- - cp -p boilerplate.w gb_types.w $(CWEBINPUTS)
+- - mkdir $(INCLUDEDIR)
+- - cp -p $(HEADERS) Makefile $(INCLUDEDIR)
++install: lib certified installdata
++ - mkdir -p $(DESTDIR)$(LIBDIR)
++ - cp libgb.a $(DESTDIR)$(LIBDIR)
++ - mkdir -p $(DESTDIR)$(CWEBINPUTS)
++ - cp -p boilerplate.w gb_types.w $(DESTDIR)$(CWEBINPUTS)
++ - mkdir -p $(DESTDIR)$(INCLUDEDIR)
++ - cp -p $(HEADERS) Makefile $(DESTDIR)$(INCLUDEDIR)
+
+ installdata: $(DATAFILES)
+- - mkdir $(SGBDIR)
+- - mkdir $(DATADIR)
+- - cp -p $(DATAFILES) $(DATADIR)
++ - mkdir -p $(DESTDIR)$(SGBDIR)
++ - mkdir -p $(DESTDIR)$(DATADIR)
++ - cp -p $(DATAFILES) $(DESTDIR)$(DATADIR)
+
+ installdemos: lib $(DEMOS)
+- - mkdir $(BINDIR)
+- - mv $(DEMOS) $(BINDIR)
++ - mkdir -p $(DESTDIR)$(BINDIR)
++ - mv $(DEMOS) $(DESTDIR)$(BINDIR)
+
+ uninstalldemos:
+- - cd $(BINDIR); rm -f $(DEMOS)
++ - cd $(DESTDIR)$(BINDIR); rm -f $(DEMOS)
+
+ doc:
+ tex abstract.plaintex
diff --git a/dev-util/sgb/files/sgb-20030623-parallel-make-fix.patch b/dev-util/sgb/files/sgb-20030623-parallel-make-fix.patch
new file mode 100644
index 000000000000..4a96742f24eb
--- /dev/null
+++ b/dev-util/sgb/files/sgb-20030623-parallel-make-fix.patch
@@ -0,0 +1,47 @@
+diff -Nuar b/Makefile a/Makefile
+--- b/Makefile 1999-12-27 22:27:24.000000000 +0000
++++ a/Makefile 2009-09-21 11:49:40.000000000 +0000
+@@ -46,26 +46,14 @@
+
+ .SUFFIXES: .dvi .tex .w
+
+-.tex.dvi:
+- tex $*.tex
++all: libgb.a test_io test_graph test_flip demos
+
+-.w.c:
+- if test -r $*.ch; then ctangle $*.w $*.ch; else ctangle $*.w; fi
+-
+-.w.tex:
+- if test -r $*.ch; then cweave $*.w $*.ch; else cweave $*.w; fi
+-
+-.w.o:
+- make $*.c
+- make $*.o
+-
+-.w:
+- make $*.c
+- make $*
+-
+-.w.dvi:
+- make $*.tex
+- make $*.dvi
++%.dvi: %.tex
++ tex $^
++%.c: %.w
++ ctangle $^
++%.tex: %.w
++ cweave $^
+
+ DATAFILES = anna.dat david.dat econ.dat games.dat homer.dat huck.dat \
+ jean.dat lisa.dat miles.dat roget.dat words.dat
+@@ -175,3 +163,9 @@
+
+ fulltar: $(ALL) ERRATA ANSI AMIGA PROTOTYPES MSVC
+ tar cvf sgb.tar $(ALL) ERRATA ANSI AMIGA PROTOTYPES MSVC
++
++$(DEMOS) lib tests test_io test_graph test_flip: libgb.a
++
++demos: $(DEMOS)
++
++.PRECIOUS: .o .c .tex
diff --git a/dev-util/sgb/metadata.xml b/dev-util/sgb/metadata.xml
new file mode 100644
index 000000000000..c6d862855eb5
--- /dev/null
+++ b/dev-util/sgb/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-util/sgb/sgb-20030623.ebuild b/dev-util/sgb/sgb-20030623.ebuild
new file mode 100644
index 000000000000..a3bef58406f8
--- /dev/null
+++ b/dev-util/sgb/sgb-20030623.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib
+
+DESCRIPTION="Stanford GraphBase"
+HOMEPAGE="ftp://labrea.stanford.edu/pub/sgb/"
+SRC_URI="ftp://labrea.stanford.edu/pub/sgb/sgb-${PV:0:4}-${PV:4:2}-${PV:6:2}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+DEPEND="|| ( >=dev-util/cweb-3.00 virtual/tex-base )"
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/sgb-20030623-parallel-make-fix.patch
+ epatch "${FILESDIR}"/sgb-20030623-destdir.patch
+}
+
+src_compile() {
+ # bug #299028
+ emake -j1 \
+ CFLAGS="${CFLAGS}" \
+ SGBDIR=/usr/share/${PN} \
+ INCLUDEDIR=/usr/include/sgb \
+ LIBDIR=/usr/$(get_libdir) \
+ BINDIR=/usr/bin \
+ CFLAGS="${CFLAGS}" \
+ lib demos tests || die "Failed to build"
+ #CWEBINPUTS=/usr/share/${PN}/cweb \
+ #LDFLAGS="${LDFLAGS}" \
+}
+
+src_install() {
+ dodir /usr/share/${PN} /usr/include/sgb /usr/lib /usr/bin /usr/share/${PN}/cweb
+ emake \
+ DESTDIR="${D}" \
+ SGBDIR=/usr/share/${PN} \
+ INCLUDEDIR=/usr/include/sgb \
+ LIBDIR=/usr/$(get_libdir) \
+ BINDIR=/usr/bin \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CWEBINPUTS=/usr/share/${PN}/cweb \
+ install \
+ || die "Failed to install"
+
+ # we don't need no makefile
+ rm "${D}"/usr/include/sgb/Makefile
+
+ dodoc ERRATA README
+}
+
+src_test() {
+ emake tests
+}