summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-06 13:04:08 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-06 13:04:45 +0200
commit9f3d20c15ce6f962ecf6d4ba1e13e854e01e36fe (patch)
treebadee9dae7ce76f37acaaeae25f462e0eb163e7b /dev-util/strace
parentx11-base/xorg-proto: marked ~x64-macos (diff)
downloadgentoo-9f3d20c15ce6f962ecf6d4ba1e13e854e01e36fe.tar.gz
gentoo-9f3d20c15ce6f962ecf6d4ba1e13e854e01e36fe.tar.bz2
gentoo-9f3d20c15ce6f962ecf6d4ba1e13e854e01e36fe.zip
dev-util/strace: Bump to version 4.22
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/Manifest1
-rw-r--r--dev-util/strace/strace-4.22.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index 7745e636154d..84b0ce27e822 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -1,2 +1,3 @@
DIST strace-4.20.tar.xz 1132460 BLAKE2B 2e0e3080008ed1d5fd87572df740af8c62ebba44e0ece3c6b5ab581f246e79d8074a7fc2d0857abe158a055042fccbd880e11c9567beca1aeddc23f92d763c2d SHA512 869b3b9c48401619073a021e20e80cce37d8884f615bdb52dac9e6a2903df11507d7a0cb0ccad75bcc03d8dfafead0e68d14267e663503e94849079c9a2ebd4c
DIST strace-4.21.tar.xz 1185908 BLAKE2B 00d8c7e296dd3b2a004b4f7ae062a3813219351bb4a5aabbc2e04784c35760f271fc12fd0122dac276a9723079f63d7187239172c9379a056e55dab9606e2e4b SHA512 d3b0393f1f727530e2e5b4490c80a905d251223167a61f9a86884a4b8a4f25522c46c465961968ca25013f321e561e217cb6e8f15be31d4d371274030526187d
+DIST strace-4.22.tar.xz 1232884 BLAKE2B 4053d1923ad1f942c3887be1716b400e426b318e136cc1cba1d83091445e2a3b64588c0578f0165ffec01dda1cb1824c29dbdab05bb409232edede953f2a5e78 SHA512 624c3f27921b6df2eb8ff409a35fa9153c4571cd5f703e6cac18f024bccd5ff4acb81f88ca33f81d1046d9718dec7b2705e8940e80bb8447ec3e62a6fd5f8350
diff --git a/dev-util/strace/strace-4.22.ebuild b/dev-util/strace/strace-4.22.ebuild
new file mode 100644
index 000000000000..1c7070c5d082
--- /dev/null
+++ b/dev-util/strace/strace-4.22.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strace/strace.git"
+ inherit git-r3 autotools
+else
+ #SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="https://sourceforge.net/projects/strace/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="aio perl static unwind"
+
+LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
+# strace only uses the header from libaio to decode structs
+DEPEND="
+ static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
+ sys-kernel/linux-headers
+"
+RDEPEND="
+ !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )
+"
+
+src_prepare() {
+ default
+
+ if [[ ! -e configure ]] ; then
+ # git generation
+ ./xlat/gen.sh || die
+ ./generate_mpers_am.sh || die
+ eautoreconf
+ [[ ! -e CREDITS ]] && cp CREDITS{.in,}
+ fi
+
+ filter-lfs-flags # configure handles this sanely
+ use static && append-ldflags -static
+
+ export ac_cv_header_libaio_h=$(usex aio)
+ use elibc_musl && export ac_cv_header_stdc=no
+
+ # Stub out the -k test since it's known to be flaky. #545812
+ sed -i '1iexit 77' tests*/strace-k.test || die
+}
+
+src_configure() {
+ # Set up the default build settings, and then use the names strace expects.
+ tc-export_build_env BUILD_{CC,CPP}
+ local v bv
+ for v in CC CPP {C,CPP,LD}FLAGS ; do
+ bv="BUILD_${v}"
+ export "${v}_FOR_BUILD=${!bv}"
+ done
+
+ econf $(use_with unwind libunwind)
+}
+
+src_test() {
+ if has usersandbox $FEATURES ; then
+ ewarn "Test suite is known to fail with FEATURES=usersandbox -- skipping ..." #643044
+ return 0
+ fi
+
+ default
+}
+
+src_install() {
+ default
+ use perl || rm "${ED%/}"/usr/bin/strace-graph
+ dodoc CREDITS
+}