summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-05-05 21:37:44 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-05-05 21:39:10 -0400
commit02d752ee80accd16327dc81649693fca298c15e0 (patch)
tree9bb584b3e923f47b0696312d9751716c84199806 /dev-util/trinity
parentmedia-sound/apulse: Remove self from metadata.xml (diff)
downloadgentoo-02d752ee80accd16327dc81649693fca298c15e0.tar.gz
gentoo-02d752ee80accd16327dc81649693fca298c15e0.tar.bz2
gentoo-02d752ee80accd16327dc81649693fca298c15e0.zip
dev-util/trinity: new version 1.7.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util/trinity')
-rw-r--r--dev-util/trinity/Manifest2
-rw-r--r--dev-util/trinity/files/trinity-1.7-cflags.patch14
-rw-r--r--dev-util/trinity/trinity-1.7.ebuild (renamed from dev-util/trinity/trinity-1.6.ebuild)28
3 files changed, 28 insertions, 16 deletions
diff --git a/dev-util/trinity/Manifest b/dev-util/trinity/Manifest
index 579ef6af0714..60d846d256c2 100644
--- a/dev-util/trinity/Manifest
+++ b/dev-util/trinity/Manifest
@@ -1,2 +1,2 @@
DIST trinity-1.5.tar.xz 171684 SHA256 e7b641d21954873bac7b5c27e7a9986837e83ec14fa20c55901c4333cce22655 SHA512 58884c8e226258de6037e06029b6c593a99b467e9b107562458557954fd4af185f88fbcacc04fc52f05318a860ebab4605c227e6a02b32253439807d4071cd8d WHIRLPOOL e737ac877b95a62e40a2cc9273f0b0d4dc79275b6dafab85b54815f1581c9c824189d88781cc26468c56166f6e87273fc5df1b786b69069b1dc4654d2a874f43
-DIST trinity-1.6.tar.xz 177808 SHA256 e40efa320ddc814943e90be0386b5052ce0bbbc457b3f308fa973669d393a6d9 SHA512 43ceb5ef96e97d3c338deb582b250202073d6f203ee596ce676d77a52bcfe06f53e068d07a0ee9f1d49f74319e24ba885cb7529d8868ac67f0237f2c4cfde2de WHIRLPOOL f7afe7514fe2ac2b6de3c4a05f8a4bb0bb7a328267c093e924e6345f03ffa864be06a3223b32c24ab4e334b016868f66696417d7de30d2561ea71a1a67f45183
+DIST trinity-1.7.tar.xz 195488 SHA256 4cb2bd4049ce523fdf47490c4c18b8eb713c720d4b3b13d6ec2ae246aac908ad SHA512 bb702ec79494591e04c74279e39d6dd0c5779f7cb2696c306c94bee3a8aefb524e369674daadf02f70b58dbb19ad5699d2c331bc4c9089046d2214403a95ba87 WHIRLPOOL 2b14592a85e049eb0f41f611b645f38be61267a63f83e6ef08c2de35213398c61b30f85da4f4b37c4e9293f4c5064c317aad157df5bca5ca552bc378c2aa4837
diff --git a/dev-util/trinity/files/trinity-1.7-cflags.patch b/dev-util/trinity/files/trinity-1.7-cflags.patch
new file mode 100644
index 000000000000..accdae374bfa
--- /dev/null
+++ b/dev-util/trinity/files/trinity-1.7-cflags.patch
@@ -0,0 +1,14 @@
+diff --git a/Makefile b/Makefile
+index c77d1f9..b970d08 100644
+--- a/Makefile
++++ b/Makefile
+@@ -10,7 +10,8 @@ endif
+ CC := $(CROSS_COMPILE)$(CC)
+ LD := $(CROSS_COMPILE)$(LD)
+
+-CFLAGS += -Wall -Wextra -g -O2 -I. -Iinclude/ -Wimplicit -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE -D__linux__
++CFLAGS ?= -g -O2 -D_FORTIFY_SOURCE=2
++CFLAGS += -Wall -Wextra -I. -Iinclude/ -Wimplicit -D_GNU_SOURCE -D__linux__
+
+ CFLAGS += $(shell if $(CC) -std=gnu11 -S -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo "-std=gnu11"; else echo "-std=gnu99"; fi)
+
diff --git a/dev-util/trinity/trinity-1.6.ebuild b/dev-util/trinity/trinity-1.7.ebuild
index 3e03a8edb64b..a25cbb887f2f 100644
--- a/dev-util/trinity/trinity-1.6.ebuild
+++ b/dev-util/trinity/trinity-1.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
DESCRIPTION="A Linux system call fuzz tester"
HOMEPAGE="http://codemonkey.org.uk/projects/trinity/"
@@ -14,31 +14,29 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-DEPEND="
- app-arch/xz-utils
- sys-kernel/linux-headers
-"
+# We need newer headers to avoid compilation failures in the BPF stuff.
+DEPEND="app-arch/xz-utils
+ >=sys-kernel/linux-headers-4.8"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-cflags.patch
- tc-export CC
-}
+PATCHES=( "${FILESDIR}/${P}-cflags.patch" )
src_configure() {
- ./configure.sh || die
+ tc-export CC
+ default
}
src_compile() {
+ # Enable a verbose (i.e. not quiet) build.
emake V=1
}
src_install() {
- dobin ${PN}
+ dobin "${PN}"
dodoc Documentation/* README
if use examples ; then
- exeinto /usr/share/doc/${PF}/scripts
+ exeinto "/usr/share/doc/${PF}/scripts"
doexe scripts/*
- docompress -x /usr/share/doc/${PF}/scripts
+ docompress -x "/usr/share/doc/${PF}/scripts"
fi
}