summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-01-16 09:35:55 -0800
committerBrian Dolbec <dolsen@gentoo.org>2018-01-16 09:41:40 -0800
commit1d5e000ffc8eba127cde6d84d92f5759f121f1cb (patch)
tree479b245c055a523d19c655382f6aa11d970b3981 /dev-util
parentdev-util/buildbot-wsgi-dashboards: Version bump (diff)
downloadgentoo-1d5e000ffc8eba127cde6d84d92f5759f121f1cb.tar.gz
gentoo-1d5e000ffc8eba127cde6d84d92f5759f121f1cb.tar.bz2
gentoo-1d5e000ffc8eba127cde6d84d92f5759f121f1cb.zip
dev-util/buildbot-www: Version bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-www/Manifest1
-rw-r--r--dev-util/buildbot-www/buildbot-www-0.9.15_p1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/Manifest b/dev-util/buildbot-www/Manifest
index cac21648be4f..001280fb50d6 100644
--- a/dev-util/buildbot-www/Manifest
+++ b/dev-util/buildbot-www/Manifest
@@ -2,3 +2,4 @@ DIST buildbot-www-0.9.10.tar.gz 693452 BLAKE2B 4f66046bf2ef7d016c020a6f3582dca39
DIST buildbot-www-0.9.11.tar.gz 687664 BLAKE2B 0e7ef9532acf827620b1b720f3709a708c9a24ee29f7edef7695af73a4202d7ddf02f0b6cc5e23507365496f4b6b565b84648770e3a36aa849b0b21d4d139cfd SHA512 5a4ecde7a79bace65fbaeedb9153ccfc8094e0fdccd19bf656a1aee1cb5eb84dd28ffb0279aaa0f75a2365278276f5a16d7015eab732e2642a3344d2b28ff441
DIST buildbot-www-0.9.12.tar.gz 691551 BLAKE2B 9bef044fe9e48e34d3e314d9c9b7446a1e295898c432da5c8915e36156f2f934fd065c8075dd55f68da7bc29a567c1ef276bc415df38911aff7c33de46fa7942 SHA512 6c525d32407be24aa728a0bd9c9a09c64bb4bef092ef9e5285475527f7fcbd89d516ea376d90b22aa24af384d73125bc886360cf992dfe3d01471838193f351a
DIST buildbot-www-0.9.13.tar.gz 691556 BLAKE2B cd3fe546c88308debc6dd621e8979c400816a11235b67c23e539bb3525746a864d76df2c4f8e04f63ba4459d2186094543115ab51bdc35f56b20c8c1a0ed5a68 SHA512 b092014e490ed46f2551ddeeaef5364c85b048cdda298af11acdf664d799fc52ef6f8daa17cf7a98d588c59abcbdfebb666345b44d551859d3db9b4fa358adb9
+DIST buildbot-www-0.9.15.post1.tar.gz 718007 BLAKE2B af64eb2e0fabea2af3c02c294d50c924211755358187bd0d52f43821fddcd6d566f8aad1136da3ca69f924aee3bce52cde1e48af3c3f0419c23d6c1be25c17ee SHA512 749fd6e763580bb0fd27f7ce1576ee193ccf9cb42616c3b393a0bfac9469d9a42372069d087ceae3557e72540a3e0cc37087ba4b7901cbb67877f17f27422a47
diff --git a/dev-util/buildbot-www/buildbot-www-0.9.15_p1.ebuild b/dev-util/buildbot-www/buildbot-www-0.9.15_p1.ebuild
new file mode 100644
index 000000000000..d14a3d992e00
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-0.9.15_p1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-www"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}