summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-21 14:16:20 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-21 15:10:27 +0000
commit573f8286e7d70bf5c74a37f3864cd441e2cdb094 (patch)
treeec57d1e7bf627c5bf91e9d3276ad4dc08dd209a2 /dev-util
parentapp-text/html-xml-utils: EAPI 6. (diff)
downloadgentoo-573f8286e7d70bf5c74a37f3864cd441e2cdb094.tar.gz
gentoo-573f8286e7d70bf5c74a37f3864cd441e2cdb094.tar.bz2
gentoo-573f8286e7d70bf5c74a37f3864cd441e2cdb094.zip
dev-util/dwdiff: EAPI 6 bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/dwdiff/dwdiff-2.1.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/dwdiff/dwdiff-2.1.0-r1.ebuild b/dev-util/dwdiff/dwdiff-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..ddaef1270d29
--- /dev/null
+++ b/dev-util/dwdiff/dwdiff-2.1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="diff-like program that operates at the word level instead of the line level"
+HOMEPAGE="http://os.ghalkes.nl/dwdiff.html"
+SRC_URI="http://os.ghalkes.nl/dist/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls"
+
+CDEPEND="dev-libs/icu:="
+
+RDEPEND="
+ ${CDEPEND}
+ sys-apps/diffutils"
+
+DEPEND="
+ ${CDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/INSTALL/s:COPYING::' \
+ Makefile.in || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ $(use_with nls gettext)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install
+}