summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-02 23:35:31 +0100
committerSam James <sam@gentoo.org>2022-10-03 01:38:09 +0100
commit7aade44ba5794c724a4220949d76455f4c1db1d6 (patch)
tree31b7a4b1db1cc0685360de779b7683749c4ec84d /dev-util
parentapp-dicts/eblook: add 1.6.1_p16 (Debian fork, fixes build w/ Clang 16+) (diff)
downloadgentoo-7aade44ba5794c724a4220949d76455f4c1db1d6.tar.gz
gentoo-7aade44ba5794c724a4220949d76455f4c1db1d6.tar.bz2
gentoo-7aade44ba5794c724a4220949d76455f4c1db1d6.zip
dev-util/global: fix build with Clang 16
Closes: https://bugs.gentoo.org/870988 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/global/files/global-6.6.4-Fix-build-with-Clang-16.patch19
-rw-r--r--dev-util/global/global-6.6.4.ebuild3
2 files changed, 21 insertions, 1 deletions
diff --git a/dev-util/global/files/global-6.6.4-Fix-build-with-Clang-16.patch b/dev-util/global/files/global-6.6.4-Fix-build-with-Clang-16.patch
new file mode 100644
index 000000000000..a0398b46295b
--- /dev/null
+++ b/dev-util/global/files/global-6.6.4-Fix-build-with-Clang-16.patch
@@ -0,0 +1,19 @@
+From 13f045457f08e349d6bb3f3e98a3b59c73f32bbc Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 2 Oct 2022 23:34:05 +0100
+Subject: [PATCH] Fix build with Clang 16
+
+Bug: https://lists.gnu.org/archive/html/bug-global/2021-02/msg00012.html
+Bug: https://bugs.gentoo.org/870988
+--- a/configure.ac
++++ b/configure.ac
+@@ -74,7 +74,8 @@ case "$host_os" in
+ AC_MSG_CHECKING(whether POSIX.1-2008 realpath is equipped)
+ AC_CACHE_VAL(ac_cv_posix1_2008_realpath,
+ [AC_RUN_IFELSE([AC_LANG_SOURCE([[
+-main(){ (void)realpath("/./tmp", (void *)0); return 0; }
++#include <stdlib.h>
++int main(){ (void)realpath("/./tmp", (void *)0); return 0; }
+ ]])],[ac_cv_posix1_2008_realpath=yes],
+ [ac_cv_posix1_2008_realpath=no])])
+ AC_MSG_RESULT($ac_cv_posix1_2008_realpath)
diff --git a/dev-util/global/global-6.6.4.ebuild b/dev-util/global/global-6.6.4.ebuild
index 48f5dfdc0a92..1343cfa448b5 100644
--- a/dev-util/global/global-6.6.4.ebuild
+++ b/dev-util/global/global-6.6.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -38,6 +38,7 @@ SITEFILE="50gtags-gentoo.el"
PATCHES=(
"${FILESDIR}/${PN}-6.2.9-tinfo.patch"
"${FILESDIR}/${PN}-6.6.4-fno-common.patch"
+ "${FILESDIR}/${PN}-6.6.4-Fix-build-with-Clang-16.patch"
)
DOCS=( AUTHORS FAQ NEWS README THANKS )