summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-03-25 19:56:27 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-03-25 19:57:25 +0100
commitc0949e2433e3df04e999fae30e37be4cbce331b6 (patch)
treeede3b914e01856517bfe807a6152e50f31c966f1 /dev-util
parentdev-util/pycharm-professional: Remove old (diff)
downloadgentoo-c0949e2433e3df04e999fae30e37be4cbce331b6.tar.gz
gentoo-c0949e2433e3df04e999fae30e37be4cbce331b6.tar.bz2
gentoo-c0949e2433e3df04e999fae30e37be4cbce331b6.zip
dev-util/pycharm-community: Require Java 1.8
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pycharm-community/pycharm-community-2016.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/pycharm-community-2016.1-r1.ebuild b/dev-util/pycharm-community/pycharm-community-2016.1-r1.ebuild
new file mode 100644
index 000000000000..ebcaeb344146
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2016.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils readme.gentoo
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="/opt/${PN}/bin/fsnotifier
+ /opt/${PN}/bin/fsnotifier64"
+
+MY_PN=${PN/-community/}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon "bin/${MY_PN}.png" ${PN}.png
+ make_desktop_entry ${PN} "${PN}" "${PN}"
+
+ readme.gentoo_src_install
+}