summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-09-24 14:07:06 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-09-24 14:07:06 -0500
commitf1094ba119eec76b1bd46980fe47ba2482b52dc5 (patch)
treeb7dbb0811658cb47fbdd1e8c1488b32416f960f9 /dev-util
parentdev-lang/erlang: Stabilize 24.3.4.2 sparc, #872500 (diff)
downloadgentoo-f1094ba119eec76b1bd46980fe47ba2482b52dc5.tar.gz
gentoo-f1094ba119eec76b1bd46980fe47ba2482b52dc5.tar.bz2
gentoo-f1094ba119eec76b1bd46980fe47ba2482b52dc5.zip
dev-util/gitlab-runner: add 15.3.1
Closes: https://bugs.gentoo.org/872176 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.3.1.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index dfc70e2581c7..c65768fa903a 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -12,3 +12,5 @@ DIST gitlab-runner-15.2.1-deps.tar.xz 141242072 BLAKE2B 598850f3614772cad485a994
DIST gitlab-runner-15.2.1.tar.gz 1291638 BLAKE2B 7f2c7100ab5a7e670f8d50ea9dccd5f96b23b4e7ba60f928d732edc3a5f50b10afcfe9ffb052c4242ee401a21a0ddfad14e398a6a133ac093f3bbab84b620b0e SHA512 ed165fd95094dd00450bd2ffbbe876235849fdd98ff0ffc6ce635a103f426d4380573ef8c71f5a40d115fa6fe7ec9416b1c7b780f1563e8b3d4c4a09c02519f7
DIST gitlab-runner-15.3.0-deps.tar.xz 141251000 BLAKE2B e72c597a10e78f234f7879ff77ecbd787f8a056116f70ed683b82af47bbc701157e23b1e72e9707598796b30e2a747813049984091058c97098436806b18ed66 SHA512 1956885e185854db3f4d6a40aaebd6c6010879d2baf6f910e5fae3f1ed2ba71c4896761a30a8b29c625af2770cb57e5a0a84dc85441096e9d66ed644cab76765
DIST gitlab-runner-15.3.0.tar.gz 1306073 BLAKE2B cc7f1902e7cfc7577e936b411ae7f582c25757ed5d59cc5d61bb8f9c027ce292c7aac46788a44be78686f1705d5722373a9f5f2b295fd1eab2666e749fc50e06 SHA512 8eabe9a4fd04e46d4bf306dc202664e29f5cb12cba5d73820888957d694711702e026f79a84e1d5f5237cb3d1e7efed8e035129814dcc6354e708ee98e98cbe9
+DIST gitlab-runner-15.3.1-deps.tar.xz 141247556 BLAKE2B 8ea8e519efabfe54ff2a70477e713285a80889e6f001adae7263626db4086112964dcde328662a96c3c92d251e294fed6cd8023772f74be650a63f7d7fd2bd58 SHA512 047b4b3ac5e4fb6d493b5ae51219bcd60b056265a146d4001299ccaee491e5b6b0da8a3f1f84d4d44ae0e726b732c69d59851735283c78ddd6456ab9a7a87d49
+DIST gitlab-runner-15.3.1.tar.gz 1306831 BLAKE2B 032115edb7b0ae23d4f4083e542aa645e4f76fea04a63c5d3018080314081c82b2250d292b26b507101b627314d9142b0109f33fa8289a583010a5d692a6c1cd SHA512 62e543983e184c2e57189042f8281696e0428841890aef8779fce125041dbbd0626807491e5ae589e367f6b725fb93e663d94da3a051e2a9ec681b959c4bd85f
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.3.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.3.1.ebuild
new file mode 100644
index 000000000000..488e88ce1d88
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=447840fe
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+PATCHES=(
+ # https://gitlab.com/gitlab-org/gitlab-runner/-/merge_requests/3498
+ "${FILESDIR}"/build-for-arm64.patch
+ )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}