summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-04-26 16:23:50 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-04-26 16:24:08 +0100
commitd2f8aa85e22c399baf897fb8d45bf0a3ec667cc1 (patch)
tree9490815f87fcfc49545b30152ce456868a5f7ef4 /dev-vcs/cvs-fast-export
parentapp-admin/hcloud: regenerate Manifest, wrt bug #684422 (diff)
downloadgentoo-d2f8aa85e22c399baf897fb8d45bf0a3ec667cc1.tar.gz
gentoo-d2f8aa85e22c399baf897fb8d45bf0a3ec667cc1.tar.bz2
gentoo-d2f8aa85e22c399baf897fb8d45bf0a3ec667cc1.zip
dev-vcs/cvs-fast-export: bump up to 1.48
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-vcs/cvs-fast-export')
-rw-r--r--dev-vcs/cvs-fast-export/Manifest1
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.48.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index 29225c05f2a1..319ee3326240 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1,3 +1,4 @@
DIST cvs-fast-export-1.45.tar.gz 517917 BLAKE2B 47d0debe2ea4d5674630065ee320c5db71f7ab6e4b17b7850d28c1951359ea98c639639574a7c3a25b9ec4e09ff53f1c5db566bff070e6381061fd828e875061 SHA512 f3acadabdd74f2099003a0cda29b021ea2173127af1a358bcb855397be95edaff2b1f30d3cf31dd6c08e79a8bad07b80b826c374d9b5e43555ec60d08dd577e4
DIST cvs-fast-export-1.46.tar.gz 519521 BLAKE2B 7ecf0a87bef922a0fa69c1f63ab07e943e2a501c8565a610df3cb07e3af04b9abea02e78ae1d764c715e8e8b402cdc32f41e9109cee030d8339ebb8bdb97e561 SHA512 bd2e2a426bdfd76af06346c4a20469d134dd33ee98457afd8db3f1599e6f186451eb181057c97dd7383d35e66c4915f2cb42d51b818127cb3464c8cafc2f34f3
DIST cvs-fast-export-1.47.tar.gz 522489 BLAKE2B 5f83524137b38f863287feef9f95074dd40bc2189420abcf4d04cd02d686e21cc7fb26bf1e5fc3736efb04fe2e97202f1b4112483f420c7609fb208984c21095 SHA512 0da4b6d27e93c3bcf8ee0669acb0f15973f6eb3c566fd843755ac1176315220a23813d8ed72eba6f7429fa8ce5c00ed99d22fd9dd14e438473ff0a63c2d20cac
+DIST cvs-fast-export-1.48.tar.gz 524991 BLAKE2B d26cf7dfe07eacdf21f9a3627b12548acaf2d5fc3b1c871d4f91a8ddc1bdde621a6ed2eb93e57869a2cf5507e396fcc22d5ef800bb6966f4ad8488b6ebff5b4c SHA512 6a8398bed512abac1e8d5dffcb1fed14d5a0170f45a43f16dbde9fcfd068dc921cc22510a8d4d11ae9266a336da60a0dba33789aa447c013c5a800bf21055d7a
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.48.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.48.ebuild
new file mode 100644
index 000000000000..50babdf251fa
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.48.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship some tests in tarball
+
+src_prepare() {
+ default
+
+ tc-export CC
+ export prefix=/usr
+
+ # respect CC, CFLAGS and LDFLAGS
+ sed \
+ -e 's/cc /$(CC) $(LDFLAGS) /' \
+ -e 's/^CFLAGS += -O/#&/' \
+ -e 's/CFLAGS=/CFLAGS+=/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ # '.adoc.html' rules can't be executed in parallel
+ # as they reuse the same 'docbook-xsl.css' file name.
+ emake -j1 html
+ # Allow full parallelism for the rest
+ emake
+}
+
+src_install() {
+ default
+ dodoc README.adoc
+}