summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-08-14 10:59:57 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-08-14 10:59:57 -0400
commit1c7e6c84f0df839ba59090c34d8b43d5aa11bbfe (patch)
treeba1af11bb331b7443b79a4120d5fd81376d8f58c /dev-vcs/fossil/fossil-2.6.ebuild
parentapp-vim/gentoo-syntax: Bump to 20180814 snapshot (diff)
downloadgentoo-1c7e6c84f0df839ba59090c34d8b43d5aa11bbfe.tar.gz
gentoo-1c7e6c84f0df839ba59090c34d8b43d5aa11bbfe.tar.bz2
gentoo-1c7e6c84f0df839ba59090c34d8b43d5aa11bbfe.zip
dev-vcs/fossil: Bump to 2.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-vcs/fossil/fossil-2.6.ebuild')
-rw-r--r--dev-vcs/fossil/fossil-2.6.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-vcs/fossil/fossil-2.6.ebuild b/dev-vcs/fossil/fossil-2.6.ebuild
new file mode 100644
index 000000000000..4d67d2ea6c23
--- /dev/null
+++ b/dev-vcs/fossil/fossil-2.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/index.html/uv/fossil-src-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug fusefs json -legacy-mv-rm -miniz system-sqlite +ssl static
+ tcl tcl-stubs tcl-private-stubs th1-docs th1-hooks"
+
+REQUIRED_USE="ssl? ( !miniz )"
+
+DEPEND="
+ sys-libs/zlib
+ || ( sys-libs/readline:0 dev-libs/libedit )
+ system-sqlite? ( >=dev-db/sqlite-3.24.0:3 )
+ ssl? ( dev-libs/openssl:0 )
+ tcl? ( dev-lang/tcl:0= )
+"
+RDEPEND="${DEPEND}"
+
+# Tests can't be run from the build directory
+RESTRICT="test"
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf="--with-openssl=$(usex ssl auto none)"
+ use debug && myconf+=' --fossil-debug'
+ use json && myconf+=' --json'
+ use system-sqlite && myconf+=' --disable-internal-sqlite'
+ use static && myconf+=' --static'
+ use tcl && myconf+=' --with-tcl=1'
+ use fusefs || myconf+=' --disable-fusefs'
+
+ local u useflags
+ useflags=( legacy-mv-rm miniz tcl-stubs tcl-private-stubs
+ th1-docs th1-hooks )
+ for u in ${useflags[@]} ; do
+ use ${u} && myconf+=" --with-${u}"
+ done
+
+ tc-export CC
+ ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}