summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-20 09:41:52 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-20 09:42:30 +0200
commitd70745a4797b78af9ed560b7082d13c799df3b75 (patch)
tree979aebe2d10875004b42cbfc946bb2ec03d58099 /dev-vcs/gitg
parentdev-vcs/gitg: version bump 3.20.3 → 3.22.0 (diff)
downloadgentoo-d70745a4797b78af9ed560b7082d13c799df3b75.tar.gz
gentoo-d70745a4797b78af9ed560b7082d13c799df3b75.tar.bz2
gentoo-d70745a4797b78af9ed560b7082d13c799df3b75.zip
dev-vcs/gitg: cleanup old revisions
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-vcs/gitg')
-rw-r--r--dev-vcs/gitg/Manifest3
-rw-r--r--dev-vcs/gitg/gitg-3.18.0-r1.ebuild88
-rw-r--r--dev-vcs/gitg/gitg-3.20.1.ebuild83
-rw-r--r--dev-vcs/gitg/gitg-3.20.2.ebuild83
4 files changed, 0 insertions, 257 deletions
diff --git a/dev-vcs/gitg/Manifest b/dev-vcs/gitg/Manifest
index 0d20222740a..c6589d9635a 100644
--- a/dev-vcs/gitg/Manifest
+++ b/dev-vcs/gitg/Manifest
@@ -1,5 +1,2 @@
-DIST gitg-3.18.0.tar.xz 1413188 SHA256 fa4b7b9c492f13f5f1d864af1281ea377ac8c7619c856e05f533b18989edf421 SHA512 df6944df057d6863ec6a551749edf4d003bf9954c474b0d83ef1476747df210f1e7ead4d007dce06de6f84e25afcafb8aa4f61d8af703861c014c4189cf008d0 WHIRLPOOL 4a27708999e33a533988d62e94a2ad2ee6424184d9862e79bd5dd4a1033e38505672f407f492d9831465249cae68b20a112de6d5737286d28d6d952793c33265
-DIST gitg-3.20.1.tar.xz 1643492 SHA256 104420bcdd765fa2196a7b146ba1e0fa82a5686ed5ba9af40e31e88e601aa585 SHA512 e6ebf6ffb0ce05a23bd99114abb03332a03a40d37cadd118d342db347f69095cc64e983e092199d6125f7513b7535df117bf611470e1a6a36c6cc203f6659a20 WHIRLPOOL dbe97a0a9a66ad695fa42c55f283a2326503f8ad1cd901b6e3dd0ed95c9fbabc99cc8b3f926baed15a5b075e2734c4551812a03baca2f8ed1cb8e19f34be0ef8
-DIST gitg-3.20.2.tar.xz 1491092 SHA256 76cb421bbc5c1e57d4f58f9e63c7b77ed229cadc96c7de4296db60c46ee7d71b SHA512 4a63c74ed3ff9cf2ab95ed74df25ac572c55b5c1f4d5ad9e0d0c7faeba06b66b4b2a4cce200bce68c697995fd3e59a5ca9adbfe5a4bfc43cdfa5f5a2a4e39588 WHIRLPOOL 79d05f55a1da9623ae8496f1fc5ddd5a8729c41014ef6f4c5f6cccfa4310895fa469d2e942e54fb96fefe45721dee8d1de12ad14a0a22a2c3ca41c528c1f6729
DIST gitg-3.20.3.tar.xz 1491156 SHA256 4b0802360cdf1341b27a73458930768d139143b568b9153e93378f32f7ba6669 SHA512 3237e56cb6df9312715b4301e99a62c876923b126378b2bc433d1bea824769fde27383b69d89e8107b1e7fe50ef6fd5faaf3e26ed9b3f8c5bd6dfea2a87a5143 WHIRLPOOL 56547badde5d6c2192252e187574800e88e42dec8db2925ea61d23cafc1eb1d5a087f94fbee8d3c6bdf06f9bf7dc38578c3ab335a2304eef9fd4132ef56f31fa
DIST gitg-3.22.0.tar.xz 1507056 SHA256 ba6895f85c18748294075980a5e03e0936ad4e84534dbb0d8f9e29aa874ddeaf SHA512 2d59af3bb725c111966544ed6977002a901a862f0280c9acf117b2b613b00d889039ea780cad83bd624de5099256e48b99cdf0421362f154a8380e98f5f977da WHIRLPOOL 088819c4580c14268f420a6f745cc68f5ec0e22c88ce318792071773dc8ecf0a1e99d78639ec0dc561ba22366d8f9a1673be4c939cd5074c6c335fc03f86a819
diff --git a/dev-vcs/gitg/gitg-3.18.0-r1.ebuild b/dev-vcs/gitg/gitg-3.18.0-r1.ebuild
deleted file mode 100644
index 860644ae8fa..00000000000
--- a/dev-vcs/gitg/gitg-3.18.0-r1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python{3_3,3_4,3_5} )
-
-inherit gnome2 pax-utils python-r1 vala
-
-DESCRIPTION="git repository viewer for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Apps/Gitg"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-
-IUSE="debug glade +python"
-REQUIRED_USE="python? ( ^^ ( $(python_gen_useflags '*') ) )"
-
-# test if unbundling of libgd is possible
-# Currently it seems not to be (unstable API/ABI)
-RDEPEND="
- app-crypt/libsecret
- dev-libs/libgee:0.8[introspection]
- >=dev-libs/json-glib-0.16
- >=app-text/gtkspell-3.0.3:3
- >=dev-libs/glib-2.38:2[dbus]
- >=dev-libs/gobject-introspection-0.10.1:=
- dev-libs/libgit2:=[threads]
-
- >=dev-libs/libgit2-glib-0.23.5[ssh]
- <dev-libs/libgit2-glib-0.24.0
-
- >=dev-libs/libpeas-1.5.0[gtk]
- >=gnome-base/gsettings-desktop-schemas-0.1.1
- >=net-libs/webkit-gtk-2.2:4[introspection]
- >=x11-libs/gtk+-3.12.0:3
- >=x11-libs/gtksourceview-3.10:3.0
- >=x11-themes/gnome-icon-theme-symbolic-3.10
- glade? ( >=dev-util/glade-3.2:3.10 )
- python? (
- ${PYTHON_DEPS}
- dev-libs/libpeas[python,${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}
- >=dev-libs/libgit2-glib-0.22.0[vala]
- gnome-base/gnome-common
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
- >=dev-util/intltool-0.40
- $(vala_depend)
-"
-
-pkg_setup() {
- use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
-}
-
-src_prepare() {
- sed \
- -e '/CFLAGS/s:-g::g' \
- -e '/CFLAGS/s:-O0::g' \
- -i configure.ac || die
-
- gnome2_src_prepare
- vala_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-static \
- --disable-deprecations \
- $(use_enable debug) \
- $(use_enable glade glade-catalog) \
- $(use_enable python)
-}
-
-src_install() {
- gnome2_src_install -j1
-
- if has_version 'net-libs/webkit-gtk:4[jit]'; then
- # needed on hardened/PaX, see github pr 910 and bug #527334
- pax-mark m "${ED}usr/bin/gitg"
- fi
-}
diff --git a/dev-vcs/gitg/gitg-3.20.1.ebuild b/dev-vcs/gitg/gitg-3.20.1.ebuild
deleted file mode 100644
index 66b86dbc405..00000000000
--- a/dev-vcs/gitg/gitg-3.20.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python{3_3,3_4,3_5} )
-VALA_MIN_API_VERSION="0.32" # Needed when gtk+-3.20 is found
-
-inherit gnome2 pax-utils python-r1 vala
-
-DESCRIPTION="git repository viewer for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Apps/Gitg"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-IUSE="debug glade +python"
-REQUIRED_USE="python? ( ^^ ( $(python_gen_useflags '*') ) )"
-
-# test if unbundling of libgd is possible
-# Currently it seems not to be (unstable API/ABI)
-RDEPEND="
- app-crypt/libsecret
- dev-libs/libgee:0.8[introspection]
- >=app-text/gtkspell-3.0.3:3
- >=dev-libs/glib-2.38:2[dbus]
- >=dev-libs/gobject-introspection-0.10.1:=
- dev-libs/libgit2:=[threads]
-
- >=dev-libs/libgit2-glib-0.24.0[ssh]
- <dev-libs/libgit2-glib-0.25.0
-
- >=dev-libs/libpeas-1.5.0[gtk]
- >=dev-libs/libxml2-2.9.0:2
- net-libs/libsoup:2.4
- >=gnome-base/gsettings-desktop-schemas-0.1.1
- >=x11-libs/gtk+-3.20.0:3
- >=x11-libs/gtksourceview-3.10:3.0
- x11-themes/adwaita-icon-theme
- glade? ( >=dev-util/glade-3.2:3.10 )
- python? (
- ${PYTHON_DEPS}
- dev-libs/libpeas[python,${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}
- $(vala_depend)
- >=dev-libs/libgit2-glib-0.22.0[vala]
- gnome-base/gnome-common
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
- >=dev-util/intltool-0.40
-"
-
-pkg_setup() {
- use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
-}
-
-src_prepare() {
- sed \
- -e '/CFLAGS/s:-g::g' \
- -e '/CFLAGS/s:-O0::g' \
- -i configure.ac || die
-
- gnome2_src_prepare
- vala_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-static \
- --disable-deprecations \
- $(use_enable debug) \
- $(use_enable glade glade-catalog) \
- $(use_enable python)
-}
-
-src_install() {
- gnome2_src_install -j1
-}
diff --git a/dev-vcs/gitg/gitg-3.20.2.ebuild b/dev-vcs/gitg/gitg-3.20.2.ebuild
deleted file mode 100644
index 66b86dbc405..00000000000
--- a/dev-vcs/gitg/gitg-3.20.2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python{3_3,3_4,3_5} )
-VALA_MIN_API_VERSION="0.32" # Needed when gtk+-3.20 is found
-
-inherit gnome2 pax-utils python-r1 vala
-
-DESCRIPTION="git repository viewer for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Apps/Gitg"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-IUSE="debug glade +python"
-REQUIRED_USE="python? ( ^^ ( $(python_gen_useflags '*') ) )"
-
-# test if unbundling of libgd is possible
-# Currently it seems not to be (unstable API/ABI)
-RDEPEND="
- app-crypt/libsecret
- dev-libs/libgee:0.8[introspection]
- >=app-text/gtkspell-3.0.3:3
- >=dev-libs/glib-2.38:2[dbus]
- >=dev-libs/gobject-introspection-0.10.1:=
- dev-libs/libgit2:=[threads]
-
- >=dev-libs/libgit2-glib-0.24.0[ssh]
- <dev-libs/libgit2-glib-0.25.0
-
- >=dev-libs/libpeas-1.5.0[gtk]
- >=dev-libs/libxml2-2.9.0:2
- net-libs/libsoup:2.4
- >=gnome-base/gsettings-desktop-schemas-0.1.1
- >=x11-libs/gtk+-3.20.0:3
- >=x11-libs/gtksourceview-3.10:3.0
- x11-themes/adwaita-icon-theme
- glade? ( >=dev-util/glade-3.2:3.10 )
- python? (
- ${PYTHON_DEPS}
- dev-libs/libpeas[python,${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}
- $(vala_depend)
- >=dev-libs/libgit2-glib-0.22.0[vala]
- gnome-base/gnome-common
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
- >=dev-util/intltool-0.40
-"
-
-pkg_setup() {
- use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
-}
-
-src_prepare() {
- sed \
- -e '/CFLAGS/s:-g::g' \
- -e '/CFLAGS/s:-O0::g' \
- -i configure.ac || die
-
- gnome2_src_prepare
- vala_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-static \
- --disable-deprecations \
- $(use_enable debug) \
- $(use_enable glade glade-catalog) \
- $(use_enable python)
-}
-
-src_install() {
- gnome2_src_install -j1
-}