summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2016-12-25 09:47:52 -0800
committerLars Wendler <polynomial-c@gentoo.org>2016-12-26 17:05:04 +0100
commit076cafffdbbb06c50da7ab174fbee4c6be05bcb0 (patch)
tree9d386b8d6bebda36e805d2468b2a9db413420169 /dev-vcs
parentdev-lang/perl: Fix ndbm inclusion (diff)
downloadgentoo-076cafffdbbb06c50da7ab174fbee4c6be05bcb0.tar.gz
gentoo-076cafffdbbb06c50da7ab174fbee4c6be05bcb0.tar.bz2
gentoo-076cafffdbbb06c50da7ab174fbee4c6be05bcb0.zip
dev-vcs/git: Fix build on musl
2.10.1+ introduce a configuration option which enables non-posix compatible regex by default, which breaks compilation on musl. Gentoo-Bug: https://bugs.gentoo.org/603710 Closes: https://github.com/gentoo/gentoo/pull/3237
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.10.1.ebuild2
-rw-r--r--dev-vcs/git/git-2.10.2.ebuild2
-rw-r--r--dev-vcs/git/git-2.11.0.ebuild2
-rw-r--r--dev-vcs/git/git-2.11.0_rc2.ebuild2
4 files changed, 8 insertions, 0 deletions
diff --git a/dev-vcs/git/git-2.10.1.ebuild b/dev-vcs/git/git-2.10.1.ebuild
index da2cc395b011..bf2f4b52979c 100644
--- a/dev-vcs/git/git-2.10.1.ebuild
+++ b/dev-vcs/git/git-2.10.1.ebuild
@@ -191,6 +191,8 @@ exportmakeopts() {
|| myopts+=" NO_PTHREADS=YesPlease"
use cvs \
|| myopts+=" NO_CVS=YesPlease"
+ use elibc_musl \
+ && myopts+=" NO_REGEX=YesPlease"
# Disabled until ~m68k-mint can be keyworded again
# if [[ ${CHOST} == *-mint* ]] ; then
# myopts+=" NO_MMAP=YesPlease"
diff --git a/dev-vcs/git/git-2.10.2.ebuild b/dev-vcs/git/git-2.10.2.ebuild
index f82defc1ca3a..ffc7e53f2605 100644
--- a/dev-vcs/git/git-2.10.2.ebuild
+++ b/dev-vcs/git/git-2.10.2.ebuild
@@ -191,6 +191,8 @@ exportmakeopts() {
|| myopts+=" NO_PTHREADS=YesPlease"
use cvs \
|| myopts+=" NO_CVS=YesPlease"
+ use elibc_musl \
+ && myopts+=" NO_REGEX=YesPlease"
# Disabled until ~m68k-mint can be keyworded again
# if [[ ${CHOST} == *-mint* ]] ; then
# myopts+=" NO_MMAP=YesPlease"
diff --git a/dev-vcs/git/git-2.11.0.ebuild b/dev-vcs/git/git-2.11.0.ebuild
index c4271de825c6..82ef7b1feb25 100644
--- a/dev-vcs/git/git-2.11.0.ebuild
+++ b/dev-vcs/git/git-2.11.0.ebuild
@@ -192,6 +192,8 @@ exportmakeopts() {
|| myopts+=" NO_PTHREADS=YesPlease"
use cvs \
|| myopts+=" NO_CVS=YesPlease"
+ use elibc_musl \
+ && myopts+=" NO_REGEX=YesPlease"
# Disabled until ~m68k-mint can be keyworded again
# if [[ ${CHOST} == *-mint* ]] ; then
# myopts+=" NO_MMAP=YesPlease"
diff --git a/dev-vcs/git/git-2.11.0_rc2.ebuild b/dev-vcs/git/git-2.11.0_rc2.ebuild
index c4271de825c6..82ef7b1feb25 100644
--- a/dev-vcs/git/git-2.11.0_rc2.ebuild
+++ b/dev-vcs/git/git-2.11.0_rc2.ebuild
@@ -192,6 +192,8 @@ exportmakeopts() {
|| myopts+=" NO_PTHREADS=YesPlease"
use cvs \
|| myopts+=" NO_CVS=YesPlease"
+ use elibc_musl \
+ && myopts+=" NO_REGEX=YesPlease"
# Disabled until ~m68k-mint can be keyworded again
# if [[ ${CHOST} == *-mint* ]] ; then
# myopts+=" NO_MMAP=YesPlease"