summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-10 20:58:43 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-10 21:00:31 -0800
commit4e68999b34c72aab62570290874265c8d22968c1 (patch)
tree278909f5c2fc07cf5b52331e9891d600a3929164 /dev-vcs
parenteclass/cargo.eclass: add CARGO_OPTIONAL condition (diff)
downloadgentoo-4e68999b34c72aab62570290874265c8d22968c1.tar.gz
gentoo-4e68999b34c72aab62570290874265c8d22968c1.tar.bz2
gentoo-4e68999b34c72aab62570290874265c8d22968c1.zip
dev-vcs/mercurial: make cargo optional
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/mercurial-5.6.ebuild4
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild3
2 files changed, 5 insertions, 2 deletions
diff --git a/dev-vcs/mercurial/mercurial-5.6.ebuild b/dev-vcs/mercurial/mercurial-5.6.ebuild
index a44702205294..20bb67f7f3f2 100644
--- a/dev-vcs/mercurial/mercurial-5.6.ebuild
+++ b/dev-vcs/mercurial/mercurial-5.6.ebuild
@@ -6,6 +6,8 @@ EAPI=7
PYTHON_COMPAT=( python3_{6..8} )
PYTHON_REQ_USE="threads(+)"
DISTUTILS_USE_SETUPTOOLS=no
+CARGO_OPTIONAL=1
+
CRATES="
adler-0.2.3
aho-corasick-0.7.13
@@ -105,7 +107,7 @@ zstd-safe-2.0.5+zstd.1.4.5
zstd-sys-1.4.17+zstd.1.4.5
"
-inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic cargo
+inherit bash-completion-r1 cargo elisp-common eutils distutils-r1 flag-o-matic
DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index 8ec439342afb..1a93cf4212cf 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -6,8 +6,9 @@ EAPI=7
PYTHON_COMPAT=( python3_{6..8} )
PYTHON_REQ_USE="threads(+)"
DISTUTILS_USE_SETUPTOOLS=no
+CARGO_OPTIONAL=1
-inherit bash-completion-r1 elisp-common eutils distutils-r1 mercurial flag-o-matic cargo
+inherit bash-completion-r1 cargo elisp-common eutils distutils-r1 mercurial flag-o-matic
DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"