summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-11 20:21:21 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-11 20:21:21 +0000
commit60794b02dbbaa13dce015cc32f616c1e0102c828 (patch)
treee249f5c773f6de01e500be8ebe322c064a759e87 /dev-vcs
parentdev-vcs/git: stable 2.24.1 for sparc, bug #702296 (diff)
downloadgentoo-60794b02dbbaa13dce015cc32f616c1e0102c828.tar.gz
gentoo-60794b02dbbaa13dce015cc32f616c1e0102c828.tar.bz2
gentoo-60794b02dbbaa13dce015cc32f616c1e0102c828.zip
dev-vcs/cvs-fast-export: bump up to 1.49
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvs-fast-export/Manifest1
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.49.ebuild52
-rw-r--r--dev-vcs/cvs-fast-export/files/cvs-fast-export-1.49-man-prefix.patch7
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index 629662c987a5..0a1231632002 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1,2 +1,3 @@
DIST cvs-fast-export-1.47.tar.gz 522489 BLAKE2B 5f83524137b38f863287feef9f95074dd40bc2189420abcf4d04cd02d686e21cc7fb26bf1e5fc3736efb04fe2e97202f1b4112483f420c7609fb208984c21095 SHA512 0da4b6d27e93c3bcf8ee0669acb0f15973f6eb3c566fd843755ac1176315220a23813d8ed72eba6f7429fa8ce5c00ed99d22fd9dd14e438473ff0a63c2d20cac
DIST cvs-fast-export-1.48.tar.gz 524991 BLAKE2B d26cf7dfe07eacdf21f9a3627b12548acaf2d5fc3b1c871d4f91a8ddc1bdde621a6ed2eb93e57869a2cf5507e396fcc22d5ef800bb6966f4ad8488b6ebff5b4c SHA512 6a8398bed512abac1e8d5dffcb1fed14d5a0170f45a43f16dbde9fcfd068dc921cc22510a8d4d11ae9266a336da60a0dba33789aa447c013c5a800bf21055d7a
+DIST cvs-fast-export-1.49.tar.gz 446347 BLAKE2B 0b26ed771eec6320a6fc9def82e10dc82bb66f166b07d900cfbae89780bbdd783d0f7fb2d56c780d4ed788a2c07f41943f1b7f84394b5376dd10175f86384482 SHA512 24630c68af954b5f6051aca5d3af9e440189a2a062c8519892cc3a2d977f650a6ba340031f978555fbf9613cf7f9f5cea766f89d3f0ad34f188a4562a0d507f4
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.49.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.49.ebuild
new file mode 100644
index 000000000000..da8067316880
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.49.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-man-prefix.patch
+)
+
+RESTRICT=test # upstream does not ship some tests in tarball
+
+src_prepare() {
+ default
+
+ tc-export CC
+ export prefix=/usr
+
+ # respect CC, CFLAGS and LDFLAGS
+ sed \
+ -e 's/cc /$(CC) $(LDFLAGS) /' \
+ -e 's/^CFLAGS += -O/#&/' \
+ -e 's/CFLAGS=/CFLAGS+=/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ # '.adoc.html' rules can't be executed in parallel
+ # as they reuse the same 'docbook-xsl.css' file name.
+ emake -j1 html
+ # Allow full parallelism for the rest
+ emake
+}
+
+src_install() {
+ default
+ dodoc README.adoc
+}
diff --git a/dev-vcs/cvs-fast-export/files/cvs-fast-export-1.49-man-prefix.patch b/dev-vcs/cvs-fast-export/files/cvs-fast-export-1.49-man-prefix.patch
new file mode 100644
index 000000000000..d65fb0683efd
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/files/cvs-fast-export-1.49-man-prefix.patch
@@ -0,0 +1,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -27,3 +27,3 @@ srcdir=$(dir $(abspath $(firstword $(MAKEFILE_LIST))))$(parsedir)
+ VPATH=$(srcdir)
+-mandir?=$(prefix)/share/man
++mandir?=$(DESTDIR)$(prefix)/share/man
+