summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-03-23 20:47:04 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-03-23 20:47:22 +0100
commita44c5d0594de93b2dcb3c5b0f52e98be08e0468a (patch)
tree2b2c8a5f4c9fb4b5580b323946ffc6c907b07ad3 /dev-vcs
parentmedia-radio/tqsl: use cmake-utils src_prepare (diff)
downloadgentoo-a44c5d0594de93b2dcb3c5b0f52e98be08e0468a.tar.gz
gentoo-a44c5d0594de93b2dcb3c5b0f52e98be08e0468a.tar.bz2
gentoo-a44c5d0594de93b2dcb3c5b0f52e98be08e0468a.zip
dev-vcs/git: Unpack man pages into ${S}
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.17.0_rc1.ebuild1
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild1
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild1
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild1
-rw-r--r--dev-vcs/git/git-9999.ebuild1
5 files changed, 5 insertions, 0 deletions
diff --git a/dev-vcs/git/git-2.17.0_rc1.ebuild b/dev-vcs/git/git-2.17.0_rc1.ebuild
index 29ff3e4669de..9079b03f7b10 100644
--- a/dev-vcs/git/git-2.17.0_rc1.ebuild
+++ b/dev-vcs/git/git-2.17.0_rc1.ebuild
@@ -254,6 +254,7 @@ exportmakeopts() {
src_unpack() {
if [[ ${PV} != *9999 ]]; then
unpack ${MY_P}.tar.${SRC_URI_SUFFIX}
+ cd "${S}" || die
unpack ${PN}-manpages-${DOC_VER}.tar.${SRC_URI_SUFFIX}
if use doc ; then
pushd "${S}"/Documentation &>/dev/null || die
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 29ff3e4669de..9079b03f7b10 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -254,6 +254,7 @@ exportmakeopts() {
src_unpack() {
if [[ ${PV} != *9999 ]]; then
unpack ${MY_P}.tar.${SRC_URI_SUFFIX}
+ cd "${S}" || die
unpack ${PN}-manpages-${DOC_VER}.tar.${SRC_URI_SUFFIX}
if use doc ; then
pushd "${S}"/Documentation &>/dev/null || die
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 29ff3e4669de..9079b03f7b10 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -254,6 +254,7 @@ exportmakeopts() {
src_unpack() {
if [[ ${PV} != *9999 ]]; then
unpack ${MY_P}.tar.${SRC_URI_SUFFIX}
+ cd "${S}" || die
unpack ${PN}-manpages-${DOC_VER}.tar.${SRC_URI_SUFFIX}
if use doc ; then
pushd "${S}"/Documentation &>/dev/null || die
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 29ff3e4669de..9079b03f7b10 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -254,6 +254,7 @@ exportmakeopts() {
src_unpack() {
if [[ ${PV} != *9999 ]]; then
unpack ${MY_P}.tar.${SRC_URI_SUFFIX}
+ cd "${S}" || die
unpack ${PN}-manpages-${DOC_VER}.tar.${SRC_URI_SUFFIX}
if use doc ; then
pushd "${S}"/Documentation &>/dev/null || die
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 29ff3e4669de..9079b03f7b10 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -254,6 +254,7 @@ exportmakeopts() {
src_unpack() {
if [[ ${PV} != *9999 ]]; then
unpack ${MY_P}.tar.${SRC_URI_SUFFIX}
+ cd "${S}" || die
unpack ${PN}-manpages-${DOC_VER}.tar.${SRC_URI_SUFFIX}
if use doc ; then
pushd "${S}"/Documentation &>/dev/null || die