summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-12-17 00:49:32 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-18 11:02:50 +0100
commitd57290d4bfea89e31f93047a634d4f74b25c167b (patch)
treef762b6f5bd412a177af928c34bc74882f8c1c5d0 /eclass/kde5.eclass
parentkde-apps/kde-l10n: Block <kde-apps/kwave-16.11.50 for file collisions (diff)
downloadgentoo-d57290d4bfea89e31f93047a634d4f74b25c167b.tar.gz
gentoo-d57290d4bfea89e31f93047a634d4f74b25c167b.tar.bz2
gentoo-d57290d4bfea89e31f93047a634d4f74b25c167b.zip
kde5.eclass: Fix configure with >=kde-apps/kde-l10n-16.12.0 L10N=sr
Upstream added a subdirectory that should not be added to the project. Closes: https://github.com/gentoo/gentoo/pull/3139 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'eclass/kde5.eclass')
-rw-r--r--eclass/kde5.eclass4
1 files changed, 3 insertions, 1 deletions
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index 3669536737d3..ebdd790de334 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -773,7 +773,9 @@ _l10n_variant_subdir_buster() {
esac
for subdir in $(find ${dir} -mindepth 1 -maxdepth 1 -type d | sed -e "s:^\./::"); do
- echo "add_subdirectory(${subdir##*/})" >> ${dir}/CMakeLists.txt
+ if [[ ${subdir##*/} != "cmake_modules" ]] ; then
+ echo "add_subdirectory(${subdir##*/})" >> ${dir}/CMakeLists.txt || die
+ fi
done
}