summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-18 20:41:29 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-28 20:09:06 +0100
commita2c3f26426b435b090b19057d52ceec5364b19ed (patch)
treeca662f7acf6e990649836af877965386bdf58415 /eclass/python-utils-r1.eclass
parentpython-utils-r1.eclass: Replace local INSDESTTREE with subshells (diff)
downloadgentoo-a2c3f26426b435b090b19057d52ceec5364b19ed.tar.gz
gentoo-a2c3f26426b435b090b19057d52ceec5364b19ed.tar.bz2
gentoo-a2c3f26426b435b090b19057d52ceec5364b19ed.zip
python-utils-r1.eclass: Ban installation helpers in EAPIs < 5
Ban python_do* and python_new* helpers in EAPIs older than 5. We should ban them in python-any-r1 uses, actually but that would break dev-python/pypy* ebuilds as they are written now.
Diffstat (limited to 'eclass/python-utils-r1.eclass')
-rw-r--r--eclass/python-utils-r1.eclass9
1 files changed, 9 insertions, 0 deletions
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index f27fdf05262..236df89c12e 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -665,6 +665,9 @@ python_newexe() {
[[ ${EPYTHON} ]] || die 'No Python implementation set (EPYTHON is null).'
[[ ${#} -eq 2 ]] || die "Usage: ${FUNCNAME} <path> <new-name>"
+ if [[ ${EAPI:-0} == [01234] ]]; then
+ die "python_do* and python_new* helpers are banned in EAPIs older than 5."
+ fi
local wrapd=${python_scriptroot:-${DESTTREE}/bin}
@@ -792,6 +795,9 @@ python_domodule() {
debug-print-function ${FUNCNAME} "${@}"
[[ ${EPYTHON} ]] || die 'No Python implementation set (EPYTHON is null).'
+ if [[ ${EAPI:-0} == [01234] ]]; then
+ die "python_do* and python_new* helpers are banned in EAPIs older than 5."
+ fi
local d
if [[ ${python_moduleroot} == /* ]]; then
@@ -830,6 +836,9 @@ python_doheader() {
debug-print-function ${FUNCNAME} "${@}"
[[ ${EPYTHON} ]] || die 'No Python implementation set (EPYTHON is null).'
+ if [[ ${EAPI:-0} == [01234] ]]; then
+ die "python_do* and python_new* helpers are banned in EAPIs older than 5."
+ fi
local d PYTHON_INCLUDEDIR=${PYTHON_INCLUDEDIR}
[[ ${PYTHON_INCLUDEDIR} ]] || python_export PYTHON_INCLUDEDIR