summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-12 11:41:51 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-12 11:41:51 +0100
commit87ac40ce74f7529302f79d2ec12d9fded0a289cb (patch)
treed512917eff33555e32b564cd59c2ccc89e6e0e33 /eclass/readme.gentoo.eclass
parentRevert "readme.gentoo.eclass: Enable EAPI 6." (diff)
downloadgentoo-87ac40ce74f7529302f79d2ec12d9fded0a289cb.tar.gz
gentoo-87ac40ce74f7529302f79d2ec12d9fded0a289cb.tar.bz2
gentoo-87ac40ce74f7529302f79d2ec12d9fded0a289cb.zip
eclass/readme.gentoo.eclass: Add EAPI6 support, stop exporting functions for that EAPI as explained at bug #520094
Diffstat (limited to 'eclass/readme.gentoo.eclass')
-rw-r--r--eclass/readme.gentoo.eclass9
1 files changed, 6 insertions, 3 deletions
diff --git a/eclass/readme.gentoo.eclass b/eclass/readme.gentoo.eclass
index fdef2fe19cb..741287ab473 100644
--- a/eclass/readme.gentoo.eclass
+++ b/eclass/readme.gentoo.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -28,14 +28,17 @@ case "${EAPI:-0}" in
# EAPI>=4 is required for REPLACING_VERSIONS preventing us
# from needing to export another pkg_preinst phase to save has_version
# result. Also relies on EAPI >=4 default src_install phase.
+ EXPORT_FUNCTIONS src_install pkg_postinst
+ ;;
+ 6)
+ # Stop exporting default functions as discussed at:
+ # https://bugs.gentoo.org/show_bug.cgi?id=520094
;;
*)
die "Unsupported EAPI=${EAPI} (unknown) for ${ECLASS}"
;;
esac
-EXPORT_FUNCTIONS src_install pkg_postinst
-
# @ECLASS-VARIABLE: DISABLE_AUTOFORMATTING
# @DEFAULT_UNSET
# @DESCRIPTION: