summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 22:05:17 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:10:26 +0100
commit594fc996480a61320a0a1b2458a7fbf4bb3c400f (patch)
tree58431fdb792b907b71fc0f6ea14812fcbb530c2a /eclass
parentdistutils-r1.eclass: Switch test deps to PYTHON_MULTI_USEDEP (diff)
downloadgentoo-594fc996480a61320a0a1b2458a7fbf4bb3c400f.tar.gz
gentoo-594fc996480a61320a0a1b2458a7fbf4bb3c400f.tar.bz2
gentoo-594fc996480a61320a0a1b2458a7fbf4bb3c400f.zip
scons-utils.eclass: Migrate to PYTHON_MULTI_USEDEP
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/scons-utils.eclass7
1 files changed, 4 insertions, 3 deletions
diff --git a/eclass/scons-utils.eclass b/eclass/scons-utils.eclass
index 35cf4e32218..33838e3ec8b 100644
--- a/eclass/scons-utils.eclass
+++ b/eclass/scons-utils.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: scons-utils.eclass
@@ -126,8 +126,9 @@ if [[ ${_PYTHON_ANY_R1} ]]; then
}
python_check_deps() { scons-utils_python_check_deps; }
elif [[ ${_PYTHON_SINGLE_R1} ]]; then
- # when using python-single-r1, use plain PYTHON_USEDEP API
- BDEPEND="${SCONS_DEPEND}[${PYTHON_USEDEP}]
+ # when using python-single-r1, use PYTHON_MULTI_USEDEP API
+ BDEPEND="
+ $(python_gen_cond_dep "${SCONS_DEPEND}[\${PYTHON_MULTI_USEDEP}]")
${PYTHON_DEPS}"
elif [[ ${EAPI:-0} == [0123456] ]]; then
# in older EAPIs, just force Python 2.7