summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-29 11:06:10 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-29 11:17:03 -0400
commit87e80c5f4f04419eb8ec2986b2713ef59e7969fd (patch)
treead0282683690e101f99e52454b1e4faf1dd9c358 /eclass
parentdev-vcs/git: git-send-email.perl: Fixed sending of many changes/patches (diff)
downloadgentoo-87e80c5f4f04419eb8ec2986b2713ef59e7969fd.tar.gz
gentoo-87e80c5f4f04419eb8ec2986b2713ef59e7969fd.tar.bz2
gentoo-87e80c5f4f04419eb8ec2986b2713ef59e7969fd.zip
autotools.eclass: run libtoolize with --ltdl automatically #534088
Diffstat (limited to 'eclass')
-rw-r--r--eclass/autotools.eclass10
1 files changed, 8 insertions, 2 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 54e5d038af08..bc4032a35136 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -198,7 +198,7 @@ eautoreconf() {
intltool false "autotools_run_tool intltoolize --automake --copy --force"
gtkdoc false "autotools_run_tool --at-missing gtkdocize --copy"
gnomedoc false "autotools_run_tool --at-missing gnome-doc-prepare --copy --force"
- libtool false "_elibtoolize --install --copy --force"
+ libtool false "_elibtoolize --auto-ltdl --install --copy --force"
)
for (( i = 0; i < ${#tools[@]}; i += 3 )) ; do
if _at_uses_${tools[i]} ; then
@@ -264,6 +264,7 @@ _at_uses_intltool() { _at_uses_pkg {AC,IT}_PROG_INTLTOOL; }
_at_uses_gtkdoc() { _at_uses_pkg GTK_DOC_CHECK; }
_at_uses_gnomedoc() { _at_uses_pkg GNOME_DOC_INIT; }
_at_uses_libtool() { _at_uses_pkg A{C,M}_PROG_LIBTOOL LT_INIT; }
+_at_uses_libltdl() { _at_uses_pkg LT_CONFIG_LTDL_DIR; }
# @FUNCTION: eaclocal_amflags
# @DESCRIPTION:
@@ -313,6 +314,11 @@ eaclocal() {
_elibtoolize() {
local LIBTOOLIZE=${LIBTOOLIZE:-$(type -P glibtoolize > /dev/null && echo glibtoolize || echo libtoolize)}
+ if [[ $1 == "--auto-ltdl" ]] ; then
+ shift
+ _at_uses_libltdl && set -- "$@" --ltdl
+ fi
+
[[ -f GNUmakefile.am || -f Makefile.am ]] && set -- "$@" --automake
autotools_run_tool ${LIBTOOLIZE} "$@"
@@ -519,7 +525,7 @@ autotools_run_tool() {
# Keep a list of all the macros we might use so that we only
# have to run the trace code once. Order doesn't matter.
ALL_AUTOTOOLS_MACROS=(
- A{C,M}_PROG_LIBTOOL LT_INIT
+ A{C,M}_PROG_LIBTOOL LT_INIT LT_CONFIG_LTDL_DIR
A{C,M}_CONFIG_HEADER{S,}
AC_CONFIG_SUBDIRS
AC_CONFIG_AUX_DIR AC_CONFIG_MACRO_DIR