summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-07-14 17:03:03 -0700
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-10 22:54:07 +0100
commite4df47d60417b51aaf1cc526c124a21252d4fefe (patch)
treeb308fbaade92e0cb49348693f57366686720f276 /eclass
parentcmake-utils.eclass: Make ninja default backend in EAPI >= 7 (diff)
downloadgentoo-e4df47d60417b51aaf1cc526c124a21252d4fefe.tar.gz
gentoo-e4df47d60417b51aaf1cc526c124a21252d4fefe.tar.bz2
gentoo-e4df47d60417b51aaf1cc526c124a21252d4fefe.zip
cmake-utils.eclass: Enable BUILD_SHARED_LIBS by default in EAPI >= 7
* Many upstreams build static libraries by default, as this is simpler for distribution. Developers can still override this variable if required. Examples: https://github.com/pezmaster31/bamtools/blob/master/CMakeLists.txt#L64 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/cmake-utils.eclass1
1 files changed, 1 insertions, 0 deletions
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index 30ee97b99a36..43397aad8c28 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -630,6 +630,7 @@ cmake-utils_src_configure() {
if [[ ${EAPI} != [56] ]]; then
cat >> "${common_config}" <<- _EOF_ || die
SET (CMAKE_INSTALL_DOCDIR "${EPREFIX}/usr/share/doc/${PF}" CACHE PATH "")
+ SET (BUILD_SHARED_LIBS ON CACHE BOOLEAN "")
_EOF_
fi