summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/accelerator3d
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/accelerator3d')
-rw-r--r--games-action/accelerator3d/Manifest1
-rw-r--r--games-action/accelerator3d/accelerator3d-0.1.1-r2.ebuild45
-rw-r--r--games-action/accelerator3d/files/accelerator3d-0.1.1-gentoo-paths.patch53
-rw-r--r--games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch11
-rw-r--r--games-action/accelerator3d/metadata.xml8
5 files changed, 118 insertions, 0 deletions
diff --git a/games-action/accelerator3d/Manifest b/games-action/accelerator3d/Manifest
new file mode 100644
index 000000000000..0cd6132197d6
--- /dev/null
+++ b/games-action/accelerator3d/Manifest
@@ -0,0 +1 @@
+DIST accelerator-0.1.1.tar.bz2 1183838 SHA256 02fac1b6fc9bb5708f53ef7bcf123f5a4a04261e2764f984d3e3c64e06a74712 SHA512 f4321beb5f5b61c10d0b275321641ec173636267ae08cf88f7a2ecaaf0799cfe6593cbc7343c8ebfa72853c59773841295b1aca9a0ac0ef510de390107aa01da WHIRLPOOL e6d705361e24cd8eebabaf4c3a8b3ba803ea8d897ff93a48f3ec2f300d0f6ed0cf57b2ef036dd8e8bf031c6ab03ff6c97ca59f013400376a91d291270b0e14f0
diff --git a/games-action/accelerator3d/accelerator3d-0.1.1-r2.ebuild b/games-action/accelerator3d/accelerator3d-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..a59cbf7d958f
--- /dev/null
+++ b/games-action/accelerator3d/accelerator3d-0.1.1-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-r1 games
+
+DESCRIPTION="Fast-paced, 3D, first-person shoot/dodge-'em-up, in the vain of Tempest or n2o"
+HOMEPAGE="http://accelerator3d.sourceforge.net/"
+SRC_URI="mirror://sourceforge/accelerator3d/accelerator-${PV}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pyode[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo-paths.patch \
+ "${FILESDIR}"/${P}-gllightmodel.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ accelerator.py || die
+}
+
+src_install() {
+ python_scriptinto "${GAMES_BINDIR}"
+ python_foreach_impl python_newscript accelerator.py accelerator
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins gfx/* snd/*
+ dodoc CHANGELOG README
+ make_desktop_entry accelerator
+
+ prepgamesdirs
+}
diff --git a/games-action/accelerator3d/files/accelerator3d-0.1.1-gentoo-paths.patch b/games-action/accelerator3d/files/accelerator3d-0.1.1-gentoo-paths.patch
new file mode 100644
index 000000000000..ab8637f24f28
--- /dev/null
+++ b/games-action/accelerator3d/files/accelerator3d-0.1.1-gentoo-paths.patch
@@ -0,0 +1,53 @@
+--- accelerator.py.old 2006-04-18 21:51:28.000000000 +0200
++++ accelerator.py 2006-04-18 22:07:28.000000000 +0200
+@@ -72,7 +72,7 @@
+ # default parameters on it (min/mag filters, wrapping).
+ def __init__(self,texfile,mipmap = False):
+ global activeTexture
+- filename = os.path.join('gfx',texfile)
++ filename = os.path.join('@GENTOO_DATADIR@',texfile)
+ image = pygame.image.load(filename)
+ data = pygame.image.tostring(image,'RGBX')
+ self.__texref = glGenTextures(1)
+@@ -599,8 +599,8 @@
+ for i in xrange(len(self.__menu[j][0])):
+ font.addString(self.__menu[j][0][i])
+ if (soundon):
+- self.__browsesound = pygame.mixer.Sound(os.path.join('snd','menu_browse.wav'))
+- self.__selectsound = pygame.mixer.Sound(os.path.join('snd','menu_select.wav'))
++ self.__browsesound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','menu_browse.wav'))
++ self.__selectsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','menu_select.wav'))
+
+ def doLoop(self):
+ global elapsed, z_increment, font
+@@ -792,19 +792,19 @@
+
+ # sound!
+ if soundon:
+- self.__shootsound = pygame.mixer.Sound(os.path.join('snd','shoot.wav'))
+- self.__cluonsound = pygame.mixer.Sound(os.path.join('snd','cluon.wav'))
+- self.__bogonsound = pygame.mixer.Sound(os.path.join('snd','bogon.wav'))
+- self.__shipdeadsound = pygame.mixer.Sound(os.path.join('snd','ship_explode.wav'))
+- self.__shocksound = pygame.mixer.Sound(os.path.join('snd','electricshock.wav'))
+- self.__thudsound = pygame.mixer.Sound(os.path.join('snd','thud.wav'))
+- self.__enginesound = pygame.mixer.Sound(os.path.join('snd','engine.wav'))
+- self.__chargesound = pygame.mixer.Sound(os.path.join('snd','neon.wav'))
++ self.__shootsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','shoot.wav'))
++ self.__cluonsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','cluon.wav'))
++ self.__bogonsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','bogon.wav'))
++ self.__shipdeadsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','ship_explode.wav'))
++ self.__shocksound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','electricshock.wav'))
++ self.__thudsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','thud.wav'))
++ self.__enginesound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','engine.wav'))
++ self.__chargesound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','neon.wav'))
+ self.__chargeplaying = False
+- self.__scrapesound = pygame.mixer.Sound(os.path.join('snd','scrape.wav'))
++ self.__scrapesound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','scrape.wav'))
+ self.__scrapeplaying = False
+- self.__slamsound = pygame.mixer.Sound(os.path.join('snd','slam.wav'))
+- self.__phlogsound = pygame.mixer.Sound(os.path.join('snd','phlogiston.wav'))
++ self.__slamsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','slam.wav'))
++ self.__phlogsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','phlogiston.wav'))
+
+ # reserve channel 0 for bullet sounds
+ pygame.mixer.set_reserved(2)
diff --git a/games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch b/games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch
new file mode 100644
index 000000000000..b850ccfa5bab
--- /dev/null
+++ b/games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch
@@ -0,0 +1,11 @@
+--- accelerator.py
++++ accelerator.py
+@@ -274,7 +274,7 @@
+ glColorMaterial(GL_FRONT,GL_AMBIENT_AND_DIFFUSE)
+ glMaterialfv(GL_FRONT,GL_SHININESS,128)
+ glMaterialfv(GL_FRONT,GL_SPECULAR,(0.5,0.5,0.5,1))
+- glLightModel(GL_LIGHT_MODEL_COLOR_CONTROL_EXT,GL_SEPARATE_SPECULAR_COLOR_EXT) # GL_LIGHT_MODEL_COLOR_CONTROL, GL_SEPARATE_SPECULAR_COLOR
++ glLightModeli(GL_LIGHT_MODEL_COLOR_CONTROL_EXT,GL_SEPARATE_SPECULAR_COLOR_EXT) # GL_LIGHT_MODEL_COLOR_CONTROL, GL_SEPARATE_SPECULAR_COLOR
+ glEnable(GL_LINE_SMOOTH)
+ glEnable(GL_NORMALIZE)
+ #glPolygonMode(GL_FRONT,GL_LINE)
diff --git a/games-action/accelerator3d/metadata.xml b/games-action/accelerator3d/metadata.xml
new file mode 100644
index 000000000000..c22ed7a09453
--- /dev/null
+++ b/games-action/accelerator3d/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">accelerator3d</remote-id>
+ </upstream>
+</pkgmetadata>