summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/extreme-tuxracer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/extreme-tuxracer')
-rw-r--r--games-action/extreme-tuxracer/Manifest1
-rw-r--r--games-action/extreme-tuxracer/extreme-tuxracer-0.6.0.ebuild58
-rw-r--r--games-action/extreme-tuxracer/files/extreme-tuxracer-0.6.0-libsdl.patch39
-rw-r--r--games-action/extreme-tuxracer/files/extreme-tuxracer-0.6.0-segfault.patch8
-rw-r--r--games-action/extreme-tuxracer/files/extreme-tuxracer.svg210
-rw-r--r--games-action/extreme-tuxracer/metadata.xml12
6 files changed, 328 insertions, 0 deletions
diff --git a/games-action/extreme-tuxracer/Manifest b/games-action/extreme-tuxracer/Manifest
new file mode 100644
index 000000000000..b10a054370cd
--- /dev/null
+++ b/games-action/extreme-tuxracer/Manifest
@@ -0,0 +1 @@
+DIST etr-0.6.0.tar.xz 32889668 SHA256 44312719a1e9aa33e5aa0c8ad50bb52df702d64fd2d16bf2abda62ee27bf893a SHA512 c3127dd1f8d9b856cc42808713a53b48a64821f020ecf3bfaae8be96e36eaddfadfedcf394d445ea1f49df650763b50d35a5ad9cac03308bcb1a4a473e4906d8 WHIRLPOOL d003d5ef070ed15d4521cc2025ceb372b18b69f3172065159b5fd18bf5f2126da4cc8c179b95311c63afd5093ec2700483697544ade7ad02e1f255e1cdfc44e4
diff --git a/games-action/extreme-tuxracer/extreme-tuxracer-0.6.0.ebuild b/games-action/extreme-tuxracer/extreme-tuxracer-0.6.0.ebuild
new file mode 100644
index 000000000000..b35789992738
--- /dev/null
+++ b/games-action/extreme-tuxracer/extreme-tuxracer-0.6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools gnome2-utils games
+
+DESCRIPTION="High speed arctic racing game based on Tux Racer"
+HOMEPAGE="http://extremetuxracer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/extremetuxracer/etr-${PV/_/}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[X,joystick,sound,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ media-libs/freetype:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/etr-${PV/_/}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-libsdl.patch \
+ "${FILESDIR}"/${P}-segfault.patch
+ # kind of ugly in there so we'll do it ourselves
+ sed -i -e '/SUBDIRS/s/resources doc//' Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{code,courses_events,guide,score_algorithm}
+ doicon -s 48 resources/etr.png
+ newicon -s scalable resources/etracericon.svg etr.svg
+ domenu resources/etr.desktop
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/extreme-tuxracer/files/extreme-tuxracer-0.6.0-libsdl.patch b/games-action/extreme-tuxracer/files/extreme-tuxracer-0.6.0-libsdl.patch
new file mode 100644
index 000000000000..71378483c171
--- /dev/null
+++ b/games-action/extreme-tuxracer/files/extreme-tuxracer-0.6.0-libsdl.patch
@@ -0,0 +1,39 @@
+From 2c08358e424b36d50e6088e5acadc6d8ac2762a9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Fri, 16 May 2014 23:26:18 +0200
+Subject: [PATCH] Append SDL flags to CXXFLAGS rather than CFLAGS.
+
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 5646c82..b3732c8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -43,19 +43,19 @@ AC_FUNC_MALLOC
+ AC_CHECK_FUNCS([floor getcwd memmove memset mkdir pow sqrt strchr strdup])
+
+ AM_PATH_SDL([1.0.0])
+-CFLAGS="$CFLAGS $SDL_CFLAGS"
++CXXFLAGS="$CXXFLAGS $SDL_CFLAGS"
+ LIBS="$LIBS $SDL_LIBS"
+
+ PKG_CHECK_MODULES([SDLIMAGE], [SDL_image],
+ [
+- CFLAGS="${CFLAGS} $SDLIMAGE_CFLAGS"
++ CXXFLAGS="${CXXFLAGS} $SDLIMAGE_CFLAGS"
+ LIBS="${LIBS} $SDLIMAGE_LIBS"
+ ],
+ [AC_MSG_ERROR([SDL_image not found])])
+
+ PKG_CHECK_MODULES([SDLMIXER], [SDL_mixer],
+ [
+- CFLAGS="${CFLAGS} $SDLMIXER_CFLAGS"
++ CXXFLAGS="${CXXFLAGS} $SDLMIXER_CFLAGS"
+ LIBS="${LIBS} $SDLMIXER_LIBS"
+ ],
+ [AC_MSG_ERROR([SDL_mixer not found])])
+--
+1.9.3
+
diff --git a/games-action/extreme-tuxracer/files/extreme-tuxracer-0.6.0-segfault.patch b/games-action/extreme-tuxracer/files/extreme-tuxracer-0.6.0-segfault.patch
new file mode 100644
index 000000000000..c51014444267
--- /dev/null
+++ b/games-action/extreme-tuxracer/files/extreme-tuxracer-0.6.0-segfault.patch
@@ -0,0 +1,8 @@
+--- physics.cpp
++++ physics.cpp
+@@ -126,3 +126,5 @@
+ TCollidable *trees = &Course.CollArr[0];
++ if (trees == NULL)
++ return false;
+ size_t num_trees = Course.CollArr.size();
+ size_t tree_type = trees[0].tree_type;
diff --git a/games-action/extreme-tuxracer/files/extreme-tuxracer.svg b/games-action/extreme-tuxracer/files/extreme-tuxracer.svg
new file mode 100644
index 000000000000..1ee01ebb2ece
--- /dev/null
+++ b/games-action/extreme-tuxracer/files/extreme-tuxracer.svg
@@ -0,0 +1,210 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+<svg
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:xlink="http://www.w3.org/1999/xlink"
+ version="1.0"
+ width="48"
+ height="48"
+ id="svg2464">
+ <defs
+ id="defs2466">
+ <linearGradient
+ id="linearGradient4129">
+ <stop
+ style="stop-color:#ffffff;stop-opacity:1"
+ offset="0"
+ id="stop4131" />
+ <stop
+ style="stop-color:#ffffff;stop-opacity:0"
+ offset="1"
+ id="stop4133" />
+ </linearGradient>
+ <linearGradient
+ x1="108.53113"
+ y1="192.81239"
+ x2="108.53113"
+ y2="53.398727"
+ id="linearGradient12059"
+ xlink:href="#linearGradient4129"
+ gradientUnits="userSpaceOnUse" />
+ <linearGradient
+ id="linearGradient5159">
+ <stop
+ style="stop-color:#ffffff;stop-opacity:1"
+ offset="0"
+ id="stop5161" />
+ <stop
+ style="stop-color:#2a7fff;stop-opacity:0"
+ offset="1"
+ id="stop5163" />
+ </linearGradient>
+ <linearGradient
+ x1="88.097565"
+ y1="68.650604"
+ x2="88.097565"
+ y2="77.480812"
+ id="linearGradient2450"
+ xlink:href="#linearGradient5159"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(-1.3429133,-2.2699906,2.2782501,-1.3380448,-7.0230568,313.38235)" />
+ <linearGradient
+ id="linearGradient7112">
+ <stop
+ style="stop-color:#ffffff;stop-opacity:1"
+ offset="0"
+ id="stop7114" />
+ <stop
+ style="stop-color:#ffffff;stop-opacity:0"
+ offset="1"
+ id="stop7116" />
+ </linearGradient>
+ <linearGradient
+ x1="84.634148"
+ y1="64.585365"
+ x2="84.68293"
+ y2="66.780487"
+ id="linearGradient2462"
+ xlink:href="#linearGradient7112"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(2.644587,0,0,2.6349994,-77.487777,-68.55094)" />
+ <linearGradient
+ id="linearGradient8084">
+ <stop
+ style="stop-color:#729fcf;stop-opacity:1"
+ offset="0"
+ id="stop8086" />
+ <stop
+ style="stop-color:#5a7ea4;stop-opacity:1"
+ offset="1"
+ id="stop8088" />
+ </linearGradient>
+ <linearGradient
+ x1="79.428566"
+ y1="70.612816"
+ x2="79.428566"
+ y2="129.2305"
+ id="linearGradient2460"
+ xlink:href="#linearGradient8084"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(0.302046,0,0,0.2967233,124.91587,77.317344)" />
+ <linearGradient
+ x1="108.53113"
+ y1="192.81239"
+ x2="108.53113"
+ y2="53.398727"
+ id="linearGradient2506"
+ xlink:href="#linearGradient4129"
+ gradientUnits="userSpaceOnUse" />
+ <linearGradient
+ x1="88.097565"
+ y1="68.650604"
+ x2="88.097565"
+ y2="77.480812"
+ id="linearGradient2508"
+ xlink:href="#linearGradient5159"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(-1.3429133,-2.2699906,2.2782501,-1.3380448,-7.0230568,313.38235)" />
+ <linearGradient
+ x1="79.428566"
+ y1="70.612816"
+ x2="79.428566"
+ y2="129.2305"
+ id="linearGradient2510"
+ xlink:href="#linearGradient8084"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(0.302046,0,0,0.2967233,124.91587,77.317344)" />
+ <linearGradient
+ x1="84.634148"
+ y1="64.585365"
+ x2="84.68293"
+ y2="66.780487"
+ id="linearGradient2512"
+ xlink:href="#linearGradient7112"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(2.644587,0,0,2.6349994,-77.487777,-68.55094)" />
+ <linearGradient
+ x1="108.53113"
+ y1="192.81239"
+ x2="108.53113"
+ y2="53.398727"
+ id="linearGradient2542"
+ xlink:href="#linearGradient4129"
+ gradientUnits="userSpaceOnUse" />
+ <linearGradient
+ x1="88.097565"
+ y1="68.650604"
+ x2="88.097565"
+ y2="77.480812"
+ id="linearGradient2544"
+ xlink:href="#linearGradient5159"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(-1.3429133,-2.2699906,2.2782501,-1.3380448,-7.0230568,313.38235)" />
+ <linearGradient
+ x1="79.428566"
+ y1="70.612816"
+ x2="79.428566"
+ y2="129.2305"
+ id="linearGradient2546"
+ xlink:href="#linearGradient8084"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(0.302046,0,0,0.2967233,124.91587,77.317344)" />
+ <linearGradient
+ x1="84.634148"
+ y1="64.585365"
+ x2="84.68293"
+ y2="66.780487"
+ id="linearGradient2548"
+ xlink:href="#linearGradient7112"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(2.644587,0,0,2.6349994,-77.487777,-68.55094)" />
+ </defs>
+ <g
+ id="layer1">
+ <g
+ transform="matrix(0.734375,0,0,0.737226,-3.8201516,15.714349)"
+ id="g2496">
+ <g
+ transform="matrix(0.978721,0,0,0.9787233,13.660731,-13.740884)"
+ id="g2532">
+ <path
+ d="M 195 101.42857 A 93.571426 93.571426 0 1 1 7.8571472,101.42857 A 93.571426 93.571426 0 1 1 195 101.42857 z"
+ transform="matrix(0.3391532,0,0,0.3379237,-9.9160368,-8.4959852)"
+ style="fill:#ff6600;fill-opacity:1;fill-rule:evenodd;stroke:none;stroke-width:10;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1;display:inline"
+ id="path12045" />
+ <path
+ d="M 195 101.42857 A 93.571426 93.571426 0 1 1 7.8571472,101.42857 A 93.571426 93.571426 0 1 1 195 101.42857 z"
+ transform="matrix(0.2961456,0,0,0.295072,-5.5538568,-4.1495872)"
+ style="opacity:0.45209578;fill:none;fill-opacity:1;fill-rule:evenodd;stroke:url(#linearGradient2542);stroke-width:9.31759739;stroke-linecap:round;stroke-linejoin:round;marker-start:none;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1;display:inline"
+ id="path12047" />
+ <path
+ d="M 195 101.42857 A 93.571426 93.571426 0 1 1 7.8571472,101.42857 A 93.571426 93.571426 0 1 1 195 101.42857 z"
+ transform="matrix(0.3248275,0,0,0.3236499,-8.4629968,-7.0482002)"
+ style="fill:none;fill-opacity:1;fill-rule:evenodd;stroke:#aa4400;stroke-width:8.25348759;stroke-linecap:round;stroke-linejoin:round;marker-start:none;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1;display:inline"
+ id="path12049" />
+ <path
+ d="M 6.0446932,-0.29403324 C 11.545213,5.5034088 20.474153,17.00584 25.565293,29.543389 C 30.234423,41.041589 39.365963,47.028059 45.356503,49.859509 C 57.100873,40.038519 60.363683,22.914829 52.321773,9.3211878 C 43.362913,-5.8223962 23.762373,-10.866786 8.5637129,-1.9404222 C 7.6895929,-1.4270402 6.8510432,-0.87475524 6.0446932,-0.29403324 z "
+ style="opacity:0.17543862;fill:url(#linearGradient2544);fill-opacity:1;fill-rule:evenodd;stroke:none;stroke-width:10;stroke-miterlimit:4;stroke-opacity:1;display:inline"
+ id="path12051" />
+ <g
+ transform="translate(-130.04499,-80.64053)"
+ style="display:inline"
+ id="g2455">
+ <path
+ d="M 131.77538,107.29307 C 131.77538,107.29307 139.53824,90.000623 163.64399,102.48962 C 176.30972,96.917602 174.67542,95.764764 175.08401,97.301891 C 175.49257,98.838991 173.44971,104.60316 174.06256,106.14026 C 174.67542,107.67736 177.38226,114.08344 175.90116,114.21008 C 173.654,114.40222 165.48256,110.75159 164.8697,111.52014 C 164.25684,112.28869 144.03253,124.39343 131.77538,107.29307 z "
+ style="fill:url(#linearGradient2546);fill-opacity:1;fill-rule:evenodd;stroke:none;stroke-width:3.70597196;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+ id="path12053" />
+ <path
+ d="M 130.37031,107.47813 C 130.37031,107.47813 138.41158,88.598822 164.18304,102.14104 C 177.72397,96.099119 175.97674,94.849075 176.41355,96.515817 C 176.85035,98.18256 174.66635,104.4328 175.32154,106.09955 C 175.97674,107.76629 178.87063,114.7126 177.28716,114.84993 C 174.88474,115.05826 166.14866,111.09975 165.49345,111.93312 C 164.89392,112.69569 146.73988,123.74999 133.61953,111.41774 C 132.401,110.27239 131.48391,109.05388 130.37031,107.47813 z "
+ style="fill:none;fill-opacity:1;fill-rule:evenodd;stroke:#142f56;stroke-width:2.63978887;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+ id="path12055" />
+ <path
+ d="M 133.43416,107.02999 L 164.39518,107.41561 L 172.90946,106.13024 L 174.1995,99.446337 L 164.52419,104.33073 C 154.6965,99.733162 144.70187,95.760779 135.24022,104.33073 L 133.43416,107.02999 z "
+ style="opacity:0.35714285;fill:url(#linearGradient2548);fill-opacity:1;fill-rule:evenodd;stroke:none;stroke-width:1px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1"
+ id="path12057" />
+ </g>
+ </g>
+ </g>
+ </g>
+</svg>
diff --git a/games-action/extreme-tuxracer/metadata.xml b/games-action/extreme-tuxracer/metadata.xml
new file mode 100644
index 000000000000..93658409190f
--- /dev/null
+++ b/games-action/extreme-tuxracer/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+Extreme Tux Racer is an open source racing game featuring Tux the Linux Penguin.
+ETRacer continues in the tracks of Tux Racer and its forks.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">extremetuxracer</remote-id>
+ </upstream>
+</pkgmetadata>