summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-02 00:24:34 +0100
committerSam James <sam@gentoo.org>2020-09-02 00:24:46 +0100
commit05e8951e0fa0ad2c41db7ad94e242aef6bcad871 (patch)
treea942e13110ad078ad1584c4b14b9e7e1ebe05af3 /games-action
parentdev-haskell/unix-time: drop old (diff)
downloadgentoo-05e8951e0fa0ad2c41db7ad94e242aef6bcad871.tar.gz
gentoo-05e8951e0fa0ad2c41db7ad94e242aef6bcad871.tar.bz2
gentoo-05e8951e0fa0ad2c41db7ad94e242aef6bcad871.zip
games-action/supertuxkart: bump to 1.2
Closes: https://bugs.gentoo.org/739480 Closes: https://bugs.gentoo.org/737250 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/supertuxkart/Manifest1
-rw-r--r--games-action/supertuxkart/files/supertuxkart-1.2-irrlicht-system-libs.patch69
-rw-r--r--games-action/supertuxkart/metadata.xml2
-rw-r--r--games-action/supertuxkart/supertuxkart-1.2.ebuild92
4 files changed, 164 insertions, 0 deletions
diff --git a/games-action/supertuxkart/Manifest b/games-action/supertuxkart/Manifest
index 4fd966710bca..cb598d30c279 100644
--- a/games-action/supertuxkart/Manifest
+++ b/games-action/supertuxkart/Manifest
@@ -1,2 +1,3 @@
+DIST SuperTuxKart-1.2-src.tar.xz 614569164 BLAKE2B 5bdaa8dcac12ab6c399e6f0fc3121906070f4cd5c58dba6ccf04229d92b9b21d87a43662f39fc29ac1528ce429aebea87934fa8a180a0933385704f5a43cd6f7 SHA512 bc7079af9b3d85b3e4839ebb3eee293fb8bfe95450165172caa28b8ad1a9e97c59618d77c2208a86090f1840aa9a4b4b6898c1053fa6f5d7dfbfe17b69536835
DIST supertuxkart-1.1-src.tar.xz 616739152 BLAKE2B a4dd9ec0a8ee158306dc902d3de363b68e7a317800df1b36339843521019df91c0713b74bdef8dc06b40bee57285237408a17b539c7bd7298cd3ef3deaf99fda SHA512 81d5ff59bb33eba8a00547239d54cacfde25eed0c56c857712a00a62032e4cf371cdd367159eaa4bfec6d4dd5781b705e41b58a26b864aa43678cfe9926bb804
DIST supertuxkart.png 4435 BLAKE2B b48b95e1cdebe930837cc784c4c5e9a089a69077e2fcfed15fe5e8c4d649a0f8024769b2f2102bbaea3a94eb21f4b58b5d291b97493266c3c5c8d7335cf69a80 SHA512 a180332f79220431922fa8b351cb476ebc5d9d1df09f20707eb3bdd7002fd264cb027b8190c73c5221050e6e8601beb6758a5809d05aedfb18f0bdb426f47eda
diff --git a/games-action/supertuxkart/files/supertuxkart-1.2-irrlicht-system-libs.patch b/games-action/supertuxkart/files/supertuxkart-1.2-irrlicht-system-libs.patch
new file mode 100644
index 000000000000..2a23e51323dc
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-1.2-irrlicht-system-libs.patch
@@ -0,0 +1,69 @@
+https://salsa.debian.org/games-team/supertuxkart/-/raw/master/debian/patches/irrlicht/use-system-libs.diff
+----
+Subject: [PATCH] debian/use-system-libs
+
+Path to build irrlicht using the system libraries for png,zlib and
+jpeg as well as the glext family of header files.
+
+Signed-off-by: Christoph Egger <debian@christoph-egger.org
+
+--- a/lib/irrlicht/source/Irrlicht/CIrrDeviceLinux.cpp
++++ b/lib/irrlicht/source/Irrlicht/CIrrDeviceLinux.cpp
+@@ -35,7 +35,7 @@
+ #include <GL/gl.h>
+ #ifdef _IRR_OPENGL_USE_EXTPOINTER_
+ #define GLX_GLXEXT_PROTOTYPES
+-#include "glxext.h"
++#include <GL/glxext.h>
+ #endif
+ #endif
+
+--- a/lib/irrlicht/source/Irrlicht/COpenGLExtensionHandler.h
++++ b/lib/irrlicht/source/Irrlicht/COpenGLExtensionHandler.h
+@@ -24,7 +24,7 @@
+ #define NO_SDL_GLEXT
+ #include <SDL_video.h>
+ #include <SDL_opengl.h>
+- #include "glext.h"
++ #include <GL/glext.h>
+ #elif defined(_IRR_WINDOWS_API_)
+ // include windows headers for HWND
+ #define WIN32_LEAN_AND_MEAN
+@@ -34,7 +34,7 @@
+ #endif
+ #include <GL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
+- #include "glext.h"
++ #include <GL/glext.h>
+ #endif
+ #include "wglext.h"
+
+@@ -49,7 +49,7 @@
+ #endif
+ #include <OpenGL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
+- #include "glext.h"
++ #include <GL/glext.h>
+ #endif
+ #endif
+
+--- a/lib/irrlicht/source/Irrlicht/COpenGLSLMaterialRenderer.h
++++ b/lib/irrlicht/source/Irrlicht/COpenGLSLMaterialRenderer.h
+@@ -12,7 +12,7 @@
+ #define WIN32_LEAN_AND_MEAN
+ #include <windows.h>
+ #include <GL/gl.h>
+- #include "glext.h"
++ #include <GL/glext.h>
+ #else
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
+ #define GL_GLEXT_LEGACY 1
+@@ -26,7 +26,7 @@
+ #include <GL/gl.h>
+ #endif
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
+- #include "glext.h"
++ #include <GL/glext.h>
+ #endif
+ #endif
+
diff --git a/games-action/supertuxkart/metadata.xml b/games-action/supertuxkart/metadata.xml
index ced8e3e6ee96..22a9fc08bd8f 100644
--- a/games-action/supertuxkart/metadata.xml
+++ b/games-action/supertuxkart/metadata.xml
@@ -9,9 +9,11 @@
<flag name="fribidi">Support for right-to-left languages</flag>
<flag name="nettle">Use <pkg>dev-libs/nettle</pkg> crypto backend</flag>
<flag name="recorder">Enable recording with <pkg>media-libs/libopenglrecorder</pkg></flag>
+ <flag name="sqlite">Record IP bans, statistics in server mode with <pkg>dev-db/sqlite</pkg></flag>
<flag name="wiimote">Support for wiimote input devices</flag>
</use>
<upstream>
+ <remote-id type="github">supertuxkart/stk-code</remote-id>
<remote-id type="sourceforge">supertuxkart</remote-id>
</upstream>
</pkgmetadata>
diff --git a/games-action/supertuxkart/supertuxkart-1.2.ebuild b/games-action/supertuxkart/supertuxkart-1.2.ebuild
new file mode 100644
index 000000000000..d78f9737b393
--- /dev/null
+++ b/games-action/supertuxkart/supertuxkart-1.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop xdg
+
+MY_P="SuperTuxKart-${PV}-src"
+DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
+HOMEPAGE="https://supertuxkart.net/"
+SRC_URI="https://github.com/${PN}/stk-code/releases/download/${PV}/${MY_P}.tar.xz
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2 GPL-3 CC-BY-SA-3.0 CC-BY-SA-4.0 CC0-1.0 public-domain ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fribidi libressl nettle recorder sqlite wiimote"
+
+# don't unbundle irrlicht and bullet
+# both are modified and system versions will break the game
+# https://sourceforge.net/p/irrlicht/feature-requests/138/
+
+RDEPEND="
+ dev-cpp/libmcpp
+ sqlite? ( dev-db/sqlite:3 )
+ dev-libs/angelscript:=
+ dev-libs/fribidi
+ media-libs/freetype:2
+ media-libs/glew:0=
+ media-libs/harfbuzz:=
+ media-libs/libpng:0=
+ media-libs/libsdl2
+ media-libs/libvorbis
+ media-libs/openal
+ net-libs/enet:1.3=
+ net-misc/curl
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg:0
+ virtual/libintl
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXxf86vm
+ nettle? ( dev-libs/nettle:= )
+ !nettle? (
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( >=dev-libs/openssl-1.0.1d:0= )
+ )
+ recorder? ( media-libs/libopenglrecorder )
+ wiimote? ( net-wireless/bluez )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-irrlicht-arch-support.patch
+ "${FILESDIR}"/${PN}-1.2-irrlicht-system-libs.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SQLITE3=$(usex sqlite)
+ -DUSE_SYSTEM_ANGELSCRIPT=ON
+ -DUSE_SYSTEM_ENET=ON
+ -DUSE_SYSTEM_GLEW=ON
+ -DUSE_SYSTEM_SQUISH=OFF
+ -DUSE_SYSTEM_WIIUSE=OFF
+ -DUSE_IPV6=OFF # not supported by system enet
+ -DOpenGL_GL_PREFERENCE=GLVND
+ -DUSE_CRYPTO_OPENSSL=$(usex nettle no yes)
+ -DBUILD_RECORDER=$(usex recorder)
+ -DUSE_WIIUSE=$(usex wiimote)
+ -DSTK_INSTALL_BINARY_DIR=bin
+ -DSTK_INSTALL_DATA_DIR=share/${PN}
+ -DBUILD_SHARED_LIBS=OFF # build bundled libsquish as static library
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ dodoc CHANGELOG.md
+
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+}