summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-02-17 09:50:56 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-02-17 09:50:56 +0000
commit520ab86b4ee56ea2e3733d5d847e113b96892759 (patch)
treeeefbaffd46be5d127cdeee81e6774b6ae843464d /games-action
parentmedia-libs/libggiwmh: amd64 stable wrt bug #677636 (diff)
downloadgentoo-520ab86b4ee56ea2e3733d5d847e113b96892759.tar.gz
gentoo-520ab86b4ee56ea2e3733d5d847e113b96892759.tar.bz2
gentoo-520ab86b4ee56ea2e3733d5d847e113b96892759.zip
games-action/abuse: Version bump to 0.9_p20181213 from new SDL2 fork
OpenGL support is now handled solely by SDL. Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/abuse/Manifest1
-rw-r--r--games-action/abuse/abuse-0.9_p20181213.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/games-action/abuse/Manifest b/games-action/abuse/Manifest
index d229ba0e09d3..411e98d2994a 100644
--- a/games-action/abuse/Manifest
+++ b/games-action/abuse/Manifest
@@ -1 +1,2 @@
DIST abuse-0.8.tar.gz 6053500 BLAKE2B 4f52256b7bf13e0efa77ef50147a976fdf1fceec4ce20fb4b855a9961a7c816cf08bf51286b424da42072956a137bc3385357cfdb61bf37ff9f907284d99e09c SHA512 5c60dcf6910f9f751da26e919cd289c12349bb82eb925f9a41dc921263ece0d0f5f24c2ab2d1c718c0a5d0315453f92dfcba665fe5082eb4135ed737d2859d18
+DIST abuse-0.9_p20181213.tar.gz 4668746 BLAKE2B 5834d9a3a3172ec6364adf4ffc4196e76b2f104a77d7c5eb94f72cb00e326a66b56bf66083ab8fd566d1bc97b7f8ac6ac1edb4ad60605526761487a45a4136ac SHA512 4a7bdd67880a86a686f896d42b9a7f0c3a6e8a9e8891e514ebb68634b6b31641f5ade91da0f0bd4e6da7081b67c3bf944246ec3538a547e5ee68b4d8f4cebbeb
diff --git a/games-action/abuse/abuse-0.9_p20181213.ebuild b/games-action/abuse/abuse-0.9_p20181213.ebuild
new file mode 100644
index 000000000000..5feb6d8953b0
--- /dev/null
+++ b/games-action/abuse/abuse-0.9_p20181213.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop xdg-utils
+
+COMMIT="42b6acd19af00689e8f34355e3b13323d8ea3f79"
+DATA_PV="0.8"
+
+DESCRIPTION="Port of Abuse by Crack Dot Com"
+HOMEPAGE="https://github.com/Xenoveritas/abuse"
+SRC_URI="https://github.com/Xenoveritas/abuse/archive/${COMMIT}.tar.gz -> ${P}.tar.gz
+ http://abuse.zoy.org/raw-attachment/wiki/download/${PN}-${DATA_PV}.tar.gz"
+
+LICENSE="GPL-2 public-domain WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=media-libs/libsdl2-2.0.3[sound,video]
+ media-libs/sdl2-mixer"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ ln -snf ../../${PN}-${DATA_PV}/data/{music,sfx} data/ || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ # https://github.com/Xenoveritas/abuse/pull/6
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon -s 32 doc/${PN}.png
+ make_desktop_entry abuse Abuse
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }