summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-30 17:58:25 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-30 18:59:21 -0600
commit77fd03586ede263c9fcc07121af00881ca3bcf99 (patch)
tree4b98ea4b0ed6d54f9adc6f87afb540bad96d9937 /games-action
parentgames-action/trine-bin: remove deprecated games eclass (diff)
downloadgentoo-77fd03586ede263c9fcc07121af00881ca3bcf99.tar.gz
gentoo-77fd03586ede263c9fcc07121af00881ca3bcf99.tar.bz2
gentoo-77fd03586ede263c9fcc07121af00881ca3bcf99.zip
games-action/tuxkart: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action')
-rw-r--r--games-action/tuxkart/tuxkart-0.4.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-action/tuxkart/tuxkart-0.4.0-r1.ebuild b/games-action/tuxkart/tuxkart-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..311dcf65dcf5
--- /dev/null
+++ b/games-action/tuxkart/tuxkart-0.4.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A racing game starring Tux, the Linux penguin"
+HOMEPAGE="http://tuxkart.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tuxkart/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/plib-1.8.0
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+
+src_prepare() {
+ default
+
+ # apparently <sys/perm.h> doesn't exist on alpha
+ if use alpha; then
+ sed -i \
+ -e '/#include <sys\/perm.h>/d' src/gfx.cxx || die
+ fi
+ sed -i \
+ -e "/^plib_suffix/ s/-lplibul/-lplibul -lplibjs/" \
+ -e "s/-malign-double//; s/-O6//" configure || die
+ sed -i \
+ -e "/^bindir/s/=.*/=@bindir@/" src/Makefile.in || die
+}
+
+src_install() {
+ default
+ dodoc doc/*.html
+ rm -rf "${D}/usr/share/tuxkart/" || die
+}