summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:07:04 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:07:04 -0500
commit9cdc51304469ea831d302a6ae9d91e5c31caf356 (patch)
tree1bebe017c3d4c36c3b9b07b42ef1763fa1a3ad3c /games-action
parentEAPI=5; minor tidying (diff)
downloadgentoo-9cdc51304469ea831d302a6ae9d91e5c31caf356.tar.gz
gentoo-9cdc51304469ea831d302a6ae9d91e5c31caf356.tar.bz2
gentoo-9cdc51304469ea831d302a6ae9d91e5c31caf356.zip
EAPI=5; minor tidying
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-action')
-rw-r--r--games-action/chickens/chickens-0.2.4.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/games-action/chickens/chickens-0.2.4.ebuild b/games-action/chickens/chickens-0.2.4.ebuild
index b40213dba250..580d38b150b0 100644
--- a/games-action/chickens/chickens-0.2.4.ebuild
+++ b/games-action/chickens/chickens-0.2.4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils games
MY_P="ChickensForLinux-Linux-${PV}"
@@ -25,23 +25,20 @@ src_prepare() {
sed -i \
-e "s:HighScores:${GAMES_STATEDIR}/${PN}/HighScores:" \
-e "s:....\(.\)\(_\)\(.*.4x0\)\(.\):M\4\2\x42\x6Fn\1s\2:" \
- highscore.cpp HighScores \
- || die "sed failed"
+ highscore.cpp HighScores || die
sed -i \
-e "s:options.cfg:${GAMES_SYSCONFDIR}/${PN}/options.cfg:" \
-e "s:\"sound/:\"${GAMES_DATADIR}/${PN}/sound/:" \
-e "s:\"dat/:\"${GAMES_DATADIR}/${PN}/dat/:" \
- main.cpp README \
- || die "sed failed"
+ main.cpp README || die
sed -i \
-e '/^CPPFLAGS/d' \
-e 's:g++:\\$(CXX) \\$(CXXFLAGS) \\$(LDFLAGS):' \
- configure \
- || die "sed failed"
+ configure || die
}
src_configure() {
- bash ./configure || die "configure failed"
+ bash ./configure || die
}
src_install() {