summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-30 15:55:11 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-30 17:09:13 -0600
commitcfa71094f1e64c24742bd7ab7c4cfba88939ac78 (patch)
treecd77d08e556761d38420e3ebe9d638a2f12d8ac7 /games-action
parentgames-action/snipes: remove deprecated games eclass (diff)
downloadgentoo-cfa71094f1e64c24742bd7ab7c4cfba88939ac78.tar.gz
gentoo-cfa71094f1e64c24742bd7ab7c4cfba88939ac78.tar.bz2
gentoo-cfa71094f1e64c24742bd7ab7c4cfba88939ac78.zip
games-action/spacetripper-demo: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action')
-rw-r--r--games-action/spacetripper-demo/spacetripper-demo-1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-action/spacetripper-demo/spacetripper-demo-1-r1.ebuild b/games-action/spacetripper-demo/spacetripper-demo-1-r1.ebuild
new file mode 100644
index 000000000000..e42823409612
--- /dev/null
+++ b/games-action/spacetripper-demo/spacetripper-demo-1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils unpacker
+
+MY_P="spacetripperdemo"
+DESCRIPTION="Hardcore arcade shoot-em-up"
+HOMEPAGE="http://www.pompomgames.com/"
+SRC_URI="http://www.btinternet.com/~bongpig/${MY_P}.sh"
+
+LICENSE="POMPOM"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-),X,video,joystick,opengl,sound]"
+
+S=${WORKDIR}
+
+dir=/opt/${PN}
+Ddir=${D}/${dir}
+
+QA_PREBUILT="${dir}/*"
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe bin/x86/*
+ # Remove libSDL since we use the system version and our version doesn't
+ # have TEXTRELs in it.
+ rm -f "${Ddir}"/libSDL-1.2.so.0.0.5 || die
+ sed -i -e "s:XYZZY:${dir}:" "${Ddir}/${MY_P}" || die
+
+ insinto "${dir}"
+ doins -r preview run styles README license.txt icon.xpm
+ newicon icon.xpm spacetripper-demo.png
+
+ make_wrapper spacetripper-demo ./spacetripperdemo "${dir}" "${dir}"
+ make_desktop_entry spacetripper-demo spacetripper-demo spacetripper-demo
+}