summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-08 04:17:00 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-09 14:24:42 -0500
commitd1dd49b298eb55c4640dc419d3dc0833c234bc6b (patch)
tree6dd185f91ef4b2a1643cd7c4f18f46725501734e /games-action
parentnet-misc/tor: fix for Prefix, marked ~ppc-macos, thanks Konstantin Tokarev, b... (diff)
downloadgentoo-d1dd49b298eb55c4640dc419d3dc0833c234bc6b.tar.gz
gentoo-d1dd49b298eb55c4640dc419d3dc0833c234bc6b.tar.bz2
gentoo-d1dd49b298eb55c4640dc419d3dc0833c234bc6b.zip
version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-action')
-rw-r--r--games-action/supertuxkart/Manifest1
-rw-r--r--games-action/supertuxkart/supertuxkart-0.9.1.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/games-action/supertuxkart/Manifest b/games-action/supertuxkart/Manifest
index dab06acd087c..a1bb6cdf8f45 100644
--- a/games-action/supertuxkart/Manifest
+++ b/games-action/supertuxkart/Manifest
@@ -1,3 +1,4 @@
DIST supertuxkart-0.8.1-src.tar.bz2 229944480 SHA256 335301ae61b0c177be68d5593c65e5b197dc807421f08a8a35740a254cacf8d6 SHA512 1d72230a2cfa6196c6ea6c5464f01d1a0064994c9dafbf5d47c04b5db87e82590fde57a88d5316f2cf6094dcebae5e115b81e5ecc964a29bd669bc83d527d13a WHIRLPOOL 5cf87e57cd5b5d12e4549bf49efb0596e4a1fafa7cba58e366c843e2ebf61c02e5c3471d1591f1231194021cbcb6082829e026616403680fc7ad05bd235b155e
DIST supertuxkart-0.9-src.tar.xz 385780604 SHA256 c0eb24eb49e23ed6d03f4864feb43573e14971c8420bf60c3c654d4e05ff9aa6 SHA512 0876ad8bda49b3a26be82ee60742704608f4aca3e16fc038a06d9aa8dce9389b15fa69b547eca4b4a3c073cea495e7872924732a2e66802987c905348ff25ebb WHIRLPOOL 780c664d418de612fdfa2905dc86f0eddced5b2c0eef60b67931203afd34b418eb254d0270113846a1c51e149acd6a64157263895163fb1016a9a840384eeb51
+DIST supertuxkart-0.9.1-src.tar.xz 425822808 SHA256 c50f00a71df165fb613d20e86bea2d9d5e51ed3e27e1d436fbac3b07cf2ea149 SHA512 11ea064210ea6bc36258f08e57c6aac46739133017ad3ba97ca0edd84c818c2f72dae60bbe7cd79135be9785fb0e15c9904b151c894e1c21b881598113344cf4 WHIRLPOOL 8acd59e878b44f8e504d57687ea1bbece05d5f14b29e0c62a22183729129fb115fccb9a1a89d5e0a86881ac6487c36ea520aab835ba5efaaa3c71471fda9b15f
DIST supertuxkart.png 4435 SHA256 99bc1801cb0514946cb0171d6d5a84484b6dc881edfa7f096b6eb5fea2f28828 SHA512 a180332f79220431922fa8b351cb476ebc5d9d1df09f20707eb3bdd7002fd264cb027b8190c73c5221050e6e8601beb6758a5809d05aedfb18f0bdb426f47eda WHIRLPOOL eef651802a927b451226fc06a682d7dea68b65b05195130ccfc7544165f26f65bda4fc9565e09d6487d02be3cf57880b0c6c257f26587c6bc6d30afc6aa5d3c2
diff --git a/games-action/supertuxkart/supertuxkart-0.9.1.ebuild b/games-action/supertuxkart/supertuxkart-0.9.1.ebuild
new file mode 100644
index 000000000000..b070ae748dfa
--- /dev/null
+++ b/games-action/supertuxkart/supertuxkart-0.9.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnome2-utils cmake-utils eutils games
+
+DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
+HOMEPAGE="http://supertuxkart.sourceforge.net/"
+SRC_URI="mirror://sourceforge/supertuxkart/SuperTuxKart/${PV}/${P}-src.tar.xz
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-3 CC-BY-SA-3.0 CC-BY-2.0 public-domain ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fribidi wiimote"
+
+# don't unbundle irrlicht and bullet
+# both are modified and system versions will break the game
+# http://sourceforge.net/tracker/?func=detail&aid=3454889&group_id=74339&atid=540679
+
+RDEPEND="media-libs/libpng:0
+ media-libs/libvorbis
+ media-libs/openal
+ net-misc/curl
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg:62
+ virtual/libintl
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXxf86vm
+ fribidi? ( dev-libs/fribidi )
+ wiimote? ( net-wireless/bluez )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # inconsistent handling of debug definition
+ # avoid using Debug build type
+ if use debug ; then
+ sed -i \
+ -e 's/add_definitions(-DNDEBUG)/add_definitions(-DDEBUG)/' \
+ CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use fribidi FRIBIDI)
+ $(cmake-utils_use_use wiimote WIIUSE)
+ -DSTK_INSTALL_BINARY_DIR="${GAMES_BINDIR}"
+ -DSTK_INSTALL_DATA_DIR="${GAMES_DATADIR}"/${PN}
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+ dodoc AUTHORS CHANGELOG.md README.md TODO.md
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}