summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-22 01:09:07 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-22 01:09:07 -0500
commitde6a4318c844c657ac65786afbfef15db11c09c7 (patch)
tree0aa8505245094c27711be43e05a376dace345ffe /games-action
parentversion bump (diff)
downloadgentoo-de6a4318c844c657ac65786afbfef15db11c09c7.tar.gz
gentoo-de6a4318c844c657ac65786afbfef15db11c09c7.tar.bz2
gentoo-de6a4318c844c657ac65786afbfef15db11c09c7.zip
use epatch to apply patch
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-action')
-rw-r--r--games-action/deathchase3d/deathchase3d-0.9.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/games-action/deathchase3d/deathchase3d-0.9.ebuild b/games-action/deathchase3d/deathchase3d-0.9.ebuild
index 35290c1aaab1..8a9b39e4ffb0 100644
--- a/games-action/deathchase3d/deathchase3d-0.9.ebuild
+++ b/games-action/deathchase3d/deathchase3d-0.9.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-inherit games
+EAPI=5
+inherit eutils games
DESCRIPTION="A remake of the Sinclair Spectrum game of the same name"
HOMEPAGE="http://www.autismuk.freeserve.co.uk/"
@@ -14,10 +14,12 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
-DEPEND="media-libs/libsdl"
-RDEPEND="${DEPEND}"
+DEPEND="media-libs/libsdl[video]"
+RDEPEND=${DEPEND}
-PATCHES=( "${FILESDIR}"/${P}-underlink.patch )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlink.patch
+}
src_install() {
dogamesbin "${PN}/${PN}"