summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-04-19 16:42:49 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-04-19 16:43:13 -0400
commit89fcf449d2750b442b33ea39ce3da704e6734ff9 (patch)
tree5033c0adab1371aef18ce828e2dd6f4e831bdff3 /games-arcade/lbreakout2/lbreakout2-2.6.5.ebuild
parentapp-shells/thefuck: Version bump to 3.8 (diff)
downloadgentoo-89fcf449d2750b442b33ea39ce3da704e6734ff9.tar.gz
gentoo-89fcf449d2750b442b33ea39ce3da704e6734ff9.tar.bz2
gentoo-89fcf449d2750b442b33ea39ce3da704e6734ff9.zip
games-arcade/lbreakout2: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-arcade/lbreakout2/lbreakout2-2.6.5.ebuild')
-rw-r--r--games-arcade/lbreakout2/lbreakout2-2.6.5.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/games-arcade/lbreakout2/lbreakout2-2.6.5.ebuild b/games-arcade/lbreakout2/lbreakout2-2.6.5.ebuild
new file mode 100644
index 000000000000..77ebf14235f0
--- /dev/null
+++ b/games-arcade/lbreakout2/lbreakout2-2.6.5.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic gnome2-utils games
+
+levels_V=20141220
+themes_V=20141220
+
+DESCRIPTION="Breakout clone written with the SDL library"
+HOMEPAGE="http://lgames.sourceforge.net/index.php?project=LBreakout2"
+SRC_URI=" mirror://sourceforge/lgames/${P}.tar.gz
+ mirror://sourceforge/lgames/add-ons/lbreakout2/${PN}-levelsets-${levels_V}.tar.gz
+ themes? ( mirror://sourceforge/lgames/add-ons/lbreakout2/${PN}-themes-${levels_V}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="nls themes"
+
+RDEPEND="media-libs/libpng:0
+ sys-libs/zlib
+ media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-net
+ media-libs/sdl-mixer
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd "${S}/client/levels"
+ unpack ${PN}-levelsets-${levels_V}.tar.gz
+
+ if use themes ; then
+ mkdir "${WORKDIR}/themes"
+ cd "${WORKDIR}/themes"
+ unpack ${PN}-themes-${themes_V}.tar.gz
+
+ # Delete a few duplicate themes (already shipped with lbreakout2
+ # tarball). Some of them have different case than built-in themes, so it
+ # is harder to just compare if the filename is the same.
+ rm -f absoluteB.zip oz.zip moiree.zip
+ for f in *.zip; do
+ unzip -q "$f" && rm -f "$f" || die
+ done
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ filter-flags -O?
+ egamesconf \
+ --enable-sdl-net \
+ --localedir=/usr/share/locale \
+ --with-docdir="/usr/share/doc/${PF}/html" \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ if use themes ; then
+ insinto "${GAMES_DATADIR}/lbreakout2/gfx"
+ doins -r "${WORKDIR}/themes/"*
+ fi
+
+ newicon client/gfx/win_icon.png ${PN}.png
+ newicon -s 32 client/gfx/win_icon.png ${PN}.png
+ make_desktop_entry lbreakout2 LBreakout2
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}