summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-24 19:32:54 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-24 21:25:59 +0200
commitb50b77d029f0baf0abcea5738c58552df1eab95f (patch)
tree178196b8d1916e827a881382cb4e26b955273e89 /games-arcade/sdlroids
parentgames-arcade/sdl-sopwith: Drop old (diff)
downloadgentoo-b50b77d029f0baf0abcea5738c58552df1eab95f.tar.gz
gentoo-b50b77d029f0baf0abcea5738c58552df1eab95f.tar.bz2
gentoo-b50b77d029f0baf0abcea5738c58552df1eab95f.zip
games-arcade/sdlroids: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade/sdlroids')
-rw-r--r--games-arcade/sdlroids/files/1.3.4-sound.patch4
-rw-r--r--games-arcade/sdlroids/sdlroids-1.3.4-r4.ebuild34
2 files changed, 36 insertions, 2 deletions
diff --git a/games-arcade/sdlroids/files/1.3.4-sound.patch b/games-arcade/sdlroids/files/1.3.4-sound.patch
index 00da03f94252..eb2eb0c2ada4 100644
--- a/games-arcade/sdlroids/files/1.3.4-sound.patch
+++ b/games-arcade/sdlroids/files/1.3.4-sound.patch
@@ -1,5 +1,5 @@
---- sdlsound.c.orig 2004-07-02 23:03:03.000000000 -0700
-+++ sdlsound.c 2004-07-02 23:05:37.000000000 -0700
+--- a/sdlsound.c.orig 2004-07-02 23:03:03.000000000 -0700
++++ b/sdlsound.c 2004-07-02 23:05:37.000000000 -0700
@@ -205,9 +205,9 @@
int load_sample(int num) {
diff --git a/games-arcade/sdlroids/sdlroids-1.3.4-r4.ebuild b/games-arcade/sdlroids/sdlroids-1.3.4-r4.ebuild
new file mode 100644
index 000000000000..83678ee1a7b4
--- /dev/null
+++ b/games-arcade/sdlroids/sdlroids-1.3.4-r4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Asteroids Clone for X using SDL"
+HOMEPAGE="http://david.hedbor.org/projects/sdlroids/"
+SRC_URI="mirror://sourceforge/sdlroids/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/$(SOUNDSDIR)/$(DESTDIR)$(SOUNDSDIR)/' \
+ -e 's/$(GFXDIR)/$(DESTDIR)$(GFXDIR)/' Makefile.in \
+ || die "sed failed"
+ eapply "${FILESDIR}"/${PV}-sound.patch
+}
+
+src_install() {
+ default
+ newicon icons/sdlroids-48x48.xpm ${PN}.xpm
+ make_desktop_entry ${PN} SDLRoids ${PN}
+}