summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-24 20:46:00 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-24 21:26:20 +0200
commit65987bd26dc833cc63f255fc0525d0a200cd19a1 (patch)
tree1e45ea03c6a8701cf35db9233523bf4b53211e8d /games-arcade/syobon
parentgames-arcade/supertransball2: Stop using games.eclass (diff)
downloadgentoo-65987bd26dc833cc63f255fc0525d0a200cd19a1.tar.gz
gentoo-65987bd26dc833cc63f255fc0525d0a200cd19a1.tar.bz2
gentoo-65987bd26dc833cc63f255fc0525d0a200cd19a1.zip
games-arcade/syobon: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade/syobon')
-rw-r--r--games-arcade/syobon/syobon-1.0.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-arcade/syobon/syobon-1.0.1-r1.ebuild b/games-arcade/syobon/syobon-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..c0bb5d581bbb
--- /dev/null
+++ b/games-arcade/syobon/syobon-1.0.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+MY_P="${PN}_${PV}_src"
+
+DESCRIPTION="Syobon Action (also known as Cat Mario or Neko Mario)"
+HOMEPAGE="http://zapek.com/?p=189"
+SRC_URI="http://download.zapek.com/software/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[sound,video,joystick]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer[vorbis]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake GAMEDATA="/usr/share/${PN}"
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto "/usr/share/${PN}"
+ doins -r BGM SE res
+ einstalldocs
+
+ make_desktop_entry ${PN}
+}