summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-06-21 16:20:38 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-06-21 16:21:43 -0400
commit7bc01941a4aa8ba1db64d3ccc4eb4e3029849743 (patch)
treee7cee628bc247eb16691b70d8d34a372190d0059 /games-arcade/vor
parentgnustep-base/gnustep-make: Remove := slot op from || dep, #561728 (diff)
downloadgentoo-7bc01941a4aa8ba1db64d3ccc4eb4e3029849743.tar.gz
gentoo-7bc01941a4aa8ba1db64d3ccc4eb4e3029849743.tar.bz2
gentoo-7bc01941a4aa8ba1db64d3ccc4eb4e3029849743.zip
games-arcade/vor: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'games-arcade/vor')
-rw-r--r--games-arcade/vor/Manifest1
-rw-r--r--games-arcade/vor/files/vor-0.5.7-underlink.patch26
-rw-r--r--games-arcade/vor/vor-0.5.7.ebuild42
3 files changed, 69 insertions, 0 deletions
diff --git a/games-arcade/vor/Manifest b/games-arcade/vor/Manifest
index c17903091bbc..36d91e4ff28e 100644
--- a/games-arcade/vor/Manifest
+++ b/games-arcade/vor/Manifest
@@ -1 +1,2 @@
DIST vor-0.5.5.tar.bz2 239291 SHA256 ead1b9786741e26d37ff7c5185b7fe1e91f90f76ebed3785225312e323b7c7da SHA512 a4de43699b78adfe28bbd773cd9f9d1e3ee50b51b4e1848ff1baf836f6242d8391a304445994ca669eab13acbd2dd3ae49f0665bdb07d19c7a1674e0dde9bfbd WHIRLPOOL d0a63aa4b0c42e234593ed9ba09017ef3ab1a00de8ba8580dffefcd88ea0d09c8bc4e1d7edf6ef10cee319d1c17db9fef024aa6ffb495462cc97bf90ad8dbc46
+DIST vor-0.5.7.tgz 358032 SHA256 f3411f747fa998d9ae13b5636ecb478a2bd9abc804030f8440c878bd2c6f8f09 SHA512 32dbfe95971298f9f0191cc95fdb5e9ec34c5f6771df1566554b128644770bfba618df3aac7242e647c8af2f41fc59c9e5620a4c56932d3af72197f6a19f0bce WHIRLPOOL 00cc37d1b911f39e8826f3af323e061d8d2744b64015410f96da4ff74497c4798d24f58cafc4e70c6bad10eb4e2c715726ca3d1666c0a3c27c004667a1002eea
diff --git a/games-arcade/vor/files/vor-0.5.7-underlink.patch b/games-arcade/vor/files/vor-0.5.7-underlink.patch
new file mode 100644
index 000000000000..0645c5695733
--- /dev/null
+++ b/games-arcade/vor/files/vor-0.5.7-underlink.patch
@@ -0,0 +1,26 @@
+--- Makefile.in
++++ Makefile.in
+@@ -43,7 +43,7 @@
+ SDL_CFLAGS := @SDL_CFLAGS@
+ SDL_LIBS := @SDL_LIBS@
+
+-ldflags := $(SDL_LIBS) -lSDL_image -lSDL_mixer $(LDFLAGS)
++ldflags := $(LIBS) $(SDL_LIBS) $(LDFLAGS)
+ cflags := -I. $(SDL_CFLAGS) $(paths) $(CFLAGS)
+
+ my_objects := args.@OBJEXT@ dust.@OBJEXT@ file.@OBJEXT@ mt.@OBJEXT@ rocks.@OBJEXT@ score.@OBJEXT@ sprite.@OBJEXT@ sound.@OBJEXT@ autopilot.@OBJEXT@
+
+--- configure.ac
++++ configure.ac
+@@ -12,6 +12,11 @@
+ AC_PROG_MAKE_SET
+
+ # Checks for libraries.
++dnl Check for libm for sqrt()
++AC_SEARCH_LIBS([sqrt], [m], [], [
++ AC_MSG_ERROR([unable to find the sqrt() function])
++])
++
+ AC_CHECK_LIB([SDL_image], [IMG_LoadPNG_RW])
+ AC_CHECK_LIB([SDL_mixer], [Mix_OpenAudio])
+
diff --git a/games-arcade/vor/vor-0.5.7.ebuild b/games-arcade/vor/vor-0.5.7.ebuild
new file mode 100644
index 000000000000..ba82dcf8862a
--- /dev/null
+++ b/games-arcade/vor/vor-0.5.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Variations on Rockdodger: Dodge the rocks until you die"
+HOMEPAGE="http://jasonwoof.org/vor"
+SRC_URI="https://jasonwoof.com/downloads/vor/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND=${DEPEND}
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ DOCS="README* todo" default
+ newicon -s 48 data/icon.png ${PN}.png
+ make_desktop_entry ${PN} VoR
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}