summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/xgalaga
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/xgalaga')
-rw-r--r--games-arcade/xgalaga/Manifest1
-rw-r--r--games-arcade/xgalaga/metadata.xml8
-rw-r--r--games-arcade/xgalaga/xgalaga-2.1.1.0.ebuild55
3 files changed, 64 insertions, 0 deletions
diff --git a/games-arcade/xgalaga/Manifest b/games-arcade/xgalaga/Manifest
new file mode 100644
index 000000000000..28620488c563
--- /dev/null
+++ b/games-arcade/xgalaga/Manifest
@@ -0,0 +1 @@
+DIST xgalaga-2.1.1.0.tar.gz 331621 SHA256 adcfbfd04876f5197c60b37af0ad89a629e553d6e09314a4b3b5c70f6c634f9b SHA512 087db9e0501cedb042bb673a217f9de32640d3e4f4f529a29fd25ed682a1aece9ae1beacdc2ee77fc93ac931411a1051e2cd19873578ccffe5f03a083bffe513 WHIRLPOOL 819208cf935a161c7852b97126912f37b664babdf0108e6ebf05b7bd24fac933fb95f2645ef4c330614aa20e1452d03ea368f0d3462db48b820768a91c29a1f0
diff --git a/games-arcade/xgalaga/metadata.xml b/games-arcade/xgalaga/metadata.xml
new file mode 100644
index 000000000000..a7e89402ccfe
--- /dev/null
+++ b/games-arcade/xgalaga/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">xgalaga</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/xgalaga/xgalaga-2.1.1.0.ebuild b/games-arcade/xgalaga/xgalaga-2.1.1.0.ebuild
new file mode 100644
index 000000000000..7f4d32aff295
--- /dev/null
+++ b/games-arcade/xgalaga/xgalaga-2.1.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A clone of the classic game Galaga for the X Window System"
+HOMEPAGE="http://sourceforge.net/projects/xgalaga"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ sed -i \
+ -e "/LEVELDIR\|SOUNDDIR/ s:prefix:datadir/${PN}:" \
+ -e "/\/scores/ s:prefix:localstatedir/${PN}:" \
+ configure \
+ || die "sed configure failed"
+ sed -i \
+ -e "/SOUNDDEFS/ s:(SOUNDSRVDIR):(SOUNDSRVDIR)/bin:" \
+ -e 's:make ;:$(MAKE) ;:' \
+ Makefile.in \
+ || die "sed Makefile.in failed"
+}
+
+src_install() {
+ dogamesbin xgalaga xgal.sndsrv.oss xgalaga-hyperspace
+ dodoc README README.SOUND CHANGES
+ newman xgalaga.6x xgalaga.6
+
+ insinto "${GAMES_DATADIR}/${PN}/sounds"
+ doins sounds/*.raw
+
+ insinto "${GAMES_DATADIR}/${PN}/levels"
+ doins levels/*.xgl
+
+ make_desktop_entry ${PN} XGalaga
+
+ dodir "${GAMES_STATEDIR}/${PN}"
+ touch "${D}${GAMES_STATEDIR}/${PN}/scores"
+ fperms 660 "${GAMES_STATEDIR}/${PN}/scores"
+ prepgamesdirs
+}