summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-04-04 10:10:35 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-04 10:38:57 +0300
commit5b23467f58e057f864b964b41fe311f401517588 (patch)
treef0d363422b8388770e887e41e9574ed03266dc5b /games-arcade
parentapp-misc/go-jira: fix LICENSE (diff)
downloadgentoo-5b23467f58e057f864b964b41fe311f401517588.tar.gz
gentoo-5b23467f58e057f864b964b41fe311f401517588.tar.bz2
gentoo-5b23467f58e057f864b964b41fe311f401517588.zip
games-arcade/oshu: Fix tests
Turn out it was failing because cmake.eclass calls ctest directly Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/oshu/oshu-2.0.1.ebuild8
-rw-r--r--games-arcade/oshu/oshu-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/games-arcade/oshu/oshu-2.0.1.ebuild b/games-arcade/oshu/oshu-2.0.1.ebuild
index 84d415b3c11a..f394d8081789 100644
--- a/games-arcade/oshu/oshu-2.0.1.ebuild
+++ b/games-arcade/oshu/oshu-2.0.1.ebuild
@@ -32,10 +32,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
-# Doesn't build executable needed for the test
-# https://github.com/fmang/oshu/issues/87
-RESTRICT="test"
-
src_prepare() {
if use osu-skin; then
eapply "${FILESDIR}/oshu-2.0.0-use_unpacked_osu-skin.patch"
@@ -53,3 +49,7 @@ src_configure() {
cmake_src_configure
}
+
+src_test() {
+ cmake_build check
+}
diff --git a/games-arcade/oshu/oshu-9999.ebuild b/games-arcade/oshu/oshu-9999.ebuild
index 84d415b3c11a..f394d8081789 100644
--- a/games-arcade/oshu/oshu-9999.ebuild
+++ b/games-arcade/oshu/oshu-9999.ebuild
@@ -32,10 +32,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
-# Doesn't build executable needed for the test
-# https://github.com/fmang/oshu/issues/87
-RESTRICT="test"
-
src_prepare() {
if use osu-skin; then
eapply "${FILESDIR}/oshu-2.0.0-use_unpacked_osu-skin.patch"
@@ -53,3 +49,7 @@ src_configure() {
cmake_src_configure
}
+
+src_test() {
+ cmake_build check
+}